summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-12-15 11:25:11 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-12-15 11:25:11 +0000
commitf1ec0be930e9e45774aceea3fce3805d520e3406 (patch)
treee1330a53096e79c37127f78c9ead6a1cf8beb603
parentStable for AMD64, wrt bug #394299 (diff)
downloadgentoo-2-f1ec0be930e9e45774aceea3fce3805d520e3406.tar.gz
gentoo-2-f1ec0be930e9e45774aceea3fce3805d520e3406.tar.bz2
gentoo-2-f1ec0be930e9e45774aceea3fce3805d520e3406.zip
disable all asm on x86 with pic, this should be much slower but, at least, pic
(Portage version: 2.2.0_alpha81/cvs/Linux x86_64)
-rw-r--r--media-video/ffmpeg/ChangeLog6
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild14
2 files changed, 11 insertions, 9 deletions
diff --git a/media-video/ffmpeg/ChangeLog b/media-video/ffmpeg/ChangeLog
index 680d5a105563..899ef800b388 100644
--- a/media-video/ffmpeg/ChangeLog
+++ b/media-video/ffmpeg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/ffmpeg
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.506 2011/12/15 11:21:08 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.507 2011/12/15 11:25:11 aballier Exp $
+
+ 15 Dec 2011; Alexis Ballier <aballier@gentoo.org> ffmpeg-9999.ebuild:
+ disable all asm on x86 with pic, this should be much slower but, at least,
+ pic
15 Dec 2011; Alexis Ballier <aballier@gentoo.org> ffmpeg-9999.ebuild:
remove x86 special handling, this should be handled automagically by the
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index b137ba07d3b7..07182db34393 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.70 2011/12/15 11:21:08 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.71 2011/12/15 11:25:11 aballier Exp $
EAPI="4"
@@ -180,15 +180,13 @@ src_configure() {
for i in ${CPU_FEATURES}; do
use ${i%:*} || myconf="${myconf} --disable-${i#*:}"
done
- # disable mmx accelerated code if PIC is required
- # as the provided asm decidedly is not PIC for x86.
- if use pic && use x86 ; then
- myconf="${myconf} --disable-mmx --disable-mmx2"
+ if use pic ; then
+ myconf="${myconf} --enable-pic"
+ # disable asm code if PIC is required
+ # as the provided asm decidedly is not PIC for x86.
+ use x86 && myconf="${myconf} --disable-asm"
fi
- # Option to force building pic
- use pic && myconf="${myconf} --enable-pic"
-
# Try to get cpu type based on CFLAGS.
# Bug #172723
# We need to do this so that features of that CPU will be better used