summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2005-01-02 03:56:46 +0000
committerChris PeBenito <pebenito@gentoo.org>2005-01-02 03:56:46 +0000
commitd5e63da9dd12dcba94f06db22cd1fe1b91bd8e1d (patch)
tree9084d9f15d761b01157dce0ea9698cf3f39a1a68 /app-admin/logrotate/logrotate-3.7.ebuild
parentAdd patch from upstream to support alpha/hppa. (Manifest recommit) (diff)
downloadgentoo-2-d5e63da9dd12dcba94f06db22cd1fe1b91bd8e1d.tar.gz
gentoo-2-d5e63da9dd12dcba94f06db22cd1fe1b91bd8e1d.tar.bz2
gentoo-2-d5e63da9dd12dcba94f06db22cd1fe1b91bd8e1d.zip
selinux code is now integrated
Diffstat (limited to 'app-admin/logrotate/logrotate-3.7.ebuild')
-rw-r--r--app-admin/logrotate/logrotate-3.7.ebuild12
1 files changed, 4 insertions, 8 deletions
diff --git a/app-admin/logrotate/logrotate-3.7.ebuild b/app-admin/logrotate/logrotate-3.7.ebuild
index 3f8689102ba9..05308d59de8d 100644
--- a/app-admin/logrotate/logrotate-3.7.ebuild
+++ b/app-admin/logrotate/logrotate-3.7.ebuild
@@ -1,10 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/logrotate/logrotate-3.7.ebuild,v 1.2 2005/01/01 11:08:57 eradicator Exp $
-
-inherit eutils
-
-SELINUX_PATCH="logrotate-3.6.5-selinux.diff.bz2"
+# $Header: /var/cvsroot/gentoo-x86/app-admin/logrotate/logrotate-3.7.ebuild,v 1.3 2005/01/02 03:56:46 pebenito Exp $
DESCRIPTION="Rotates, compresses, and mails system logs"
HOMEPAGE="http://packages.debian.org/unstable/admin/logrotate.html"
@@ -26,8 +22,6 @@ RDEPEND="${DEPEND}
src_unpack() {
unpack ${PN}_${PV}.orig.tar.gz
- use selinux && epatch ${FILESDIR}/${SELINUX_PATCH}
-
sed -i \
-e "s:CFLAGS += -g:CFLAGS += -g ${CFLAGS}:" \
-e "/CVSROOT =/d" \
@@ -39,7 +33,9 @@ src_unpack() {
}
src_compile() {
- emake || die "emake failed"
+ local myconf
+ useq selinux && myconf='WITH_SELINUX=yes'
+ emake ${myconf} || die "emake failed"
}
src_install() {