summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-12-26 20:31:52 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-12-26 20:31:52 +0000
commit5e63e3b3a050ee2e445dbca7f0f9c314cd0f7d54 (patch)
tree9d9680049e00af430f8421988a201f5182d57c67 /app-admin/puppet
parentBug #461982: Make it possible to build with custom-cflags, but not by default... (diff)
downloadgentoo-2-5e63e3b3a050ee2e445dbca7f0f9c314cd0f7d54.tar.gz
gentoo-2-5e63e3b3a050ee2e445dbca7f0f9c314cd0f7d54.tar.bz2
gentoo-2-5e63e3b3a050ee2e445dbca7f0f9c314cd0f7d54.zip
updating puppet for CVE-2013-4969 bug 494768
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'app-admin/puppet')
-rw-r--r--app-admin/puppet/ChangeLog9
-rw-r--r--app-admin/puppet/puppet-2.7.24.ebuild (renamed from app-admin/puppet/puppet-3.3.2.ebuild)74
-rw-r--r--app-admin/puppet/puppet-3.4.1.ebuild (renamed from app-admin/puppet/puppet-3.3.2-r1.ebuild)5
3 files changed, 62 insertions, 26 deletions
diff --git a/app-admin/puppet/ChangeLog b/app-admin/puppet/ChangeLog
index 086788c78709..0d93d574e697 100644
--- a/app-admin/puppet/ChangeLog
+++ b/app-admin/puppet/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/puppet
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/ChangeLog,v 1.181 2013/12/24 12:45:42 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/ChangeLog,v 1.182 2013/12/26 20:31:52 prometheanfire Exp $
+
+*puppet-2.7.24 (26 Dec 2013)
+*puppet-3.4.1 (26 Dec 2013)
+
+ 26 Dec 2013; Matthew Thode <prometheanfire@gentoo.org> +puppet-2.7.24.ebuild,
+ +puppet-3.4.1.ebuild, -puppet-3.3.2-r1.ebuild, -puppet-3.3.2.ebuild:
+ updating puppet for CVE-2013-4969 bug 494768
24 Dec 2013; Agostino Sarubbo <ago@gentoo.org> puppet-3.2.4.ebuild:
Stable for x86, wrt bug #486002
diff --git a/app-admin/puppet/puppet-3.3.2.ebuild b/app-admin/puppet/puppet-2.7.24.ebuild
index 45c096472984..7c7a5d84aaa7 100644
--- a/app-admin/puppet/puppet-3.3.2.ebuild
+++ b/app-admin/puppet/puppet-2.7.24.ebuild
@@ -1,12 +1,15 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-3.3.2.ebuild,v 1.2 2013/11/17 12:32:05 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-2.7.24.ebuild,v 1.1 2013/12/26 20:31:52 prometheanfire Exp $
EAPI="5"
+USE_RUBY="ruby19"
-USE_RUBY="ruby18 ruby19"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST="test"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG* README*"
-inherit elisp-common xemacs-elisp-common eutils user ruby-ng versionator
+inherit elisp-common xemacs-elisp-common eutils ruby-fakegem user
DESCRIPTION="A system automation and configuration management software"
HOMEPAGE="http://puppetlabs.com/"
@@ -14,12 +17,11 @@ SRC_URI="http://www.puppetlabs.com/downloads/puppet/${P}.tar.gz"
LICENSE="Apache-2.0 GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
IUSE="augeas diff doc emacs ldap minimal rrdtool selinux shadow sqlite3 vim-syntax xemacs"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
ruby_add_rdepend "
- dev-ruby/hiera
- >=dev-ruby/facter-1.6.2
+ >=dev-ruby/facter-1.5.6
augeas? ( dev-ruby/ruby-augeas )
diff? ( dev-ruby/diff-lcs )
doc? ( dev-ruby/rdoc )
@@ -27,29 +29,43 @@ ruby_add_rdepend "
shadow? ( dev-ruby/ruby-shadow )
sqlite3? ( dev-ruby/sqlite3 )
virtual/ruby-ssl"
+# couchdb? ( dev-ruby/couchrest )
+# mongrel? ( www-servers/mongrel )
+# rack? ( >=dev-ruby/rack-1 )
+# rails? (
+# dev-ruby/rails
+# >=dev-ruby/activerecord-2.1
+# )
+# stomp? ( dev-ruby/stomp )
DEPEND="${DEPEND}
ruby_targets_ruby19? ( dev-lang/ruby:1.9[yaml] )
emacs? ( virtual/emacs )
- xemacs? ( app-editors/xemacs )"
+ xemacs? ( app-editors/xemacs )
+ selinux? ( sec-policy/selinux-puppet )"
RDEPEND="${RDEPEND}
ruby_targets_ruby19? ( dev-lang/ruby:1.9[yaml] )
+ emacs? ( virtual/emacs )
+ xemacs? ( app-editors/xemacs )
rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
selinux? (
sys-libs/libselinux[ruby]
sec-policy/selinux-puppet
)
- vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
>=app-portage/eix-0.18.0"
SITEFILE="50${PN}-mode-gentoo.el"
+RUBY_PATCHES=( )
+
pkg_setup() {
enewgroup puppet
enewuser puppet -1 -1 /var/lib/puppet puppet
}
all_ruby_compile() {
+ all_fakegem_compile
+
if use emacs ; then
elisp-compile ext/emacs/puppet-mode.el
fi
@@ -63,27 +79,35 @@ all_ruby_compile() {
fi
}
-each_ruby_install() {
- ${RUBY} install.rb --destdir="${D}" install || die
+each_fakegem_install() {
+ ${RUBY} install.rb --destdir="${D}" install
}
all_ruby_install() {
+ all_fakegem_install
+
newinitd "${FILESDIR}"/puppet.init-r1 puppet
+ doconfd conf/gentoo/conf.d/puppet
# Initial configuration files
insinto /etc/puppet
+ # Bug #338439
+ #doins conf/gentoo/puppet/*
+ doins conf/redhat/puppet.conf
# Location of log and data files
- keepdir /var/log/puppet
- fowners -R puppet:puppet /var/log/puppet
+ keepdir /var/{run,log}/puppet
+ fowners -R puppet:puppet /var/{run,log}/puppet
if use minimal ; then
+ rm "${ED}/usr/bin/puppetmasterd"
rm "${ED}/etc/puppet/auth.conf"
else
- newinitd "${FILESDIR}"/puppetmaster.init-r1 puppetmaster
+ newinitd "${FILESDIR}"/puppetmaster.init puppetmaster
newconfd "${FILESDIR}"/puppetmaster.confd puppetmaster
insinto /etc/puppet
+ doins conf/redhat/fileserver.conf
keepdir /etc/puppet/manifests
keepdir /etc/puppet/modules
@@ -91,7 +115,7 @@ all_ruby_install() {
keepdir /var/lib/puppet/ssl
keepdir /var/lib/puppet/facts
keepdir /var/lib/puppet/files
- fowners -R puppet:puppet /var/lib/puppet
+ fowners -R puppet:puppet /var/{run,log,lib}/puppet
fi
if use emacs ; then
@@ -108,10 +132,16 @@ all_ruby_install() {
insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
fi
+ if use vim-syntax ; then
+ insinto /usr/share/vim/vimfiles/ftdetect; doins ext/vim/ftdetect/puppet.vim
+ insinto /usr/share/vim/vimfiles/syntax; doins ext/vim/syntax/puppet.vim
+ fi
+
# ext and examples files
for f in $(find ext examples -type f) ; do
docinto "$(dirname ${f})"; dodoc "${f}"
done
+ docinto conf; dodoc conf/namespaceauth.conf
}
pkg_postinst() {
@@ -119,8 +149,13 @@ pkg_postinst() {
elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
elog "cause puppet to hang while installing packages."
elog
- elog "Portage Puppet module with Gentoo-specific resources:"
- elog "http://forge.puppetlabs.com/gentoo/portage"
+ elog "Puppet uses eix to get information about currently installed packages,"
+ elog "so please keep the eix metadata cache updated so puppet is able to properly"
+ elog "handle package installations."
+ elog
+ elog "Currently puppet only supports adding and removing services to the default"
+ elog "runlevel, if you want to add/remove a service from another runlevel you may"
+ elog "do so using symlinking."
elog
if [ \
@@ -136,13 +171,6 @@ pkg_postinst() {
elog
fi
- if [ "$(get_major_version $REPLACING_VERSIONS)" = "2" ]; then
- elog
- elog "If you're upgrading from 2.x then we strongly suggest you to read:"
- elog "http://docs.puppetlabs.com/guides/upgrading.html"
- elog
- fi
-
use emacs && elisp-site-regen
use xemacs && xemacs-elisp-site-regen
}
diff --git a/app-admin/puppet/puppet-3.3.2-r1.ebuild b/app-admin/puppet/puppet-3.4.1.ebuild
index 19a237811a7b..8db71d1bfd75 100644
--- a/app-admin/puppet/puppet-3.3.2-r1.ebuild
+++ b/app-admin/puppet/puppet-3.4.1.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-3.3.2-r1.ebuild,v 1.1 2013/12/23 00:01:03 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-3.4.1.ebuild,v 1.1 2013/12/26 20:31:52 prometheanfire Exp $
EAPI="5"
+#supports ruby20, but needs deps first
USE_RUBY="ruby19"
inherit elisp-common xemacs-elisp-common eutils user ruby-ng versionator
@@ -70,7 +71,7 @@ each_ruby_install() {
all_ruby_install() {
#systemd stuffs
insinto /usr/lib/systemd/system
- doins "${WORKDIR}/all/${P}/ext/systemd/puppetagent.service"
+ doins "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
insinto /usr/lib/tmpfiles.d
newins "${FILESDIR}/tmpfiles.d" "puppet.conf"