summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-07-24 18:16:51 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-07-24 18:16:51 +0000
commit723bda80b89e4f1760b630c8029e840982990a90 (patch)
tree18a61281299cc68fc1f6b52681f828341477956e /app-admin/ulog-acctd/ulog-acctd-0.4.2.ebuild
parentadd macos keyword to 4.08 (diff)
downloadgentoo-2-723bda80b89e4f1760b630c8029e840982990a90.tar.gz
gentoo-2-723bda80b89e4f1760b630c8029e840982990a90.tar.bz2
gentoo-2-723bda80b89e4f1760b630c8029e840982990a90.zip
intial package release. ebuild based on Thomas Eckert ebuild and patch from bug #19204.
Diffstat (limited to 'app-admin/ulog-acctd/ulog-acctd-0.4.2.ebuild')
-rw-r--r--app-admin/ulog-acctd/ulog-acctd-0.4.2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/app-admin/ulog-acctd/ulog-acctd-0.4.2.ebuild b/app-admin/ulog-acctd/ulog-acctd-0.4.2.ebuild
new file mode 100644
index 000000000000..ac20a9c2ed35
--- /dev/null
+++ b/app-admin/ulog-acctd/ulog-acctd-0.4.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ulog-acctd/ulog-acctd-0.4.2.ebuild,v 1.1 2004/07/24 18:16:51 liquidx Exp $
+
+inherit eutils
+
+DESCRIPTION="ULOG-based accounting daemon with flexible log-format"
+SRC_URI="http://alioth.debian.org/download.php/604/${PN}_${PV}.orig.tar.gz"
+HOMEPAGE="http://savannah.nongnu.org/projects/ulog-acctd/ http://alioth.debian.org/projects/pkg-ulog-acctd"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="net-firewall/iptables"
+
+S=${WORKDIR}/${PN}-${PV}.orig
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/src
+ epatch ${FILESDIR}/${P}-gcc2.patch
+}
+
+src_compile() {
+ cd ${S}/src || die "cannot change to src-directory"
+ make || die "compile of pgm failed"
+ cd ${S}/doc || die "cannot change to doc-directory"
+ make || die "compile of docu failed"
+}
+
+src_install() {
+ dosbin src/ulog-acctd
+
+ insinto /etc/
+ doins src/ulog-acctd.conf
+
+ doman doc/ulog-acctd.8
+ doinfo doc/ulog-acctd.info
+
+ ## install contrib-dir in /usr/share/doc/${P}:
+ docinto contrib/pg_load
+ dodoc contrib/pg_load/*
+
+ docinto contrib/ulog-acctd2mrtg
+ dodoc contrib/ulog-acctd2mrtg/*
+
+ keepdir /var/log/ulog-acctd
+}
+
+pkg_postinst() {
+ einfo "ulog-acctd get's it's packages via ULOG-targets in your iptables-rules."
+}