summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-02-06 20:13:50 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-02-06 20:13:50 +0000
commit4c35452cc15482d0f0e988eb3d62c2b7eca69016 (patch)
treeda2a501408e2b42afed0fc04ce3619244e1302de /app-admin/webmin
parentVersion bump. Bug #448982 (diff)
downloadgentoo-2-4c35452cc15482d0f0e988eb3d62c2b7eca69016.tar.gz
gentoo-2-4c35452cc15482d0f0e988eb3d62c2b7eca69016.tar.bz2
gentoo-2-4c35452cc15482d0f0e988eb3d62c2b7eca69016.zip
Version bump. Drop old ebuilds. Bug #455898. Thanks to PhobosK <phobosk@fastmail.fm>
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key B4AFF2C2)
Diffstat (limited to 'app-admin/webmin')
-rw-r--r--app-admin/webmin/ChangeLog12
-rwxr-xr-xapp-admin/webmin/files/gentoo-setup13
-rw-r--r--app-admin/webmin/files/webmin-1.600-SA51201.patch105
-rw-r--r--app-admin/webmin/webmin-1.610.ebuild265
-rw-r--r--app-admin/webmin/webmin-1.620.ebuild (renamed from app-admin/webmin/webmin-1.600-r1.ebuild)13
5 files changed, 29 insertions, 379 deletions
diff --git a/app-admin/webmin/ChangeLog b/app-admin/webmin/ChangeLog
index 17dc4707d833..b5c4df439d0b 100644
--- a/app-admin/webmin/ChangeLog
+++ b/app-admin/webmin/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-admin/webmin
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/ChangeLog,v 1.202 2012/12/05 18:57:25 hwoarang Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/ChangeLog,v 1.203 2013/02/06 20:13:50 hwoarang Exp $
+
+*webmin-1.620 (06 Feb 2013)
+
+ 06 Feb 2013; Markos Chandras <hwoarang@gentoo.org> +webmin-1.620.ebuild,
+ -files/webmin-1.600-SA51201.patch, -webmin-1.600-r1.ebuild,
+ -webmin-1.610.ebuild, files/gentoo-setup:
+ Version bump. Drop old ebuilds. Bug #455898. Thanks to PhobosK
+ <phobosk@fastmail.fm>
*webmin-1.610 (05 Dec 2012)
diff --git a/app-admin/webmin/files/gentoo-setup b/app-admin/webmin/files/gentoo-setup
index 566e564ed387..ef03a9a59059 100755
--- a/app-admin/webmin/files/gentoo-setup
+++ b/app-admin/webmin/files/gentoo-setup
@@ -1,5 +1,8 @@
#!/bin/sh
# gentoo-setup.sh
+#
+# Version 1.1
+#
# A modified original Webmin setup.sh script to comply with Gentoo specifics
#
# Modification done by: PhobosK <phobosk@kbfx.net>
@@ -91,10 +94,11 @@ if [ "$upgrading" = 1 ]; then
real_os_type=`grep "^real_os_type=" $config_dir/config | sed -e 's/real_os_type=//g'`
real_os_version=`grep "^real_os_version=" $config_dir/config | sed -e 's/real_os_version=//g'`
- # Get port, ssl, ssl_redirect and keyfile
+ # Get port, ssl, ssl_redirect, no_sslcompression and keyfile
port=`grep "^port=" $config_dir/miniserv.conf | sed -e 's/port=//g'`
ssl=`grep "^ssl=" $config_dir/miniserv.conf | sed -e 's/ssl=//g'`
ssl_redirect=`grep "^ssl_redirect=" $config_dir/miniserv.conf | sed -e 's/ssl_redirect=//g'`
+ no_sslcompression=`grep "^no_sslcompression=" $config_dir/miniserv.conf | sed -e 's/no_sslcompression=//g'`
keyfile=`grep "^keyfile=" $config_dir/miniserv.conf | sed -e 's/keyfile=//g'`
# Update ACLs
@@ -136,6 +140,7 @@ else
echo "ppath=$ppath" >> $cfile
echo "ssl=$ssl" >> $cfile
echo "ssl_redirect=$ssl_redirect" >> $cfile
+ echo "no_sslcompression=$no_sslcompression" >> $cfile
echo "keyfile=$keyfile" >> $cfile
echo "env_WEBMIN_CONFIG=$config_dir" >> $cfile
echo "env_WEBMIN_VAR=$var_dir" >> $cfile
@@ -277,6 +282,12 @@ if [ "$?" != "0" ]; then
echo passwd_mode=0 >> $config_dir/miniserv.conf
fi
+# Disable SSL compression to defeat BEAST attack
+grep no_sslcompression= $config_dir/miniserv.conf >/dev/null
+if [ "$?" != "0" ]; then
+ echo no_sslcompression=1 >> $config_dir/miniserv.conf
+fi
+
# Make Perl crypt MD5 the default
echo md5pass=1 >> $config_dir/config
diff --git a/app-admin/webmin/files/webmin-1.600-SA51201.patch b/app-admin/webmin/files/webmin-1.600-SA51201.patch
deleted file mode 100644
index 43d1783f9d84..000000000000
--- a/app-admin/webmin/files/webmin-1.600-SA51201.patch
+++ /dev/null
@@ -1,105 +0,0 @@
-diff -ur a/passwd/edit_passwd.cgi b/passwd/edit_passwd.cgi
---- a/passwd/edit_passwd.cgi 2012-09-21 21:07:11.000000000 +0300
-+++ b/passwd/edit_passwd.cgi 2012-11-01 19:00:02.000000000 +0200
-@@ -19,7 +19,7 @@
- %uconfig = &foreign_config("useradmin");
- $user[6] =~ s/,.*$// if ($uconfig{'extra_real'});
- print &ui_table_row($text{'passwd_for'},
-- $user[0].( $user[6] ? " ($user[6])" : "" ));
-+ &html_escape($user[0].( $user[6] ? " ($user[6])" : "" )));
-
- # Old password field
- if ($access{'old'} == 1 ||
-diff -ur a/passwd/index.cgi b/passwd/index.cgi
---- a/passwd/index.cgi 2012-09-21 21:07:11.000000000 +0300
-+++ b/passwd/index.cgi 2012-11-01 19:00:02.000000000 +0200
-@@ -85,7 +85,7 @@
- @grid = ( );
- for($i=0; $i<@ulist; $i++) {
- push(@grid, "<a href=\"edit_passwd.cgi?".
-- "user=$ulist[$i]->[0]\">".
-+ "user=".&urlize($ulist[$i]->[0])."\">".
- &html_escape($ulist[$i]->[0])."</a>");
- }
- print &ui_grid_table(\@grid, 4, 100, undef, undef,
-diff -ur a/passwd/module.info b/passwd/module.info
---- a/passwd/module.info 2012-09-21 21:11:10.000000000 +0300
-+++ b/passwd/module.info 2012-11-01 19:00:02.000000000 +0200
-@@ -1,48 +1,38 @@
--desc_pt_BR=Alterar Senha
--desc_ca=Canvi de Contrasenyes
--desc_it=Cambio Password
--desc_hu.UTF-8=Jelszavak
--readonly=1
--desc=Change Passwords
- category=system
--desc_ja_JP.euc=パスワードの変更
--desc_zh_TW.Big5=怒鷄KX
--desc_ko_KR.UTF-8= 覲蟆
--desc_fi=Vaihda Salasanoja
-+depends=useradmin
-+desc=Change Passwords
-+desc_pl=Zmiany hase
-+desc_hu=Jelszavak
- name=Passwd
--desc_tr=Parolalar Deitir
--os_support=!windows
-+desc_ca=Canvi de Contrasenyes
- desc_de=Passw&#246;rter &#228;ndern
--desc_af=Verander Wagwoord
--desc_sk=Zmena hesla
--desc_pl.UTF-8=Zmiany hase
--desc_cz.UTF-8=Zmna hesla
--desc_ja_JP.UTF-8=鴻若紊
--desc_fr=Changez le Mot de Passe
--desc_pl=Zmiany hase
-+desc_nl=Wachtwoorden Wijzigen
-+desc_zh_TW.Big5=怒鷄KX
- desc_es=Cambio de Contrase&#241;as
--desc_ru_RU=瑁鉉
- desc_no=Passord administrasjon
--desc_cz=Zmna hesla
--desc_ms=Menukar Katalaluan
--desc_nl=Wachtwoorden Wijzigen
--desc_sk.UTF-8=Zmena hesla
--desc_hu=Jelszavak
--desc_zh_TW.UTF-8=莅翫腆
--version=1.600
--longdesc=Change the password of any user on the system.
-+desc_af=Verander Wagwoord
-+desc_it=Cambio Password
- desc_ru_SU=霑厦棉
-+desc_ru_RU=瑁鉉
- passwd=Change the passwords of Unix users.
-+longdesc=Change the password of any user on the system.
-+desc_pt_BR=Alterar Senha
-+desc_ms=Menukar Katalaluan
-+desc_cz=Zmna hesla
-+desc_sk=Zmena hesla
-+desc_tr=Parolalar Deitir
-+readonly=1
-+os_support=!windows
-+desc_zh_TW.UTF-8=莅翫腆
-+desc_fi=Vaihda Salasanoja
- desc_ko_KR.euc=章硲 痕井
-+desc_ko_KR.UTF-8= 覲蟆
-+desc_ja_JP.euc=パスワードの変更
-+desc_ja_JP.UTF-8=鴻若紊
- desc_ru.UTF-8=舒仂仍亳
--depends=useradmin 1.600
--desc_de.UTF-8=Passw&#246;rter &#228;ndern
--desc_fi.UTF-8=Vaihda Salasanoja
--desc_af.UTF-8=Verander Wagwoord
--desc_fr.UTF-8=Changez le Mot de Passe
--desc_ms.UTF-8=Menukar Katalaluan
--desc_it.UTF-8=Cambio Password
--desc_es.UTF-8=Cambio de Contrase&#241;as
--desc_ca.UTF-8=Canvi de Contrasenyes
--desc_pt_BR.UTF-8=Alterar Senha
--desc_nl.UTF-8=Wachtwoorden Wijzigen
-+desc_fr=Changez le Mot de Passe
-+desc_hu.UTF-8=Jelszavak
-+desc_cz.UTF-8=Zmna hesla
-+desc_pl.UTF-8=Zmiany hase
-+desc_sk.UTF-8=Zmena hesla
-+version=1.605
diff --git a/app-admin/webmin/webmin-1.610.ebuild b/app-admin/webmin/webmin-1.610.ebuild
deleted file mode 100644
index 04154b8f469f..000000000000
--- a/app-admin/webmin/webmin-1.610.ebuild
+++ /dev/null
@@ -1,265 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/webmin-1.610.ebuild,v 1.1 2012/12/05 18:57:25 hwoarang Exp $
-
-EAPI="3"
-
-inherit eutils pam ssl-cert
-
-DESCRIPTION="A web-based Unix systems administration interface"
-HOMEPAGE="http://www.webmin.com/"
-SRC_URI="minimal? ( mirror://sourceforge/webadmin/${P}-minimal.tar.gz )
- !minimal? ( mirror://sourceforge/webadmin/${P}.tar.gz )"
-
-LICENSE="BSD GPL-2"
-SLOT="0"
-
-KEYWORDS="~amd64 ~x86"
-
-# NOTE: The ssl flag auto added by ssl-cert eclass is not used actually
-# because openssl is forced by dev-perl/Net-SSLeay
-IUSE="minimal +ssl mysql postgres ldap"
-
-# All the required perl modules can be found easily using (in Webmin's root src dir):
-# find . -name cpan_modules.pl -exec grep "::" {} \;
-# NOTE: If Webmin doesn't find the required perl modules, it offers(runtime) the user
-# to install them using the in-built cpan module, and this will mess up perl on the system
-# That's why some modules are forced without a use flag
-# NOTE: pam, ssl and dnssec-tools deps are forced for security and Gentoo compliance installation reasons
-DEPEND="virtual/perl-Sys-Syslog
- virtual/perl-Time-HiRes
- virtual/perl-Time-Local
- dev-perl/Authen-Libwrap
- dev-perl/IO-Tty
- dev-perl/MD5
- dev-perl/Net-SSLeay
- dev-perl/Authen-PAM
- dev-perl/Sys-Hostname-Long
- >=net-dns/dnssec-tools-1.13
- !minimal? (
- mysql? ( dev-perl/DBD-mysql )
- postgres? ( dev-perl/DBD-Pg )
- ldap? ( dev-perl/perl-ldap )
- dev-perl/XML-Generator
- dev-perl/XML-Parser
- )"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- local perl="$( which perl )"
-
- # Remove the unnecessary and incompatible files
- rm -rf acl/Authen-SolarisRBAC-0.1*
- if ! use minimal ; then
- rm -rf {format,{bsd,hpux,sgi}exports,zones,rbac}
- rm -f mount/{free,net,open}bsd-mounts*
- rm -f mount/macos-mounts*
- fi
-
- # For security reasons remove the SSL certificate that comes with Webmin
- # We will create our own later
- rm -f miniserv.pem
-
- # Remove the Webmin setup scripts to avoid Webmin in runtime to mess up config
- # We will use our own later
- rm -f setup.{sh,pl}
-
- # Fix the permissions of the install files
- chmod -R og-w "${S}"
-
- # Since we should not modify any files after install
- # we set the perl path in all cgi and pl files here using Webmin's routines
- # The pl file is Prefix safe and works only on provided input, no other filesystem files
- ebegin "Fixing perl path in source files"
- (find "${S}" -name '*.cgi' -print ; find "${S}" -name '*.pl' -print) | $perl "${S}"/perlpath.pl $perl -
- eend $?
-}
-
-src_install() {
- # Create config dir and keep
- diropts -m0755
- dodir /etc/webmin
- keepdir /etc/webmin
-
- # Create install dir
- # Third party modules installed through Webmin go here too, so keep
- dodir /usr/libexec/webmin
- keepdir /usr/libexec/webmin
-
- # Copy our own setup script to installation folder
- insinto /usr/libexec/webmin
- newins "${FILESDIR}"/gentoo-setup gentoo-setup.sh
- fperms 0744 /usr/libexec/webmin/gentoo-setup.sh
-
- # This is here if we ever want in future ebuilds to add some specific
- # config values in the /etc/webmin/miniserv.conf
- # The format of this file should be the same as the one of miniserv.conf:
- # var=value
- #
- # Uncomment it if you use such file. Before that check if upstream
- # has this file in root dir too.
- #newins "${FILESDIR}/miniserv-conf" miniserv-conf
-
- # Create the log dir and keep
- diropts -m0700
- dodir /var/log/webmin
- keepdir /var/log/webmin
-
- # Create the init.d file and put the neccessary variables there
- newinitd "${FILESDIR}"/init.d.webmin webmin
- sed -i \
- -e "s:%exe%:${EROOT}usr/libexec/webmin/miniserv.pl:" \
- -e "s:%pid%:${EROOT}var/run/webmin.pid:" \
- -e "s:%conf%:${EROOT}etc/webmin/miniserv.conf:" \
- -e "s:%perllib%:${EROOT}usr/libexec/webmin:" \
- "${ED}etc/init.d/webmin" \
- || die "Failed to patch the webmin init file"
-
- # Setup pam
- pamd_mimic system-auth webmin auth account session
-
- # Copy files to installation folder
- ebegin "Copying install files to destination"
- cp -pPR "${S}"/* "${ED}usr/libexec/webmin"
- eend $?
-}
-
-pkg_preinst() {
- # First stop service if running so Webmin to not messup our config
- ebegin "Stopping any running Webmin instance prior merging"
- rc-service --ifexists -- webmin --ifstarted stop
- eend $?
-}
-
-pkg_postinst() {
- # Run pkg_config phase first - non interactively
- export INTERACTIVE="no"
- pkg_config
- # Every next time pkg_config should be interactive
- INTERACTIVE="yes"
-
- ewarn
- ewarn "Bare in mind that not all Webmin modules are Gentoo tweaked and may have some issues."
- ewarn "Always be careful when using modules that modify init entries, do update of webmin, install CPAN modules etc."
- ewarn "To avoid problems, please before using any module, look at its configuration options first."
- ewarn "(Usually there is a link at top in the right pane of Webmin for configuring the module.)"
- ewarn
- elog "- To make Webmin start at boot time, run: 'rc-update add webmin default'"
- elog "- The default URL to connect to Webmin is: https://localhost:10000"
- elog "- The default user that can login is: root"
- elog "- To reconfigure Webmin in case of problems run 'emerge --config app-admin/webmin'"
-}
-
-pkg_prerm() {
- # First stop service if running - we do not want Webmin to mess up config
- ebegin "Stopping any running Webmin instance prior unmerging"
- rc-service --ifexists -- webmin --ifstarted stop
- eend $?
-}
-
-pkg_postrm() {
- ewarn
- ewarn "You have uninstalled Webmin, so have in mind that all cron jobs scheduled"
- ewarn "by Webmin for its own modules, are left active and they will fail when Webmin is missing."
- ewarn "To fix this just disable them if you intend to use Webmin again,"
- ewarn "OR delete them if not."
- ewarn
-}
-
-pkg_config(){
- # First stop service if running
- ebegin "Stopping any running Webmin instance"
- rc-service --ifexists -- webmin --ifstarted stop
- eend $?
-
- # Next set the default reset variable to 'none'
- # reset/_reset can be:
- # 'none' - does not reset anything, just upgrades if a conf is present
- # OR installs new conf if a conf is missing
- # 'soft' - deletes only $config_dir/config file and thus resetting most
- # conf values to their defaults. Keeps the specific Webmin cron jobs
- # 'hard' - deletes all files in $config_dir (keeping the .keep_* Gentoo file)
- # and thus resetting all Webmin. Deletes the specific Webmin cron jobs too.
- local _reset="none"
-
- # If in interactive mode ask user what should we do
- if [[ "${INTERACTIVE}" = "yes" ]]; then
- einfo
- einfo "Please enter the number of the action you would like to perform?"
- einfo
- einfo "1. Update configuration"
- einfo " (keeps old config options and adds the new ones)"
- einfo "2. Soft reset configuration"
- einfo " (keeps some old config options, the other options are set to default)"
- ewarn " All Webmin users will be reset"
- einfo "3. Hard reset configuration"
- einfo " (all options including module options are set to default)"
- ewarn " You will lose all Webmin configuration options you have done till now"
- einfo "4. Exit this configuration utility (default)"
- while [ "$correct" != "true" ] ; do
- read answer
- if [[ "$answer" = "1" ]] ; then
- _reset="none"
- correct="true"
- elif [[ "$answer" = "2" ]] ; then
- _reset="soft"
- correct="true"
- elif [[ "$answer" = "3" ]] ; then
- _reset="hard"
- correct="true"
- elif [ "$answer" = "4" -o "$answer" = "" ] ; then
- die "User aborted configuration."
- else
- echo "Answer not recognized. Enter a number from 1 to 4"
- fi
- done
-
- if [[ "$_reset" = "hard" ]]; then
- while [ "$sure" != "true" ] ; do
- ewarn "You will lose all Webmin configuration options you have done till now."
- ewarn "Are you sure you want to do this? (y/n)"
- read answer
- if [[ $answer =~ ^[Yy]([Ee][Ss])?$ ]] ; then
- sure="true"
- elif [[ $answer =~ ^[Nn]([Oo])?$ ]] ; then
- die "User aborted configuration."
- else
- echo "Answer not recognized. Enter 'y' or 'n'"
- fi
- done
- fi
- fi
-
- export reset=$_reset
-
- # Create ssl certificate for Webmin if there is not one in the proper place
- if [[ ! -e "${EROOT}etc/ssl/webmin/server.pem" ]]; then
- SSL_ORGANIZATION="${SSL_ORGANIZATION:-Webmin Server}"
- SSL_COMMONNAME="${SSL_COMMONNAME:-*}"
- install_cert "${EROOT}/etc/ssl/webmin/server"
- fi
-
- # Ensure all paths passed to the setup script use EROOT
- export wadir="${EROOT}usr/libexec/webmin"
- export config_dir="${EROOT}etc/webmin"
- export var_dir="${EROOT}var/log/webmin"
- export tempdir="${T}"
- export pidfile="${EROOT}var/run/webmin.pid"
- export perl="$( which perl )"
- export os_type='gentoo-linux'
- export os_version='*'
- export real_os_type='Gentoo Linux'
- export real_os_version='Any version'
- # Forcing 'ssl' and 'ssl_redirect' for tightening security
- export ssl=1
- export ssl_redirect=1
- export keyfile="${EROOT}etc/ssl/webmin/server.pem"
- export port=10000
-
- export atboot=0
-
- einfo "Executing Webmin's configure script"
- $wadir/gentoo-setup.sh
-
- einfo "Configuration of Webmin done"
-}
diff --git a/app-admin/webmin/webmin-1.600-r1.ebuild b/app-admin/webmin/webmin-1.620.ebuild
index 939ce83a12a4..5055a52a7d54 100644
--- a/app-admin/webmin/webmin-1.600-r1.ebuild
+++ b/app-admin/webmin/webmin-1.620.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/webmin-1.600-r1.ebuild,v 1.2 2012/11/07 18:51:57 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/webmin-1.620.ebuild,v 1.1 2013/02/06 20:13:50 hwoarang Exp $
EAPI="3"
@@ -54,9 +54,6 @@ src_prepare() {
rm -rf {format,{bsd,hpux,sgi}exports,zones,rbac}
rm -f mount/{free,net,open}bsd-mounts*
rm -f mount/macos-mounts*
-
- # Fix security bug - https://bugs.gentoo.org/show_bug.cgi?id=441840
- epatch "${FILESDIR}/${P}-SA51201.patch"
fi
# For security reasons remove the SSL certificate that comes with Webmin
@@ -67,6 +64,9 @@ src_prepare() {
# We will use our own later
rm -f setup.{sh,pl}
+ # Set the installation type/mode to Gentoo
+ echo "gentoo" > install-type
+
# Fix the permissions of the install files
chmod -R og-w "${S}"
@@ -253,9 +253,10 @@ pkg_config(){
export os_version='*'
export real_os_type='Gentoo Linux'
export real_os_version='Any version'
- # Forcing 'ssl' and 'ssl_redirect' for tightening security
+ # Forcing 'ssl', 'ssl_redirect' and 'no_sslcompression' for tightening security
export ssl=1
export ssl_redirect=1
+ export no_sslcompression=1
export keyfile="${EROOT}etc/ssl/webmin/server.pem"
export port=10000