summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-06-02 05:57:07 +0000
committerJeroen Roovers <jer@gentoo.org>2009-06-02 05:57:07 +0000
commitd9387c5b6b7d60c6480bfb2a9c3adf5d00b6d3c7 (patch)
treed6f36e015f8c5a20af5ac0a0127c45e349415a14 /app-admin
parentx11-drivers/xf86-input-synaptics: changing herd metadata from x11-drivers to x11 (diff)
downloadgentoo-2-d9387c5b6b7d60c6480bfb2a9c3adf5d00b6d3c7.tar.gz
gentoo-2-d9387c5b6b7d60c6480bfb2a9c3adf5d00b6d3c7.tar.bz2
gentoo-2-d9387c5b6b7d60c6480bfb2a9c3adf5d00b6d3c7.zip
Version bump to patch the old parallel make bug yet again (bug #212398).
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/sysstat/ChangeLog8
-rw-r--r--app-admin/sysstat/files/sysstat-9.0.3-ar.patch17
-rw-r--r--app-admin/sysstat/sysstat-9.0.3-r1.ebuild45
3 files changed, 69 insertions, 1 deletions
diff --git a/app-admin/sysstat/ChangeLog b/app-admin/sysstat/ChangeLog
index 1dc50c20d299..778c067c30c0 100644
--- a/app-admin/sysstat/ChangeLog
+++ b/app-admin/sysstat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/sysstat
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/sysstat/ChangeLog,v 1.137 2009/05/25 03:35:39 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sysstat/ChangeLog,v 1.138 2009/06/02 05:57:07 jer Exp $
+
+*sysstat-9.0.3-r1 (02 Jun 2009)
+
+ 02 Jun 2009; Jeroen Roovers <jer@gentoo.org> +sysstat-9.0.3-r1.ebuild,
+ +files/sysstat-9.0.3-ar.patch:
+ Version bump to patch the old parallel make bug yet again (bug #212398).
*sysstat-9.0.3 (25 May 2009)
diff --git a/app-admin/sysstat/files/sysstat-9.0.3-ar.patch b/app-admin/sysstat/files/sysstat-9.0.3-ar.patch
new file mode 100644
index 000000000000..fc6fb54ebe00
--- /dev/null
+++ b/app-admin/sysstat/files/sysstat-9.0.3-ar.patch
@@ -0,0 +1,17 @@
+Get rid of the implicit rule entirely (bug #212398).
+
+
+--- sysstat-9.0.3/Makefile.in.orig 2009-04-13 16:27:15.000000000 +0200
++++ sysstat-9.0.3/Makefile.in 2009-05-31 18:48:48.000000000 +0200
+@@ -175,9 +175,8 @@
+
+ # Explicit rules needed to prevent possible file corruption
+ # when using parallel execution.
+-libsyscom.a: libsyscom.a(common.o ioconf.o)
+- $(AR) rv $@ common.o
+- $(AR) rv $@ ioconf.o
++libsyscom.a: common.o ioconf.o
++ $(AR) rv $@ $?
+ $(AR) s $@
+
+ librdstats.a: librdstats.a(rd_stats.o)
diff --git a/app-admin/sysstat/sysstat-9.0.3-r1.ebuild b/app-admin/sysstat/sysstat-9.0.3-r1.ebuild
new file mode 100644
index 000000000000..9adfaa7c373a
--- /dev/null
+++ b/app-admin/sysstat/sysstat-9.0.3-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sysstat/sysstat-9.0.3-r1.ebuild,v 1.1 2009/06/02 05:57:07 jer Exp $
+
+EAPI="2"
+
+inherit eutils multilib
+
+DESCRIPTION="System performance tools for Linux"
+HOMEPAGE="http://perso.wanadoo.fr/sebastien.godard/"
+SRC_URI="http://perso.orange.fr/sebastien.godard/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-ar.patch"
+}
+
+src_configure() {
+ sa_lib_dir=/usr/$(get_libdir)/sa \
+ econf $(use_enable nls) conf_dir=/etc || die "econf failed"
+}
+
+src_compile() {
+ emake LFLAGS="${LDFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ keepdir /var/log/sa
+
+ emake DESTDIR="${D}" DOC_DIR=/usr/share/doc/${PF} \
+ install || die "make install failed"
+
+ newdoc sysstat.crond.sample crontab.example
+ newinitd "${FILESDIR}"/sysstat.init.d sysstat
+
+ ewarn "The sysstat configuration files have moved from /etc/sysconfig to /etc"
+}