summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2008-06-28 08:54:08 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2008-06-28 08:54:08 +0000
commit8a5a84942dfb9956601050997862381604b090b6 (patch)
tree763f40e7ecb7cae8fca54e904dc72b6589c5f367 /app-arch/pbzip2
parentAdd missing conditional for USE=-xft in XmRenderT.c, bug 229779. (diff)
downloadgentoo-2-8a5a84942dfb9956601050997862381604b090b6.tar.gz
gentoo-2-8a5a84942dfb9956601050997862381604b090b6.tar.bz2
gentoo-2-8a5a84942dfb9956601050997862381604b090b6.zip
Revision bump to add a pbunzip2 link. Thanks to Santiago M. Mola <coldwind@gentoo.org> for pointing it out. Closing bug #220271.
(Portage version: 2.1.5.5)
Diffstat (limited to 'app-arch/pbzip2')
-rw-r--r--app-arch/pbzip2/ChangeLog11
-rw-r--r--app-arch/pbzip2/pbzip2-1.0.1.ebuild6
-rw-r--r--app-arch/pbzip2/pbzip2-1.0.2-r1.ebuild37
3 files changed, 49 insertions, 5 deletions
diff --git a/app-arch/pbzip2/ChangeLog b/app-arch/pbzip2/ChangeLog
index b50ba3eb135b..de18752e6f82 100644
--- a/app-arch/pbzip2/ChangeLog
+++ b/app-arch/pbzip2/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-arch/pbzip2
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/pbzip2/ChangeLog,v 1.42 2007/11/27 14:28:12 armin76 Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pbzip2/ChangeLog,v 1.43 2008/06/28 08:54:08 wolf31o2 Exp $
+
+*pbzip2-1.0.2-r1 (28 Jun 2008)
+
+ 28 Jun 2008; Chris Gianelloni <wolf31o2@gentoo.org> pbzip2-1.0.1.ebuild,
+ +pbzip2-1.0.2-r1.ebuild:
+ Revision bump to add a pbunzip2 link. Thanks to Santiago M. Mola
+ <coldwind@gentoo.org> for pointing it out. Closing bug #220271.
27 Nov 2007; Raúl Porcel <armin76@gentoo.org> pbzip2-1.0.2.ebuild:
alpha/ia64/sparc stable wrt #198599
diff --git a/app-arch/pbzip2/pbzip2-1.0.1.ebuild b/app-arch/pbzip2/pbzip2-1.0.1.ebuild
index 39f36a8c1d11..5c430d0f9764 100644
--- a/app-arch/pbzip2/pbzip2-1.0.1.ebuild
+++ b/app-arch/pbzip2/pbzip2-1.0.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/pbzip2/pbzip2-1.0.1.ebuild,v 1.3 2007/11/24 16:03:23 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pbzip2/pbzip2-1.0.1.ebuild,v 1.4 2008/06/28 08:54:08 wolf31o2 Exp $
inherit multilib
@@ -22,7 +22,7 @@ src_unpack() {
src_compile() {
if use static ; then
- cp -f /usr/$(get_libdir)/libbz2.a ${S}
+ cp -f /usr/$(get_libdir)/libbz2.a "${S}"
emake pbzip2-static || die "Failed to build"
else
emake pbzip2 || die "Failed to build"
diff --git a/app-arch/pbzip2/pbzip2-1.0.2-r1.ebuild b/app-arch/pbzip2/pbzip2-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..95ef7c600f2a
--- /dev/null
+++ b/app-arch/pbzip2/pbzip2-1.0.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pbzip2/pbzip2-1.0.2-r1.ebuild,v 1.1 2008/06/28 08:54:08 wolf31o2 Exp $
+
+inherit multilib
+
+DESCRIPTION="A parallel version of BZIP2"
+HOMEPAGE="http://compression.ca/pbzip2/"
+SRC_URI="http://compression.ca/${PN}/${P}.tar.gz"
+
+LICENSE="PBZIP2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static"
+
+DEPEND="app-arch/bzip2"
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e 's:-O3:${CFLAGS}:g' ${P}/Makefile || die
+}
+
+src_compile() {
+ if use static ; then
+ cp -f /usr/$(get_libdir)/libbz2.a "${S}"
+ emake pbzip2-static || die "Failed to build"
+ else
+ emake pbzip2 || die "Failed to build"
+ fi
+}
+
+src_install() {
+ dobin pbzip2 || die "Failed to install"
+ dodoc AUTHORS ChangeLog README
+ doman pbzip2.1 || die "Failed to install man page"
+ dosym /usr/bin/pbzip2 /usr/bin/pbunzip2
+}