summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-08-17 18:20:14 +0000
committerMike Frysinger <vapier@gentoo.org>2011-08-17 18:20:14 +0000
commitca30250a9a1c6715f92a165216f8cc452966a752 (patch)
treea208b8b50e5c7a3d713ff8e57fadaa3d728b8c03 /app-arch
parentFixed manifest after a script that got a bit too eager (diff)
downloadgentoo-2-ca30250a9a1c6715f92a165216f8cc452966a752.tar.gz
gentoo-2-ca30250a9a1c6715f92a165216f8cc452966a752.tar.bz2
gentoo-2-ca30250a9a1c6715f92a165216f8cc452966a752.zip
Add live git version and fix up various bugs.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/pxz/ChangeLog8
-rw-r--r--app-arch/pxz/pxz-9999.ebuild44
2 files changed, 50 insertions, 2 deletions
diff --git a/app-arch/pxz/ChangeLog b/app-arch/pxz/ChangeLog
index ef671ced6e50..94a68036f87e 100644
--- a/app-arch/pxz/ChangeLog
+++ b/app-arch/pxz/ChangeLog
@@ -1,10 +1,14 @@
# ChangeLog for app-arch/pxz
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/pxz/ChangeLog,v 1.1 2011/08/11 20:59:44 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pxz/ChangeLog,v 1.2 2011/08/17 18:20:14 vapier Exp $
+
+*pxz-9999 (17 Aug 2011)
+
+ 17 Aug 2011; Mike Frysinger <vapier@gentoo.org> +pxz-9999.ebuild:
+ Add live git version and fix up various bugs.
*pxz-5.0_pre20110811 (11 Aug 2011)
11 Aug 2011; Patrick McLean <chutzpah@gentoo.org>
+pxz-5.0_pre20110811.ebuild, +metadata.xml:
Initial ebuild.
-
diff --git a/app-arch/pxz/pxz-9999.ebuild b/app-arch/pxz/pxz-9999.ebuild
new file mode 100644
index 000000000000..bf4d3713e8d8
--- /dev/null
+++ b/app-arch/pxz/pxz-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pxz/pxz-9999.ebuild,v 1.1 2011/08/17 18:20:14 vapier Exp $
+
+EAPI="3"
+
+inherit toolchain-funcs flag-o-matic
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/jnovy/pxz.git"
+ inherit git-2
+else
+ MY_PV=${PV/_}
+ case ${MY_PV} in
+ *beta?*) MY_PV="${MY_PV/beta/beta.}git" ;;
+ esac
+ MY_P="${PN}-${MY_PV}"
+ SRC_URI="http://jnovy.fedorapeople.org/pxz/${MY_P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+ S=${WORKDIR}/${MY_P/beta*/beta}
+fi
+
+DESCRIPTION="parallel LZMA compressor (no parallel decompression!)"
+HOMEPAGE="http://jnovy.fedorapeople.org/pxz/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+# needs the library from xz-utils
+# needs the libgomp library from gcc at runtime
+DEPEND="app-arch/xz-utils
+ sys-devel/gcc[openmp]"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ append-lfs-flags
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+}