summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-07-01 07:54:17 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-07-01 07:54:17 +0000
commitca388d94f056a54bb8f4bd3961f66b9fd0a73f35 (patch)
tree73e579e3d4f334ed34a4aa4ec11f5c0c09c5e798 /app-benchmarks/acovea
parentSet default ABI_X86. Just in case. (diff)
downloadgentoo-2-ca388d94f056a54bb8f4bd3961f66b9fd0a73f35.tar.gz
gentoo-2-ca388d94f056a54bb8f4bd3961f66b9fd0a73f35.tar.bz2
gentoo-2-ca388d94f056a54bb8f4bd3961f66b9fd0a73f35.zip
Fix underlinking #495212
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-benchmarks/acovea')
-rw-r--r--app-benchmarks/acovea/ChangeLog11
-rw-r--r--app-benchmarks/acovea/acovea-5.1.1-r1.ebuild49
-rw-r--r--app-benchmarks/acovea/acovea-5.1.1.ebuild6
-rw-r--r--app-benchmarks/acovea/files/acovea-5.1.1-underlinking.patch10
4 files changed, 70 insertions, 6 deletions
diff --git a/app-benchmarks/acovea/ChangeLog b/app-benchmarks/acovea/ChangeLog
index b452fdacd279..7f9db5f4f304 100644
--- a/app-benchmarks/acovea/ChangeLog
+++ b/app-benchmarks/acovea/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-benchmarks/acovea
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/acovea/ChangeLog,v 1.19 2010/09/06 23:22:02 ssuominen Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/acovea/ChangeLog,v 1.20 2014/07/01 07:54:17 patrick Exp $
+
+*acovea-5.1.1-r1 (01 Jul 2014)
+
+ 01 Jul 2014; Patrick Lauer <patrick@gentoo.org> +acovea-5.1.1-r1.ebuild,
+ +files/acovea-5.1.1-underlinking.patch, acovea-5.1.1.ebuild:
+ Fix underlinking #495212
06 Sep 2010; Samuli Suominen <ssuominen@gentoo.org> acovea-5.1.1.ebuild,
+files/acovea-5.1.1-glibc-212.patch:
@@ -64,4 +70,3 @@
07 May 2004; Daniel Ahlberg <aliz@gentoo.org> acovea-4.0.0.ebuild:
Initial import.
-
diff --git a/app-benchmarks/acovea/acovea-5.1.1-r1.ebuild b/app-benchmarks/acovea/acovea-5.1.1-r1.ebuild
new file mode 100644
index 000000000000..0ed40990520b
--- /dev/null
+++ b/app-benchmarks/acovea/acovea-5.1.1-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/acovea/acovea-5.1.1-r1.ebuild,v 1.1 2014/07/01 07:54:17 patrick Exp $
+
+EAPI=2
+WANT_AUTOMAKE=1.9
+inherit autotools eutils
+
+DESCRIPTION="Analysis of Compiler Options via Evolutionary Algorithm"
+HOMEPAGE="http://www.coyotegulch.com/products/acovea/"
+SRC_URI="http://www.coyotegulch.com/distfiles/lib${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/libcoyotl-3.1.0
+ >=dev-libs/libevocosm-3.1.0
+ dev-libs/expat"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/lib${P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch \
+ "${FILESDIR}"/${P}-free-fix.patch \
+ "${FILESDIR}"/${P}-gcc44.patch \
+ "${FILESDIR}"/${P}-glibc-212.patch \
+ "${FILESDIR}"/${P}-underlinking.patch
+
+ if has_version ">=dev-libs/libevocosm-3.3.0"; then
+ epatch ${FILESDIR}"/${P}-libevocosm.patch"
+ fi
+
+ eautomake
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog NEWS README
+ find "${D}" -name '*.la' -exec rm -f '{}' +
+}
diff --git a/app-benchmarks/acovea/acovea-5.1.1.ebuild b/app-benchmarks/acovea/acovea-5.1.1.ebuild
index 6c38340c1cf8..0a9913c32165 100644
--- a/app-benchmarks/acovea/acovea-5.1.1.ebuild
+++ b/app-benchmarks/acovea/acovea-5.1.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/acovea/acovea-5.1.1.ebuild,v 1.10 2010/09/06 23:28:23 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/acovea/acovea-5.1.1.ebuild,v 1.11 2014/07/01 07:54:17 patrick Exp $
-EAPI=2
+EAPI=5
WANT_AUTOMAKE=1.9
inherit autotools eutils
diff --git a/app-benchmarks/acovea/files/acovea-5.1.1-underlinking.patch b/app-benchmarks/acovea/files/acovea-5.1.1-underlinking.patch
new file mode 100644
index 000000000000..06ef410b6cc6
--- /dev/null
+++ b/app-benchmarks/acovea/files/acovea-5.1.1-underlinking.patch
@@ -0,0 +1,10 @@
+diff --git a/cmdline/Makefile.am b/cmdline/Makefile.am
+index f3c763e..8e18d9c 100644
+--- a/cmdline/Makefile.am
++++ b/cmdline/Makefile.am
+@@ -7,4 +7,4 @@ bin_PROGRAMS = runacovea
+
+ runacovea_SOURCES = runacovea.cpp
+
+-LIBS = -L../libacovea -lacovea -lcoyotl -levocosm
++LIBS = -L../libacovea -lacovea -lcoyotl -levocosm -lbrahe