summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2008-12-30 17:26:47 +0000
committerChristoph Mende <angelos@gentoo.org>2008-12-30 17:26:47 +0000
commitf73b3f33c04b80808e93988a536c2964a1e5d5ac (patch)
treea978dbd74e101f5ad701ec86a8394f6c85cf7390 /app-benchmarks/contest
parentremove old clock init script forcibly during the upgrade since it appears to ... (diff)
downloadgentoo-2-f73b3f33c04b80808e93988a536c2964a1e5d5ac.tar.gz
gentoo-2-f73b3f33c04b80808e93988a536c2964a1e5d5ac.tar.bz2
gentoo-2-f73b3f33c04b80808e93988a536c2964a1e5d5ac.zip
QA: Use correct CC (bug #243514) and respect LDFLAGS
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'app-benchmarks/contest')
-rw-r--r--app-benchmarks/contest/ChangeLog5
-rw-r--r--app-benchmarks/contest/contest-0.61.ebuild17
2 files changed, 15 insertions, 7 deletions
diff --git a/app-benchmarks/contest/ChangeLog b/app-benchmarks/contest/ChangeLog
index 7efe7426455e..ecae5aef5846 100644
--- a/app-benchmarks/contest/ChangeLog
+++ b/app-benchmarks/contest/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-benchmarks/contest
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/contest/ChangeLog,v 1.7 2008/04/21 16:32:09 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/contest/ChangeLog,v 1.8 2008/12/30 17:26:47 angelos Exp $
+
+ 30 Dec 2008; Christoph Mende <angelos@gentoo.org> contest-0.61.ebuild:
+ QA: Use correct CC (bug #243514) and respect LDFLAGS
21 Apr 2008; Christian Heim <phreak@gentoo.org> metadata.xml:
Fix up metadata.xml. If there's no maintainer for the package, the metadata
diff --git a/app-benchmarks/contest/contest-0.61.ebuild b/app-benchmarks/contest/contest-0.61.ebuild
index 4cecb2fca254..214bd1b78a7e 100644
--- a/app-benchmarks/contest/contest-0.61.ebuild
+++ b/app-benchmarks/contest/contest-0.61.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/contest/contest-0.61.ebuild,v 1.6 2005/07/08 14:19:56 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/contest/contest-0.61.ebuild,v 1.7 2008/12/30 17:26:47 angelos Exp $
-DESCRIPTION="Test system responsiveness for compare different kernels"
+inherit toolchain-funcs
+
+DESCRIPTION="Test system responsiveness to compare different kernels"
HOMEPAGE="http://members.optusnet.com.au/ckolivas/contest/"
-SRC_URI="http://members.optusnet.com.au/ckolivas/contest/${P}.tar.gz"
+SRC_URI="http://members.optusnet.com.au/ckolivas/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -15,10 +17,13 @@ RDEPEND=">=app-benchmarks/dbench-2.0"
src_unpack () {
unpack ${A}
+ cd "${S}"
+
#Removing -g
- sed -i "s:-g::" ${S}/Makefile
+ sed -i "s:-g::" Makefile
#Adding our cflags
- sed -i "s:-O2:${CFLAGS}:" ${S}/Makefile
+ sed -i "s:-O2:${CFLAGS} ${LDFLAGS}:" Makefile
+ sed -i -e "/^CC/s/gcc/$(tc-getCC)/" Makefile
}
src_compile() {
emake || die