summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2009-01-30 11:24:42 +0000
committerDaniel Black <dragonheart@gentoo.org>2009-01-30 11:24:42 +0000
commitfda7183289642991fe919b780c7bf12047e58791 (patch)
tree5bc5a8b25daf9524b9b9aeba2cf8d048945cf02a /app-crypt/gnupg/files
parentCleanup. Add perl to metadata (diff)
downloadgentoo-2-fda7183289642991fe919b780c7bf12047e58791.tar.gz
gentoo-2-fda7183289642991fe919b780c7bf12047e58791.tar.bz2
gentoo-2-fda7183289642991fe919b780c7bf12047e58791.zip
gcc-4.3 patch from redhat as per bug #256671 thanks cilly. old version cleanout too
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt/gnupg/files')
-rw-r--r--app-crypt/gnupg/files/gnupg-1.4.3-keyserver.patch14
-rw-r--r--app-crypt/gnupg/files/gnupg-1.4.3-selftest.patch30
-rw-r--r--app-crypt/gnupg/files/gnupg-1.4.9-gcc43.patch49
-rw-r--r--app-crypt/gnupg/files/gnupg-2.0.4-idea.patch25
4 files changed, 49 insertions, 69 deletions
diff --git a/app-crypt/gnupg/files/gnupg-1.4.3-keyserver.patch b/app-crypt/gnupg/files/gnupg-1.4.3-keyserver.patch
deleted file mode 100644
index 105a0f62eeab..000000000000
--- a/app-crypt/gnupg/files/gnupg-1.4.3-keyserver.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -ur gnupg-1.4.3.orig/g10/keyserver.c gnupg-1.4.3/g10/keyserver.c
---- gnupg-1.4.3.orig/g10/keyserver.c 2006-03-21 13:29:47.000000000 +0100
-+++ gnupg-1.4.3/g10/keyserver.c 2006-04-09 14:50:02.000000000 +0200
-@@ -934,7 +934,9 @@
- static const char *
- keyserver_typemap(const char *type)
- {
-- if(strcmp(type,"ldaps")==0)
-+ if(strcmp(type,"ldap")==0)
-+ return "ldap";
-+ else if(strcmp(type,"ldaps")==0)
- return "ldap";
- else
- return type;
diff --git a/app-crypt/gnupg/files/gnupg-1.4.3-selftest.patch b/app-crypt/gnupg/files/gnupg-1.4.3-selftest.patch
deleted file mode 100644
index a5ba3840670a..000000000000
--- a/app-crypt/gnupg/files/gnupg-1.4.3-selftest.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff -ur gnupg-1.4.3.orig/checks/Makefile.in gnupg-1.4.3/checks/Makefile.in
---- gnupg-1.4.3.orig/checks/Makefile.in 2006-04-03 11:45:05.000000000 +0200
-+++ gnupg-1.4.3/checks/Makefile.in 2006-04-09 14:29:21.000000000 +0200
-@@ -540,9 +540,11 @@
-
- ./gpg_dearmor:
- echo '#!/bin/sh' >./gpg_dearmor
-- echo "../g10/gpg --no-options --no-greeting \
-+ echo "../g10/gpg --no-options --no-greeting --homedir . \
- --no-secmem-warning --batch --dearmor" >>./gpg_dearmor
- chmod 755 ./gpg_dearmor
-+ if test ! -f ./pubring.gpg; then touch -t 197001020000 ./pubring.gpg; fi
-+ if test ! -f ./secring.gpg; then touch -t 197001020000 ./secring.gpg; fi
-
- ./pubring.gpg: $(srcdir)/pubring.asc $(srcdir)/pubdemo.asc ./gpg_dearmor
- ./gpg_dearmor > ./pubring.gpg < $(srcdir)/pubring.asc
-diff -ur gnupg-1.4.3.orig/g10/openfile.c gnupg-1.4.3/g10/openfile.c
---- gnupg-1.4.3.orig/g10/openfile.c 2006-03-28 09:41:45.000000000 +0200
-+++ gnupg-1.4.3/g10/openfile.c 2006-04-09 14:30:42.000000000 +0200
-@@ -401,8 +401,10 @@
- * To cope with HOME, we do compare only the suffix if we see that
- * the default homedir does start with a tilde.
- */
-+#ifndef ENABLE_SELINUX_HACKS
- if( opt.dry_run || opt.no_homedir_creation )
- return;
-+#endif
-
- if ( ( *defhome == '~'
- && ( strlen(fname) >= strlen (defhome+1)
diff --git a/app-crypt/gnupg/files/gnupg-1.4.9-gcc43.patch b/app-crypt/gnupg/files/gnupg-1.4.9-gcc43.patch
new file mode 100644
index 000000000000..0a88e258db1e
--- /dev/null
+++ b/app-crypt/gnupg/files/gnupg-1.4.9-gcc43.patch
@@ -0,0 +1,49 @@
+diff -up gnupg-1.4.9/keyserver/gpgkeys_curl.c.BAD gnupg-1.4.9/keyserver/gpgkeys_curl.c
+--- gnupg-1.4.9/keyserver/gpgkeys_curl.c.BAD 2008-05-24 12:41:24.000000000 -0500
++++ gnupg-1.4.9/keyserver/gpgkeys_curl.c 2008-05-24 12:41:41.000000000 -0500
+@@ -286,7 +286,7 @@ main(int argc,char *argv[])
+
+ if(follow_redirects)
+ {
+- curl_easy_setopt(curl,CURLOPT_FOLLOWLOCATION,1);
++ curl_easy_setopt(curl,CURLOPT_FOLLOWLOCATION,1L);
+ if(follow_redirects>0)
+ curl_easy_setopt(curl,CURLOPT_MAXREDIRS,follow_redirects);
+ }
+@@ -298,10 +298,10 @@ main(int argc,char *argv[])
+ {
+ fprintf(console,"gpgkeys: curl version = %s\n",curl_version());
+ curl_easy_setopt(curl,CURLOPT_STDERR,console);
+- curl_easy_setopt(curl,CURLOPT_VERBOSE,1);
++ curl_easy_setopt(curl,CURLOPT_VERBOSE,1L);
+ }
+
+- curl_easy_setopt(curl,CURLOPT_SSL_VERIFYPEER,opt->flags.check_cert);
++ curl_easy_setopt(curl,CURLOPT_SSL_VERIFYPEER,(long)opt->flags.check_cert);
+ curl_easy_setopt(curl,CURLOPT_CAINFO,opt->ca_cert_file);
+
+ if(proxy)
+diff -up gnupg-1.4.9/keyserver/gpgkeys_hkp.c.BAD gnupg-1.4.9/keyserver/gpgkeys_hkp.c
+--- gnupg-1.4.9/keyserver/gpgkeys_hkp.c.BAD 2008-05-24 12:41:47.000000000 -0500
++++ gnupg-1.4.9/keyserver/gpgkeys_hkp.c 2008-05-24 12:42:10.000000000 -0500
+@@ -202,9 +202,9 @@ send_key(int *eof)
+ fprintf(console,"gpgkeys: HTTP URL is `%s'\n",request);
+
+ curl_easy_setopt(curl,CURLOPT_URL,request);
+- curl_easy_setopt(curl,CURLOPT_POST,1);
++ curl_easy_setopt(curl,CURLOPT_POST,1L);
+ curl_easy_setopt(curl,CURLOPT_POSTFIELDS,key);
+- curl_easy_setopt(curl,CURLOPT_FAILONERROR,1);
++ curl_easy_setopt(curl,CURLOPT_FAILONERROR,1L);
+
+ res=curl_easy_perform(curl);
+ if(res!=0)
+@@ -661,7 +661,7 @@ main(int argc,char *argv[])
+ {
+ fprintf(console,"gpgkeys: curl version = %s\n",curl_version());
+ curl_easy_setopt(curl,CURLOPT_STDERR,console);
+- curl_easy_setopt(curl,CURLOPT_VERBOSE,1);
++ curl_easy_setopt(curl,CURLOPT_VERBOSE,1L);
+ }
+
+ if(proxy)
diff --git a/app-crypt/gnupg/files/gnupg-2.0.4-idea.patch b/app-crypt/gnupg/files/gnupg-2.0.4-idea.patch
deleted file mode 100644
index aa65cc9f7ac5..000000000000
--- a/app-crypt/gnupg/files/gnupg-2.0.4-idea.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-
-This is required in order to support IDEA encrypted keys
-using gnupg-1.4.X. The raw key has two bytes which are part
-of the checksum but not part of the key.
-
-This will not get into upstream as upstream does not wish to support
-IDEA at all even for backward compatibility.
-
-Signed-off-by: Alon Bar-Lev <alonbl@gentoo.org>
-
-diff -urNp gnupg-2.0.4.org/g10/seckey-cert.c gnupg-2.0.4/g10/seckey-cert.c
---- gnupg-2.0.4.org/g10/seckey-cert.c 2006-11-21 10:26:13.000000000 +0200
-+++ gnupg-2.0.4/g10/seckey-cert.c 2007-06-22 18:08:48.000000000 +0300
-@@ -211,6 +211,11 @@ do_check( PKT_secret_key *sk, const char
- csum += checksum (buffer, ndata);
- gcry_mpi_release (sk->skey[i]);
-
-+ if (sk->protect.algo==CIPHER_ALGO_IDEA) {
-+ buffer[0] = 0;
-+ buffer[1] = 0;
-+ }
-+
- err = gcry_mpi_scan( &sk->skey[i], GCRYMPI_FMT_USG,
- buffer, ndata, &ndata );
- xfree (buffer);