summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2011-02-20 18:16:10 +0000
committerEray Aslan <eras@gentoo.org>2011-02-20 18:16:10 +0000
commit6bab1216315215506b9db7c10121f2e45d4b9cac (patch)
tree3a117bbf958fef7f0c463c38863a044608fb825d /app-crypt/heimdal
parentFix building with libpng-1.5, convert to EAPI=2, disable unneeded configure w... (diff)
downloadgentoo-2-6bab1216315215506b9db7c10121f2e45d4b9cac.tar.gz
gentoo-2-6bab1216315215506b9db7c10121f2e45d4b9cac.tar.bz2
gentoo-2-6bab1216315215506b9db7c10121f2e45d4b9cac.zip
Correct -berkdb option to configure script. Thanks to Jan Psota. Remove old.
(Portage version: 2.1.9.40/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt/heimdal')
-rw-r--r--app-crypt/heimdal/ChangeLog7
-rw-r--r--app-crypt/heimdal/heimdal-1.4.1_pre20110216-r1.ebuild13
-rw-r--r--app-crypt/heimdal/heimdal-1.4.1_pre20110216.ebuild137
3 files changed, 15 insertions, 142 deletions
diff --git a/app-crypt/heimdal/ChangeLog b/app-crypt/heimdal/ChangeLog
index 73d8041debe6..b3884ce3b586 100644
--- a/app-crypt/heimdal/ChangeLog
+++ b/app-crypt/heimdal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/heimdal
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/ChangeLog,v 1.169 2011/02/20 10:22:40 eras Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/ChangeLog,v 1.170 2011/02/20 18:16:10 eras Exp $
+
+ 20 Feb 2011; Eray Aslan <eras@gentoo.org>
+ -heimdal-1.4.1_pre20110216.ebuild, heimdal-1.4.1_pre20110216-r1.ebuild:
+ Correct -berkdb option to configure script. Thanks to Jan Psota. Remove
+ old.
*heimdal-1.4.1_pre20110216-r1 (20 Feb 2011)
diff --git a/app-crypt/heimdal/heimdal-1.4.1_pre20110216-r1.ebuild b/app-crypt/heimdal/heimdal-1.4.1_pre20110216-r1.ebuild
index 2436c9b613b2..9d866cfd377c 100644
--- a/app-crypt/heimdal/heimdal-1.4.1_pre20110216-r1.ebuild
+++ b/app-crypt/heimdal/heimdal-1.4.1_pre20110216-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/heimdal-1.4.1_pre20110216-r1.ebuild,v 1.1 2011/02/20 10:22:40 eras Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/heimdal-1.4.1_pre20110216-r1.ebuild,v 1.2 2011/02/20 18:16:10 eras Exp $
EAPI=2
# PYTHON_BDEPEND="2"
@@ -51,6 +51,12 @@ src_prepare() {
}
src_configure() {
+ local myconf=""
+ if use berkdb; then
+ myconf="--with-berkeley-db --with-berkeley-db-include=$(db_includedir)"
+ else
+ myconf="--without-berkeley-db"
+ fi
econf \
--enable-kcm \
--disable-osfc2 \
@@ -64,13 +70,12 @@ src_configure() {
$(use_enable pkinit kx509) \
$(use_enable pkinit pk-init) \
$(use_enable threads pthread-support) \
- $(use_with berkdb berkeley-db) \
- $(use_with berkdb berkeley-db-include=$(db_includedir)) \
$(use_with caps capng) \
$(use_with hdb-ldap openldap /usr) \
$(use_with ipv6) \
$(use_with ssl openssl /usr) \
- $(use_with X x)
+ $(use_with X x) \
+ ${myconf}
}
src_compile() {
diff --git a/app-crypt/heimdal/heimdal-1.4.1_pre20110216.ebuild b/app-crypt/heimdal/heimdal-1.4.1_pre20110216.ebuild
deleted file mode 100644
index 1b2f59854027..000000000000
--- a/app-crypt/heimdal/heimdal-1.4.1_pre20110216.ebuild
+++ /dev/null
@@ -1,137 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/heimdal-1.4.1_pre20110216.ebuild,v 1.2 2011/02/17 17:06:20 arfrever Exp $
-
-EAPI=2
-# PYTHON_BDEPEND="2"
-VIRTUALX_REQUIRED="manual"
-
-inherit autotools db-use eutils libtool python toolchain-funcs virtualx
-
-MY_P="${P}"
-DESCRIPTION="Kerberos 5 implementation from KTH"
-HOMEPAGE="http://www.h5l.org/"
-SRC_URI="http://www.h5l.org/dist/src/${MY_P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="afs +berkdb caps hdb-ldap ipv6 otp +pkinit ssl threads test X"
-
-RDEPEND="ssl? ( dev-libs/openssl )
- berkdb? ( sys-libs/db )
- !berkdb? ( sys-libs/gdbm )
- caps? ( sys-libs/libcap-ng )
- >=dev-db/sqlite-3.5.7
- >=sys-libs/e2fsprogs-libs-1.41.11
- afs? ( net-fs/openafs )
- hdb-ldap? ( >=net-nds/openldap-2.3.0 )
- !!app-crypt/mit-krb5"
-
-DEPEND="${RDEPEND}
- =dev-lang/python-2*
- dev-util/pkgconfig
- >=sys-devel/autoconf-2.62
- test? ( X? ( ${VIRTUALX_DEPEND} ) )"
-
-PROVIDE="virtual/krb5"
-
-S="${WORKDIR}/${PN}"
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- epatch "${FILESDIR}/heimdal_db5.patch"
- epatch "${FILESDIR}/heimdal_disable-check-iprop.patch"
- epatch "${FILESDIR}/heimdal_link_order.patch"
- eautoreconf
-}
-
-src_configure() {
- econf \
- --enable-kcm \
- --disable-osfc2 \
- --enable-shared \
- --with-libintl=/usr \
- --with-readline=/usr \
- --with-sqlite3=/usr \
- --libexecdir=/usr/sbin \
- $(use_enable afs afs-support) \
- $(use_enable otp) \
- $(use_enable pkinit kx509) \
- $(use_enable pkinit pk-init) \
- $(use_enable threads pthread-support) \
- $(use_with berkdb berkeley-db) \
- $(use_with berkdb berkeley-db-include=$(db_includedir)) \
- $(use_with caps capng) \
- $(use_with hdb-ldap openldap /usr) \
- $(use_with ipv6) \
- $(use_with ssl openssl /usr) \
- $(use_with X x)
-}
-
-src_compile() {
- emake -j1 || die "emake failed"
-}
-
-src_test() {
- einfo "Disabled check-iprop which is known to fail. Other tests should work."
- default_src_test
-}
-
-src_install() {
- INSTALL_CATPAGES="no" emake DESTDIR="${D}" install || die "emake install failed"
-
- dodoc ChangeLog README NEWS TODO
-
- # Begin client rename and install
- for i in {telnetd,ftpd,rshd,popper}
- do
- mv "${D}"/usr/share/man/man8/{,k}${i}.8
- mv "${D}"/usr/sbin/{,k}${i}
- done
-
- for i in {rcp,rsh,telnet,ftp,su,login,pagsh,kf}
- do
- mv "${D}"/usr/share/man/man1/{,k}${i}.1
- mv "${D}"/usr/bin/{,k}${i}
- done
-
- mv "${D}"/usr/share/man/man5/{,k}ftpusers.5
- mv "${D}"/usr/share/man/man5/{,k}login.access.5
-
- newinitd "${FILESDIR}"/heimdal-kdc.initd-r1 heimdal-kdc
- newinitd "${FILESDIR}"/heimdal-kadmind.initd-r1 heimdal-kadmind
- newinitd "${FILESDIR}"/heimdal-kpasswdd.initd-r1 heimdal-kpasswdd
- newinitd "${FILESDIR}"/heimdal-kcm.initd-r1 heimdal-kcm
-
- newconfd "${FILESDIR}"/heimdal-kdc.confd heimdal-kdc
- newconfd "${FILESDIR}"/heimdal-kadmind.confd heimdal-kadmind
- newconfd "${FILESDIR}"/heimdal-kpasswdd.confd heimdal-kpasswdd
- newconfd "${FILESDIR}"/heimdal-kcm.confd heimdal-kcm
-
- insinto /etc
- newins "${FILESDIR}"/krb5.conf krb5.conf.example
-
- if use hdb-ldap; then
- insinto /etc/openldap/schema
- doins "${S}/lib/hdb/hdb.schema"
- fi
-
- # default database dir
- keepdir /var/heimdal
-}
-
-pkg_preinst() {
-
- if has_version "=${CATEGORY}/${PN}-1.3.2*" ; then
- if use hdb-ldap ; then
- ewarn "Schema name changed to hdb.schema to follow upstream."
- ewarn "Please check your slapd conf file to make sure"
- ewarn "that the correct schema file is included."
- fi
- fi
-}