summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-03-01 13:15:20 +0000
committerJustin Lecher <jlec@gentoo.org>2013-03-01 13:15:20 +0000
commitf73a4d9374214178a8db9be3a3fbcba5606be188 (patch)
tree0681c3acef63073384137c2a2ec4702fd6ee410c /app-dicts/wordnet
parentAdd kde into metadata.xml (diff)
downloadgentoo-2-f73a4d9374214178a8db9be3a3fbcba5606be188.tar.gz
gentoo-2-f73a4d9374214178a8db9be3a3fbcba5606be188.tar.bz2
gentoo-2-f73a4d9374214178a8db9be3a3fbcba5606be188.zip
app-dicts/wordnet: Fix compilation gainst tcl-8.6, #451400
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'app-dicts/wordnet')
-rw-r--r--app-dicts/wordnet/ChangeLog8
-rw-r--r--app-dicts/wordnet/files/wordnet-3.0-tcl8.6.patch133
-rw-r--r--app-dicts/wordnet/metadata.xml2
-rw-r--r--app-dicts/wordnet/wordnet-3.0-r3.ebuild8
4 files changed, 145 insertions, 6 deletions
diff --git a/app-dicts/wordnet/ChangeLog b/app-dicts/wordnet/ChangeLog
index 93353a7f53d4..e4746887bee1 100644
--- a/app-dicts/wordnet/ChangeLog
+++ b/app-dicts/wordnet/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-dicts/wordnet
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/wordnet/ChangeLog,v 1.23 2012/05/31 03:36:03 zmedico Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/wordnet/ChangeLog,v 1.24 2013/03/01 13:15:19 jlec Exp $
+
+ 01 Mar 2013; Justin Lecher <jlec@gentoo.org> wordnet-3.0-r3.ebuild,
+ +files/wordnet-3.0-tcl8.6.patch, metadata.xml:
+ Fix compilation gainst tcl-8.6, #451400
31 May 2012; Zac Medico <zmedico@gentoo.org> wordnet-3.0-r2.ebuild,
wordnet-3.0-r3.ebuild:
diff --git a/app-dicts/wordnet/files/wordnet-3.0-tcl8.6.patch b/app-dicts/wordnet/files/wordnet-3.0-tcl8.6.patch
new file mode 100644
index 000000000000..110ffc2110b8
--- /dev/null
+++ b/app-dicts/wordnet/files/wordnet-3.0-tcl8.6.patch
@@ -0,0 +1,133 @@
+ src/stubs.c | 33 +++++++++++++++++----------------
+ 1 file changed, 17 insertions(+), 16 deletions(-)
+
+diff --git a/src/stubs.c b/src/stubs.c
+index 794485c..cec2c04 100644
+--- a/src/stubs.c
++++ b/src/stubs.c
+@@ -40,8 +40,8 @@ int wn_findvalidsearches (ClientData clientData, Tcl_Interp *interp,
+ char *morph;
+ int pos;
+ if (argc != 3) {
+- interp -> result =
+- "usage: findvalidsearches searchword partofspeechnum";
++ Tcl_SetResult(interp,
++ "usage: findvalidsearches searchword partofspeechnum", TCL_STATIC);
+ return TCL_ERROR;
+ }
+ pos = atoi (argv[2]);
+@@ -52,7 +52,7 @@ int wn_findvalidsearches (ClientData clientData, Tcl_Interp *interp,
+ } while ((morph = morphstr (NULL, pos)) != NULL);
+ }
+ sprintf (bitfieldstr, "%u", bitfield);
+- interp -> result = bitfieldstr;
++ Tcl_SetResult(interp, bitfieldstr, TCL_STATIC);
+ return TCL_OK;
+ }
+
+@@ -69,13 +69,13 @@ int wn_bit (ClientData clientData, Tcl_Interp *interp,
+ static char bitfieldstr[32];
+ int whichbit;
+ if (argc != 2) {
+- interp -> result = "usage: bit bitnum";
++ Tcl_SetResult(interp, "usage: bit bitnum", TCL_STATIC);
+ return TCL_ERROR;
+ }
+ whichbit = atoi (argv[1]);
+ bitfield = bit (whichbit);
+ sprintf (bitfieldstr, "%u", bitfield);
+- interp -> result = bitfieldstr;
++ Tcl_SetResult(interp, bitfieldstr, TCL_STATIC);
+ return TCL_OK;
+ }
+
+@@ -89,8 +89,8 @@ int wn_search (ClientData clientData, Tcl_Interp *interp,
+ int pos, searchtype, sense;
+ char *morph;
+ if (argc != 5) {
+- interp -> result =
+- "usage: search searchword partofspeechnum searchtypenum sensenum";
++ Tcl_SetResult(interp,
++ "usage: search searchword partofspeechnum searchtypenum sensenum", TCL_STATIC);
+ return TCL_ERROR;
+ }
+ pos = atoi (argv[2]);
+@@ -102,7 +102,7 @@ int wn_search (ClientData clientData, Tcl_Interp *interp,
+ strcat (resultbuf, findtheinfo (morph, pos, searchtype, sense));
+ } while ((morph = morphstr (NULL, pos)) != NULL);
+ }
+- interp -> result = resultbuf;
++ Tcl_SetResult(interp, resultbuf, TCL_STATIC);
+ return TCL_OK;
+ }
+
+@@ -114,7 +114,7 @@ int wn_search (ClientData clientData, Tcl_Interp *interp,
+ int wn_glosses (ClientData clientData, Tcl_Interp *interp,
+ int argc, char *argv[]) {
+ if (argc != 2) {
+- interp -> result = "usage: glosses [1 | 0]";
++ Tcl_SetResult(interp, "usage: glosses [1 | 0]", TCL_STATIC);
+ return TCL_ERROR;
+ }
+ dflag = atoi (argv[1]);
+@@ -129,7 +129,7 @@ int wn_glosses (ClientData clientData, Tcl_Interp *interp,
+ int wn_fileinfo (ClientData clientData, Tcl_Interp *interp,
+ int argc, char *argv[]) {
+ if (argc != 2) {
+- interp -> result = "usage: fileinfo [1 | 0]";
++ Tcl_SetResult(interp, "usage: fileinfo [1 | 0]", TCL_STATIC);
+ return TCL_ERROR;
+ }
+ fileinfoflag = atoi (argv[1]);
+@@ -144,7 +144,7 @@ int wn_fileinfo (ClientData clientData, Tcl_Interp *interp,
+ int wn_byteoffset (ClientData clientData, Tcl_Interp *interp,
+ int argc, char *argv[]) {
+ if (argc != 2) {
+- interp -> result = "usage: byteoffset [1 | 0]";
++ Tcl_SetResult(interp, "usage: byteoffset [1 | 0]", TCL_STATIC);
+ return TCL_ERROR;
+ }
+ offsetflag = atoi (argv[1]);
+@@ -159,7 +159,7 @@ int wn_byteoffset (ClientData clientData, Tcl_Interp *interp,
+ int wn_senseflag (ClientData clientData, Tcl_Interp *interp,
+ int argc, char *argv[]) {
+ if (argc != 2) {
+- interp -> result = "usage: senseflag [1 | 0]";
++ Tcl_SetResult(interp, "usage: senseflag [1 | 0]", TCL_STATIC);
+ return TCL_ERROR;
+ }
+ wnsnsflag = atoi (argv[1]);
+@@ -175,12 +175,13 @@ int wn_contextualhelp (ClientData clientData, Tcl_Interp *interp,
+ int argc, char *argv[]) {
+ int pos, searchtype;
+ if (argc != 3) {
+- interp -> result = "usage: contextualhelp partofspeechnum searchtypenum";
++ Tcl_SetResult(interp,
++ "usage: contextualhelp partofspeechnum searchtypenum", TCL_STATIC);
+ return TCL_ERROR;
+ }
+ pos = atoi (argv[1]);
+ searchtype = atoi (argv[2]);
+- interp -> result = helptext[pos][searchtype];
++ Tcl_SetResult(interp, helptext[pos][searchtype], TCL_STATIC);
+ return TCL_OK;
+ }
+
+@@ -190,7 +191,7 @@ int wn_contextualhelp (ClientData clientData, Tcl_Interp *interp,
+ int wn_reopendb (ClientData clientData, Tcl_Interp *interp,
+ int argc, char *argv[]) {
+ if (argc != 1) {
+- interp -> result = "usage: reopendb";
++ Tcl_SetResult(interp, "usage: reopendb", TCL_STATIC);
+ return TCL_ERROR;
+ }
+ re_wninit ();
+@@ -204,7 +205,7 @@ int wn_reopendb (ClientData clientData, Tcl_Interp *interp,
+ int wn_abortsearch (ClientData clientData, Tcl_Interp *interp,
+ int argc, char *argv[]) {
+ if (argc != 1) {
+- interp -> result = "usage: abortsearch";
++ Tcl_SetResult(interp, "usage: abortsearch", TCL_STATIC);
+ return TCL_ERROR;
+ }
+ abortsearch = 1;
diff --git a/app-dicts/wordnet/metadata.xml b/app-dicts/wordnet/metadata.xml
index 8f9450df306e..9ba4ed3f5685 100644
--- a/app-dicts/wordnet/metadata.xml
+++ b/app-dicts/wordnet/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>app-dicts</herd>
+ <herd>app-dicts</herd>
</pkgmetadata>
diff --git a/app-dicts/wordnet/wordnet-3.0-r3.ebuild b/app-dicts/wordnet/wordnet-3.0-r3.ebuild
index 9b84c9198bf5..0368285827fe 100644
--- a/app-dicts/wordnet/wordnet-3.0-r3.ebuild
+++ b/app-dicts/wordnet/wordnet-3.0-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/wordnet/wordnet-3.0-r3.ebuild,v 1.5 2012/05/31 03:36:03 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/wordnet/wordnet-3.0-r3.ebuild,v 1.6 2013/03/01 13:15:19 jlec Exp $
EAPI="3"
@@ -34,6 +34,8 @@ src_prepare() {
epatch "${WORKDIR}"/${P}-CVE-2008-3908.patch #211491
epatch "${WORKDIR}"/${P}-CVE-2008-2149.patch #211491
+ epatch "${FILESDIR}"/${P}-tcl8.6.patch
+
# Don't install all the extra docs (html, pdf, ps) without doc USE flag.
use doc || sed -i -e "s:SUBDIRS =.*:SUBDIRS = man:" doc/Makefile.am
@@ -47,7 +49,7 @@ src_prepare() {
}
src_configure() {
- append-flags -DUNIX -I"${T}"/usr/include
+ append-cppflags -DUNIX -I"${T}"/usr/include
PLATFORM=linux WN_ROOT="${T}/usr" \
WN_DICTDIR="${T}/usr/share/wordnet/dict" \