summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-01-31 16:24:11 +0000
committerUlrich Müller <ulm@gentoo.org>2010-01-31 16:24:11 +0000
commitee162871abc91699699869939453b1e7e011c3ea (patch)
tree9c7ff60450620149c0efb465672000096ab2972c /app-editors/jasspa-microemacs
parentStable on amd64 wrt bug #300713 (diff)
downloadgentoo-2-ee162871abc91699699869939453b1e7e011c3ea.tar.gz
gentoo-2-ee162871abc91699699869939453b1e7e011c3ea.tar.bz2
gentoo-2-ee162871abc91699699869939453b1e7e011c3ea.zip
Add prefix keywords, change EAPI to 3.
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'app-editors/jasspa-microemacs')
-rw-r--r--app-editors/jasspa-microemacs/ChangeLog10
-rw-r--r--app-editors/jasspa-microemacs/jasspa-microemacs-20091011-r1.ebuild81
2 files changed, 89 insertions, 2 deletions
diff --git a/app-editors/jasspa-microemacs/ChangeLog b/app-editors/jasspa-microemacs/ChangeLog
index e4fc047446b9..0acc866fe37f 100644
--- a/app-editors/jasspa-microemacs/ChangeLog
+++ b/app-editors/jasspa-microemacs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/jasspa-microemacs
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jasspa-microemacs/ChangeLog,v 1.41 2009/12/02 19:40:54 ulm Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jasspa-microemacs/ChangeLog,v 1.42 2010/01/31 16:24:11 ulm Exp $
+
+*jasspa-microemacs-20091011-r1 (31 Jan 2010)
+
+ 31 Jan 2010; Ulrich Mueller <ulm@gentoo.org>
+ +jasspa-microemacs-20091011-r1.ebuild:
+ Add prefix keywords, change EAPI to 3.
02 Dec 2009; Ulrich Mueller <ulm@gentoo.org>
-files/20050505-ncurses.patch:
diff --git a/app-editors/jasspa-microemacs/jasspa-microemacs-20091011-r1.ebuild b/app-editors/jasspa-microemacs/jasspa-microemacs-20091011-r1.ebuild
new file mode 100644
index 000000000000..ca94dd9b251d
--- /dev/null
+++ b/app-editors/jasspa-microemacs/jasspa-microemacs-20091011-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jasspa-microemacs/jasspa-microemacs-20091011-r1.ebuild,v 1.1 2010/01/31 16:24:11 ulm Exp $
+
+EAPI=3
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Jasspa Microemacs"
+HOMEPAGE="http://www.jasspa.com/"
+SRC_URI="http://www.jasspa.com/release_20090909/jasspa-mesrc-${PV}.tar.gz
+ !nanoemacs? (
+ http://www.jasspa.com/release_20090909/jasspa-memacros-${PV}.tar.gz
+ http://www.jasspa.com/release_20090909/jasspa-mehtml-${PV}.tar.gz
+ http://www.jasspa.com/release_20060909/meicons-extra.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE="nanoemacs X xpm"
+
+RDEPEND="sys-libs/ncurses
+ X? ( x11-libs/libX11
+ xpm? ( x11-libs/libXpm ) )
+ nanoemacs? ( !app-editors/ne )"
+
+DEPEND="${RDEPEND}
+ X? ( x11-libs/libXt
+ x11-proto/xproto )"
+
+S="${WORKDIR}/me${PV:2}/src"
+
+src_unpack() {
+ unpack jasspa-mesrc-${PV}.tar.gz
+ if ! use nanoemacs; then
+ mkdir "${WORKDIR}/jasspa"
+ cd "${WORKDIR}/jasspa"
+ # everything except jasspa-mesrc
+ unpack ${A/jasspa-mesrc-${PV}.tar.gz/}
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-ncurses.patch"
+
+ # allow for some variables to be passed to make
+ sed -i '/make/s/\$OPTIONS/& CC="$CC" COPTIMISE="$CFLAGS" STRIP=true/' \
+ build || die "sed failed"
+}
+
+src_compile() {
+ local pkgdatadir="${EPREFIX}/usr/share/jasspa"
+ local me="" type=c
+ use nanoemacs && me="-ne"
+ use X && type=cw
+ use xpm || export XPM_INCLUDE=. # prevent Xpm autodetection
+
+ CC="$(tc-getCC)" ./build ${me} \
+ -t ${type} \
+ -p "~/.jasspa:${pkgdatadir}/site:${pkgdatadir}" \
+ || die "build failed"
+}
+
+src_install() {
+ local me=me type=c
+ use nanoemacs && me=ne
+ use X && type=cw
+ newbin ${me}${type} ${me} || die "newbin failed"
+
+ if ! use nanoemacs; then
+ keepdir /usr/share/jasspa/site
+ insinto /usr/share
+ doins -r "${WORKDIR}/jasspa"
+ if use X; then
+ insinto /usr/share/applications
+ doins "${FILESDIR}/${PN}.desktop"
+ fi
+ fi
+
+ dodoc ../faq.txt ../readme.txt ../change.log || die "dodoc failed"
+}