summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2008-12-31 05:29:06 +0000
committerJeremy Olexa <darkside@gentoo.org>2008-12-31 05:29:06 +0000
commit1ff7a82825224ba108f0f4bf6c535f0084db496e (patch)
treec68daf59dfaa2b0a6828c94e1b0e98e365c2b885 /app-editors/mp
parentadd ~amd64 kw (diff)
downloadgentoo-2-1ff7a82825224ba108f0f4bf6c535f0084db496e.tar.gz
gentoo-2-1ff7a82825224ba108f0f4bf6c535f0084db496e.tar.bz2
gentoo-2-1ff7a82825224ba108f0f4bf6c535f0084db496e.zip
(non maintainer commit) Version bump to latest - dropped arches due to added dep. Thanks to the work of Guenther Brunthaler in bug 205950
(Portage version: 2.2_rc20/cvs/Linux 2.6.27.10 x86_64)
Diffstat (limited to 'app-editors/mp')
-rw-r--r--app-editors/mp/ChangeLog8
-rw-r--r--app-editors/mp/mp-5.1.1.ebuild71
2 files changed, 78 insertions, 1 deletions
diff --git a/app-editors/mp/ChangeLog b/app-editors/mp/ChangeLog
index 37dfbf4b2ed0..f7e7c0c48f2a 100644
--- a/app-editors/mp/ChangeLog
+++ b/app-editors/mp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/mp
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/ChangeLog,v 1.66 2008/12/30 18:41:07 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/ChangeLog,v 1.67 2008/12/31 05:29:06 darkside Exp $
+
+*mp-5.1.1 (31 Dec 2008)
+
+ 31 Dec 2008; Jeremy Olexa <darkside@gentoo.org> +mp-5.1.1.ebuild:
+ (non maintainer commit) Version bump to latest - dropped arches due to added
+ dep. Thanks to the work of Guenther Brunthaler in bug 205950
30 Dec 2008; Christoph Mende <angelos@gentoo.org> mp-3.3.18b.ebuild:
QA: Respect CC (bug 243568)
diff --git a/app-editors/mp/mp-5.1.1.ebuild b/app-editors/mp/mp-5.1.1.ebuild
new file mode 100644
index 000000000000..458951575cb3
--- /dev/null
+++ b/app-editors/mp/mp-5.1.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-5.1.1.ebuild,v 1.1 2008/12/31 05:29:06 darkside Exp $
+
+inherit eutils
+
+DESCRIPTION="Minimum Profit: A text editor for programmers"
+HOMEPAGE="http://www.triptico.com/software/mp.html"
+SRC_URI="http://www.triptico.com/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="gtk ncurses nls pcre iconv"
+
+RDEPEND="virtual/libc
+ ncurses? ( sys-libs/ncurses )
+ gtk? ( >=x11-libs/gtk+-2 >=x11-libs/pango-1.8.0 )
+ !gtk? ( sys-libs/ncurses )
+ nls? ( sys-devel/gettext )
+ pcre? ( dev-libs/libpcre )
+ iconv? ( virtual/libiconv )
+ app-text/grutatxt"
+DEPEND="${RDEPEND}
+ app-text/grutatxt
+ dev-util/pkgconfig
+ dev-lang/perl"
+
+src_compile() {
+ local myconf="--prefix=/usr --without-win32"
+
+ if use gtk; then
+ ! use ncurses && myconf="${myconf} --without-curses"
+ else
+ myconf="${myconf} --without-gtk2"
+ fi
+
+ use nls || myconfig="${myconf} --without-gettext"
+
+ if use pcre; then
+ myconf="${myconf} --with-pcre"
+ else
+ myconf="${myconf} --without-pcre --with-included-regex"
+ fi
+
+ use iconv || myconf="${myconf} --without-iconv"
+
+ sh config.sh ${myconf} || die "Configure failed"
+
+ echo ${CFLAGS} >> config.cflags
+ echo ${LDFLAGS} >> config.ldflags
+ emake || die "Compile Failed"
+}
+
+src_install() {
+ mkdir -p "${D}/${DESTTREE}/bin"
+ sh config.sh --prefix="${DESTTREE}"
+ make DESTDIR="${D}" install || die "Install Failed"
+ use gtk && dosym mp-5 ${DESTTREE}/bin/gmp
+}
+
+pkg_postinst() {
+ if use gtk ; then
+ einfo
+ einfo "mp-5 is symlinked to gmp! Use"
+ einfo "$ DISPLAY=\"\" mp-5"
+ einfo "to use text mode!"
+ einfo
+ epause 5
+ fi
+}