summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-07-25 18:39:22 +0000
committerTorsten Veller <tove@gentoo.org>2010-07-25 18:39:22 +0000
commit5f0b507656cc47bbf7893e92587d2c3a7bab0453 (patch)
treef4ed2f82852cd771d2399ea455ebd34c45c565c2 /app-editors/xmlcopyeditor
parentDelete older ebuild. (diff)
downloadgentoo-2-5f0b507656cc47bbf7893e92587d2c3a7bab0453.tar.gz
gentoo-2-5f0b507656cc47bbf7893e92587d2c3a7bab0453.tar.bz2
gentoo-2-5f0b507656cc47bbf7893e92587d2c3a7bab0453.zip
Version bump (#327693). dabbott maintains xmlcopyeditor
(Portage version: 2.2_rc67_p240/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/xmlcopyeditor')
-rw-r--r--app-editors/xmlcopyeditor/ChangeLog8
-rw-r--r--app-editors/xmlcopyeditor/metadata.xml5
-rw-r--r--app-editors/xmlcopyeditor/xmlcopyeditor-1.2.0.6.ebuild42
3 files changed, 53 insertions, 2 deletions
diff --git a/app-editors/xmlcopyeditor/ChangeLog b/app-editors/xmlcopyeditor/ChangeLog
index ae63e7b019e1..50556d6c4e6e 100644
--- a/app-editors/xmlcopyeditor/ChangeLog
+++ b/app-editors/xmlcopyeditor/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/xmlcopyeditor
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xmlcopyeditor/ChangeLog,v 1.14 2010/06/02 06:26:17 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xmlcopyeditor/ChangeLog,v 1.15 2010/07/25 18:39:22 tove Exp $
+
+*xmlcopyeditor-1.2.0.6 (25 Jul 2010)
+
+ 25 Jul 2010; Torsten Veller <tove@gentoo.org>
+ +xmlcopyeditor-1.2.0.6.ebuild, metadata.xml:
+ Version bump (#327693). dabbott maintains xmlcopyeditor
02 Jun 2010; Torsten Veller <tove@gentoo.org> metadata.xml:
Remove yoswink from metadata.xml (#78785)
diff --git a/app-editors/xmlcopyeditor/metadata.xml b/app-editors/xmlcopyeditor/metadata.xml
index f28f1656b053..dbcd6b47b6a1 100644
--- a/app-editors/xmlcopyeditor/metadata.xml
+++ b/app-editors/xmlcopyeditor/metadata.xml
@@ -3,7 +3,10 @@
<pkgmetadata>
<herd>no-herd</herd>
<maintainer>
- <email>maintainer-needed@gentoo.org</email>
+ <email>dabbott@gentoo.org</email>
+</maintainer>
+<maintainer>
+ <email>tove@gentoo.org</email>
</maintainer>
<longdescription>
Fast, free, validating XML editor.
diff --git a/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.0.6.ebuild b/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.0.6.ebuild
new file mode 100644
index 000000000000..cf94d76e35ff
--- /dev/null
+++ b/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.0.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.0.6.ebuild,v 1.1 2010/07/25 18:39:22 tove Exp $
+
+EAPI="2"
+
+WX_GTK_VER="2.8"
+MY_P=${P}-2
+
+inherit wxwidgets
+
+DESCRIPTION="XML Copy Editor is a fast, free, validating XML editor"
+HOMEPAGE="http://xml-copy-editor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xml-copy-editor/${MY_P}.tar.gz
+ guidexml? ( mirror://gentoo/GuideXML-templates.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="guidexml"
+
+DEPEND=">=dev-libs/libxml2-2.7.3-r1
+ dev-libs/libxslt
+ dev-libs/xerces-c
+ dev-libs/boost
+ dev-libs/libpcre
+ app-text/aspell
+ x11-libs/wxGTK:2.8[X]"
+RDEPEND=${DEPEND}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ if use guidexml; then
+ insinto /usr/share/xmlcopyeditor/templates/
+ for TEMPLATE in "${WORKDIR}"/GuideXML-templates/*.xml; do
+ newins "${TEMPLATE}" "${TEMPLATE##*/}" || die "GuideXML templates failed"
+ done
+ fi
+
+ dodoc AUTHORS ChangeLog README NEWS
+}