summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosé Luis Rivero <yoswink@gentoo.org>2008-07-04 19:43:05 +0000
committerJosé Luis Rivero <yoswink@gentoo.org>2008-07-04 19:43:05 +0000
commitd4b8914be4e51bf8b12ac18dc5c1dbc03fdc65aa (patch)
tree407660b3478c21240d5379583ad4d3915af7c455 /app-editors/xmlcopyeditor
parentcleanup old stuff (diff)
downloadgentoo-2-d4b8914be4e51bf8b12ac18dc5c1dbc03fdc65aa.tar.gz
gentoo-2-d4b8914be4e51bf8b12ac18dc5c1dbc03fdc65aa.tar.bz2
gentoo-2-d4b8914be4e51bf8b12ac18dc5c1dbc03fdc65aa.zip
Make the application to compile with gcc-4.3 series thanks to patch by Ian Abbott <ian@abbott.org> in #230731
(Portage version: 2.2_rc1/cvs/Linux 2.6.24-mactel i686)
Diffstat (limited to 'app-editors/xmlcopyeditor')
-rw-r--r--app-editors/xmlcopyeditor/ChangeLog8
-rw-r--r--app-editors/xmlcopyeditor/files/gcc-4.3-header-dependency.patch264
-rw-r--r--app-editors/xmlcopyeditor/xmlcopyeditor-1.1.0.6.ebuild9
-rw-r--r--app-editors/xmlcopyeditor/xmlcopyeditor-1.1.0.7.ebuild9
4 files changed, 287 insertions, 3 deletions
diff --git a/app-editors/xmlcopyeditor/ChangeLog b/app-editors/xmlcopyeditor/ChangeLog
index a03491685641..c2ea12036df3 100644
--- a/app-editors/xmlcopyeditor/ChangeLog
+++ b/app-editors/xmlcopyeditor/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/xmlcopyeditor
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xmlcopyeditor/ChangeLog,v 1.4 2008/07/03 22:24:36 yoswink Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xmlcopyeditor/ChangeLog,v 1.5 2008/07/04 19:43:04 yoswink Exp $
+
+ 04 Jul 2008; Jose Luis Rivero <yoswink@gentoo.org>
+ +files/gcc-4.3-header-dependency.patch, xmlcopyeditor-1.1.0.6.ebuild,
+ xmlcopyeditor-1.1.0.7.ebuild:
+ Make the application to compile with gcc-4.3 series thanks to patch by Ian
+ Abbott <ian@abbott.org> in #230731
*xmlcopyeditor-1.1.0.7 (03 Jul 2008)
diff --git a/app-editors/xmlcopyeditor/files/gcc-4.3-header-dependency.patch b/app-editors/xmlcopyeditor/files/gcc-4.3-header-dependency.patch
new file mode 100644
index 000000000000..7de4407197aa
--- /dev/null
+++ b/app-editors/xmlcopyeditor/files/gcc-4.3-header-dependency.patch
@@ -0,0 +1,264 @@
+diff -ur src/globalreplacedialog.cpp src/globalreplacedialog.cpp
+--- src/globalreplacedialog.cpp 2008-01-20 20:14:24.000000000 +0000
++++ src/globalreplacedialog.cpp 2008-07-04 15:03:47.000000000 +0100
+@@ -17,6 +17,7 @@
+ * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+ */
+
++#include <memory>
+ #include "globalreplacedialog.h"
+ #include "wrapregex.h"
+
+diff -ur src/housestyle.cpp src/housestyle.cpp
+--- src/housestyle.cpp 2008-01-20 20:14:24.000000000 +0000
++++ src/housestyle.cpp 2008-07-04 15:03:47.000000000 +0100
+@@ -17,6 +17,7 @@
+ * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+ */
+
++#include <cstring>
+ #include "housestyle.h"
+ #include "readfile.h"
+
+diff -ur src/housestylereader.h src/housestylereader.h
+--- src/housestylereader.h 2008-01-20 20:14:30.000000000 +0000
++++ src/housestylereader.h 2008-07-04 15:03:47.000000000 +0100
+@@ -24,6 +24,7 @@
+ #include <map>
+ #include <set>
+ #include <vector>
++#include <memory>
+ #include <expat.h>
+ #include "wrapexpat.h"
+
+diff -ur src/housestylewriter.h src/housestylewriter.h
+--- src/housestylewriter.h 2008-01-20 20:14:30.000000000 +0000
++++ src/housestylewriter.h 2008-07-04 15:03:47.000000000 +0100
+@@ -22,6 +22,7 @@
+
+ #include <set>
+ #include <string>
++#include <memory>
+ #include <expat.h>
+ #include "wrapexpat.h"
+ #include "wrapregex.h"
+diff -ur src/stringset.h src/stringset.h
+--- src/stringset.h 2008-01-20 20:14:30.000000000 +0000
++++ src/stringset.h 2008-07-04 15:03:47.000000000 +0100
+@@ -24,6 +24,7 @@
+ #include <stdexcept>
+ #include <cmath>
+ #include <climits>
++#include <cstring>
+ #ifdef __WXMSW__
+ #include <mem.h>
+ #endif
+diff -ur src/wrapregex.cpp src/wrapregex.cpp
+--- src/wrapregex.cpp 2008-01-20 20:14:24.000000000 +0000
++++ src/wrapregex.cpp 2008-07-04 15:03:47.000000000 +0100
+@@ -21,6 +21,7 @@
+ #include <string>
+ #include <ctype.h>
+ #include <stdexcept>
++#include <cstring>
+ #include "wrapregex.h"
+ #include "contexthandler.h"
+
+diff -ur src/xmlassociatedtd.h src/xmlassociatedtd.h
+--- src/xmlassociatedtd.h 2008-01-20 20:14:30.000000000 +0000
++++ src/xmlassociatedtd.h 2008-07-04 15:03:47.000000000 +0100
+@@ -23,6 +23,7 @@
+ #include <vector>
+ #include <expat.h>
+ #include <string>
++#include <memory>
+ #include "wrapexpat.h"
+
+ struct DtdData : public ParserData
+diff -ur src/xmlassociatexsd.cpp src/xmlassociatexsd.cpp
+--- src/xmlassociatexsd.cpp 2008-01-20 20:14:24.000000000 +0000
++++ src/xmlassociatexsd.cpp 2008-07-04 15:03:47.000000000 +0100
+@@ -21,6 +21,7 @@
+ #include <vector>
+ #include <stdexcept>
+ #include <expat.h>
++#include <cstring>
+ #include "xmlassociatexsd.h"
+ #include "xmlparseschemans.h"
+ #include "readfile.h"
+diff -ur src/xmlassociatexsd.h src/xmlassociatexsd.h
+--- src/xmlassociatexsd.h 2008-01-20 20:14:30.000000000 +0000
++++ src/xmlassociatexsd.h 2008-07-04 15:03:47.000000000 +0100
+@@ -24,6 +24,7 @@
+ #include <expat.h>
+ #include <string>
+ #include <map>
++#include <memory>
+ #include "wrapexpat.h"
+
+ struct AssociateXsdData : public ParserData
+diff -ur src/xmlassociatexsl.cpp src/xmlassociatexsl.cpp
+--- src/xmlassociatexsl.cpp 2008-01-20 20:14:24.000000000 +0000
++++ src/xmlassociatexsl.cpp 2008-07-04 15:03:47.000000000 +0100
+@@ -21,6 +21,7 @@
+ #include <vector>
+ #include <stdexcept>
+ #include <expat.h>
++#include <cstring>
+ #include "xmlassociatexsl.h"
+
+ XmlAssociateXsl::XmlAssociateXsl ( const std::string& path, size_t size ) :
+diff -ur src/xmlassociatexsl.h src/xmlassociatexsl.h
+--- src/xmlassociatexsl.h 2008-01-20 20:14:30.000000000 +0000
++++ src/xmlassociatexsl.h 2008-07-04 15:03:47.000000000 +0100
+@@ -23,6 +23,7 @@
+ #include <vector>
+ #include <expat.h>
+ #include <string>
++#include <memory>
+ #include "wrapexpat.h"
+
+ struct XslData : public ParserData
+diff -ur src/xmlencodinghandler.cpp src/xmlencodinghandler.cpp
+--- src/xmlencodinghandler.cpp 2008-01-20 20:14:24.000000000 +0000
++++ src/xmlencodinghandler.cpp 2008-07-04 15:03:47.000000000 +0100
+@@ -17,6 +17,7 @@
+ * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+ */
+
++#include <cstring>
+ #include "xmlencodinghandler.h"
+
+ bool XmlEncodingHandler::hasDeclaration ( const std::string& utf8 )
+diff -ur src/xmlencodingspy.h src/xmlencodingspy.h
+--- src/xmlencodingspy.h 2008-01-20 20:14:30.000000000 +0000
++++ src/xmlencodingspy.h 2008-07-04 15:03:47.000000000 +0100
+@@ -22,6 +22,7 @@
+
+ #include <expat.h>
+ #include <string>
++#include <memory>
+ #include "wrapexpat.h"
+
+ struct EncodingData : public ParserData
+diff -ur src/xmlfilterreader.cpp src/xmlfilterreader.cpp
+--- src/xmlfilterreader.cpp 2008-01-20 20:14:24.000000000 +0000
++++ src/xmlfilterreader.cpp 2008-07-04 15:03:47.000000000 +0100
+@@ -23,6 +23,7 @@
+ #include <expat.h>
+ #include <map>
+ #include <set>
++#include <cstring>
+ #include "xmlfilterreader.h"
+
+ using namespace std;
+diff -ur src/xmlfilterreader.h src/xmlfilterreader.h
+--- src/xmlfilterreader.h 2008-01-20 20:14:30.000000000 +0000
++++ src/xmlfilterreader.h 2008-07-04 15:03:47.000000000 +0100
+@@ -24,6 +24,7 @@
+ #include <vector>
+ #include <map>
+ #include <set>
++#include <memory>
+ #include <expat.h>
+ #include "wrapexpat.h"
+
+diff -ur src/xmlparseschemans.h src/xmlparseschemans.h
+--- src/xmlparseschemans.h 2008-01-20 20:14:30.000000000 +0000
++++ src/xmlparseschemans.h 2008-07-04 15:03:47.000000000 +0100
+@@ -23,6 +23,7 @@
+ #include <vector>
+ #include <expat.h>
+ #include <string>
++#include <memory>
+ #include "wrapexpat.h"
+
+ struct ParseSchemaNsData : public ParserData
+diff -ur src/xmlpromptgenerator.h src/xmlpromptgenerator.h
+--- src/xmlpromptgenerator.h 2008-01-20 20:14:30.000000000 +0000
++++ src/xmlpromptgenerator.h 2008-07-04 15:03:47.000000000 +0100
+@@ -23,6 +23,7 @@
+ #include <expat.h>
+ #include <map>
+ #include <set>
++#include <memory>
+ #include "wrapexpat.h"
+ #include "parserdata.h"
+
+diff -ur src/xmlschemalocator.cpp src/xmlschemalocator.cpp
+--- src/xmlschemalocator.cpp 2008-01-20 20:14:24.000000000 +0000
++++ src/xmlschemalocator.cpp 2008-07-04 15:03:47.000000000 +0100
+@@ -20,6 +20,7 @@
+ #include <string>
+ #include <vector>
+ #include <stdexcept>
++#include <cstring>
+ #include <expat.h>
+ #include "xmlschemalocator.h"
+
+diff -ur src/xmlschemalocator.h src/xmlschemalocator.h
+--- src/xmlschemalocator.h 2008-01-20 20:14:30.000000000 +0000
++++ src/xmlschemalocator.h 2008-07-04 15:03:47.000000000 +0100
+@@ -22,6 +22,7 @@
+
+ #include <expat.h>
+ #include <string>
++#include <memory>
+ #include "wrapexpat.h"
+
+ struct SchemaLocatorData
+diff -ur src/xmlshallowvalidator.h src/xmlshallowvalidator.h
+--- src/xmlshallowvalidator.h 2008-01-20 20:14:30.000000000 +0000
++++ src/xmlshallowvalidator.h 2008-07-04 15:03:47.000000000 +0100
+@@ -25,6 +25,7 @@
+ #include <set>
+ #include <vector>
+ #include <utility>
++#include <memory>
+ #include <expat.h>
+ #include "wrapexpat.h"
+
+diff -ur src/xmlutf8reader.h src/xmlutf8reader.h
+--- src/xmlutf8reader.h 2008-01-20 20:14:30.000000000 +0000
++++ src/xmlutf8reader.h 2008-07-04 15:03:47.000000000 +0100
+@@ -23,6 +23,7 @@
+ #include <vector>
+ #include <expat.h>
+ #include <string>
++#include <memory>
+ #include "wrapexpat.h"
+
+ struct UtfData : public ParserData
+diff -ur src/xmlwordcount.h src/xmlwordcount.h
+--- src/xmlwordcount.h 2008-01-20 20:14:30.000000000 +0000
++++ src/xmlwordcount.h 2008-07-04 15:03:47.000000000 +0100
+@@ -21,6 +21,7 @@
+ #define XML_WORD_COUNT_H
+
+ #include <string>
++#include <memory>
+ #include "wrapexpat.h"
+
+ struct WordCountData : public ParserData
+diff -ur src/xsllocator.cpp src/xsllocator.cpp
+--- src/xsllocator.cpp 2008-01-20 20:14:24.000000000 +0000
++++ src/xsllocator.cpp 2008-07-04 15:03:47.000000000 +0100
+@@ -20,6 +20,7 @@
+ #include <string>
+ #include <vector>
+ #include <stdexcept>
++#include <cstring>
+ #include <expat.h>
+ #include "xsllocator.h"
+
+diff -ur src/xsllocator.h src/xsllocator.h
+--- src/xsllocator.h 2008-01-20 20:14:30.000000000 +0000
++++ src/xsllocator.h 2008-07-04 15:03:47.000000000 +0100
+@@ -22,6 +22,7 @@
+
+ #include <expat.h>
+ #include <string>
++#include <memory>
+ #include "wrapexpat.h"
+
+ struct XslLocatorData : public ParserData
diff --git a/app-editors/xmlcopyeditor/xmlcopyeditor-1.1.0.6.ebuild b/app-editors/xmlcopyeditor/xmlcopyeditor-1.1.0.6.ebuild
index 1413df65a6d0..dc51fc4e8933 100644
--- a/app-editors/xmlcopyeditor/xmlcopyeditor-1.1.0.6.ebuild
+++ b/app-editors/xmlcopyeditor/xmlcopyeditor-1.1.0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xmlcopyeditor/xmlcopyeditor-1.1.0.6.ebuild,v 1.1 2008/01/23 00:23:37 yoswink Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xmlcopyeditor/xmlcopyeditor-1.1.0.6.ebuild,v 1.2 2008/07/04 19:43:04 yoswink Exp $
WX_GTK_VER="2.8"
@@ -22,6 +22,13 @@ DEPEND="dev-libs/xerces-c \
app-text/aspell \
=x11-libs/wxGTK-2.8*"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/gcc-4.3-header-dependency.patch"
+}
+
src_install() {
emake DESTDIR="${D}" install || die "make install failed"
diff --git a/app-editors/xmlcopyeditor/xmlcopyeditor-1.1.0.7.ebuild b/app-editors/xmlcopyeditor/xmlcopyeditor-1.1.0.7.ebuild
index 3e5ef51d91ea..15879bd097ad 100644
--- a/app-editors/xmlcopyeditor/xmlcopyeditor-1.1.0.7.ebuild
+++ b/app-editors/xmlcopyeditor/xmlcopyeditor-1.1.0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xmlcopyeditor/xmlcopyeditor-1.1.0.7.ebuild,v 1.1 2008/07/03 22:24:36 yoswink Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xmlcopyeditor/xmlcopyeditor-1.1.0.7.ebuild,v 1.2 2008/07/04 19:43:04 yoswink Exp $
WX_GTK_VER="2.8"
@@ -22,6 +22,13 @@ DEPEND="dev-libs/xerces-c \
app-text/aspell \
=x11-libs/wxGTK-2.8*"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/gcc-4.3-header-dependency.patch"
+}
+
src_install() {
emake DESTDIR="${D}" install || die "make install failed"