summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2007-06-25 21:21:16 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2007-06-25 21:21:16 +0000
commitaae870c59cb95e1df207ce13225fed94df2b30ba (patch)
tree859c8feeb8442d1f8a55f18d7165af353f4d2b80 /app-editors
parentStable on sparc wrt security #181385 (diff)
downloadgentoo-2-aae870c59cb95e1df207ce13225fed94df2b30ba.tar.gz
gentoo-2-aae870c59cb95e1df207ce13225fed94df2b30ba.tar.bz2
gentoo-2-aae870c59cb95e1df207ce13225fed94df2b30ba.zip
Version bump.
(Portage version: 2.1.3_rc5)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/scite/ChangeLog8
-rw-r--r--app-editors/scite/files/digest-scite-1.743
-rw-r--r--app-editors/scite/files/scite-1.74-install.patch20
-rw-r--r--app-editors/scite/scite-1.74.ebuild73
4 files changed, 103 insertions, 1 deletions
diff --git a/app-editors/scite/ChangeLog b/app-editors/scite/ChangeLog
index 762bbda681a9..3d278872598d 100644
--- a/app-editors/scite/ChangeLog
+++ b/app-editors/scite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/scite
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/ChangeLog,v 1.66 2007/04/21 12:47:58 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/ChangeLog,v 1.67 2007/06/25 21:21:16 nelchael Exp $
+
+*scite-1.74 (25 Jun 2007)
+
+ 25 Jun 2007; Krzysiek Pawlik <nelchael@gentoo.org>
+ +files/scite-1.74-install.patch, +scite-1.74.ebuild:
+ Version bump.
21 Apr 2007; Krzysiek Pawlik <nelchael@gentoo.org>
-files/scite-1.73-iconv.patch, scite-1.73.ebuild:
diff --git a/app-editors/scite/files/digest-scite-1.74 b/app-editors/scite/files/digest-scite-1.74
new file mode 100644
index 000000000000..45bfff129f9d
--- /dev/null
+++ b/app-editors/scite/files/digest-scite-1.74
@@ -0,0 +1,3 @@
+MD5 09ad25f1fa6dab3feec41dba2480047f scite174.tgz 1460459
+RMD160 a4547865bf2884108fbfbc8eaae1c7d1200ddd47 scite174.tgz 1460459
+SHA256 10640a1c4bde4b1f5726085c95f7a139a044853911ebeaffa58f42aa26359e01 scite174.tgz 1460459
diff --git a/app-editors/scite/files/scite-1.74-install.patch b/app-editors/scite/files/scite-1.74-install.patch
new file mode 100644
index 000000000000..c1d87501c855
--- /dev/null
+++ b/app-editors/scite/files/scite-1.74-install.patch
@@ -0,0 +1,20 @@
+--- scite/gtk/makefile.orig 2006-10-09 06:26:55 -0300
++++ scite/gtk/makefile 2006-10-09 06:36:09 -0300
+@@ -123,11 +123,14 @@
+
+ ifdef gnomeprefix
+ ifdef GTK2
+- $(INSTALL) -m 755 -D SciTE.desktop $(DESTDIR)$(datadir)/applications/SciTE.desktop
++ $(INSTALL) -m 755 -d $(DESTDIR)$(datadir)/applications/
++ $(INSTALL) -m 755 SciTE.desktop $(DESTDIR)$(datadir)/applications/
+ else
+- $(INSTALL) -m 755 -D SciTE.desktop $(DESTDIR)$(datadir)/applications/SciTE.desktop
++ $(INSTALL) -m 755 -d $(DESTDIR)$(datadir)/applications/
++ $(INSTALL) -m 755 SciTE.desktop $(DESTDIR)$(datadir)/applications/
+ endif
+- $(INSTALL) -m 644 -D Sci48M.png $(DESTDIR)$(pixmapdir)/Sci48M.png
++ $(INSTALL) -m 644 -d $(DESTDIR)$(pixmapdir)/
++ $(INSTALL) -m 644 Sci48M.png $(DESTDIR)$(pixmapdir)/Sci48M.png
+ endif
+
+ uninstall:
diff --git a/app-editors/scite/scite-1.74.ebuild b/app-editors/scite/scite-1.74.ebuild
new file mode 100644
index 000000000000..a3b882c86cce
--- /dev/null
+++ b/app-editors/scite/scite-1.74.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/scite-1.74.ebuild,v 1.1 2007/06/25 21:21:16 nelchael Exp $
+
+inherit toolchain-funcs eutils
+
+MY_PV=${PV//./}
+DESCRIPTION="A very powerful editor for programmers"
+HOMEPAGE="http://scintilla.sourceforge.net/SciTE.html"
+SRC_URI="mirror://sourceforge/scintilla/${PN}${MY_PV}.tgz"
+
+LICENSE="Scintilla"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="lua"
+
+RDEPEND=">=x11-libs/gtk+-2
+ lua? ( >=dev-lang/lua-5 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=sys-apps/sed-4"
+
+S=${WORKDIR}/${PN}/gtk
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}/scintilla/gtk
+ sed -i makefile \
+ -e "s#^CXXFLAGS=#CXXFLAGS=${CXXFLAGS} #" \
+ -e "s#^\(CXXFLAGS=.*\)-Os#\1#" \
+ -e "s#^CC =\(.*\)#CC = $(tc-getCXX)#" \
+ || die "error patching makefile"
+
+ cd ${S}
+ sed -i makefile \
+ -e 's#usr/local#usr#g' \
+ -e 's#/gnome/apps/Applications#/applications#' \
+ -e "s#^CXXFLAGS=#CXXFLAGS=${CXXFLAGS} #" \
+ -e "s#^\(CXXFLAGS=.*\)-Os#\1#" \
+ -e "s#^CC =\(.*\)#CC = $(tc-getCXX)#" \
+ -e 's#${D}##' \
+ -e 's#-g root#-g 0#' \
+ || die "error patching makefile"
+ epatch ${FILESDIR}/${P}-install.patch
+}
+
+src_compile() {
+ make -C ../../scintilla/gtk || die "prep make failed"
+ if use lua; then
+ emake || die "make failed"
+ else
+ emake NO_LUA=1 || die "make failed"
+ fi
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/share/{pixmaps,applications}
+
+ make prefix=${D}/usr install || die
+
+ # we have to keep this because otherwise it'll break upgrading
+ mv ${D}/usr/bin/SciTE ${D}/usr/bin/scite
+ dosym /usr/bin/scite /usr/bin/SciTE
+
+ # replace .desktop file with our own working version
+ insinto /usr/share/applications
+ rm -f ${D}/usr/share/applications/SciTE.desktop
+ doins ${FILESDIR}/scite.desktop
+
+ doman ../doc/scite.1
+ dodoc ../README
+}