summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-02-10 22:13:23 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-02-10 22:13:23 +0000
commit2748a6436385fe0a42341e6d4b6dbc17ecb2dd63 (patch)
tree8a2916512eec0c7b71d648e940eab37c2e2f4e8b /app-emacs/haskell-mode
parentMasked udev-104-r10 for testing. (diff)
downloadgentoo-2-2748a6436385fe0a42341e6d4b6dbc17ecb2dd63.tar.gz
gentoo-2-2748a6436385fe0a42341e6d4b6dbc17ecb2dd63.tar.bz2
gentoo-2-2748a6436385fe0a42341e6d4b6dbc17ecb2dd63.zip
version bump, reported by Bas van Dijk <basvandijk@home.nl> in bug 166183
(Portage version: 2.1.2-r9)
Diffstat (limited to 'app-emacs/haskell-mode')
-rw-r--r--app-emacs/haskell-mode/ChangeLog8
-rw-r--r--app-emacs/haskell-mode/files/digest-haskell-mode-2.23
-rw-r--r--app-emacs/haskell-mode/haskell-mode-2.2.ebuild35
3 files changed, 45 insertions, 1 deletions
diff --git a/app-emacs/haskell-mode/ChangeLog b/app-emacs/haskell-mode/ChangeLog
index 9144ab9bfe89..51076356227a 100644
--- a/app-emacs/haskell-mode/ChangeLog
+++ b/app-emacs/haskell-mode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/haskell-mode
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/haskell-mode/ChangeLog,v 1.17 2007/01/28 04:16:00 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/haskell-mode/ChangeLog,v 1.18 2007/02/10 22:13:23 opfer Exp $
+
+*haskell-mode-2.2 (10 Feb 2007)
+
+ 10 Feb 2007; Christian Faulhammer <opfer@gentoo.org>
+ +haskell-mode-2.2.ebuild:
+ version bump, reported by Bas van Dijk <basvandijk@home.nl> in bug 166183
28 Jan 2007; Marius Mauch <genone@gentoo.org> haskell-mode-1.44-r1.ebuild,
haskell-mode-1.45.ebuild, haskell-mode-2.0.ebuild,
diff --git a/app-emacs/haskell-mode/files/digest-haskell-mode-2.2 b/app-emacs/haskell-mode/files/digest-haskell-mode-2.2
new file mode 100644
index 000000000000..f1b87cc57bde
--- /dev/null
+++ b/app-emacs/haskell-mode/files/digest-haskell-mode-2.2
@@ -0,0 +1,3 @@
+MD5 c911d1d2e8c7864834ab37e6cd7fcbbf haskell-mode-2.2.tar.gz 77480
+RMD160 3c813001a7c5243fcb5d79034ffdbbb7ca2585f7 haskell-mode-2.2.tar.gz 77480
+SHA256 0bcc23ad01f88386b9e54f30a94b819761ee32ea4b0093f63cf9fea6b3e362cf haskell-mode-2.2.tar.gz 77480
diff --git a/app-emacs/haskell-mode/haskell-mode-2.2.ebuild b/app-emacs/haskell-mode/haskell-mode-2.2.ebuild
new file mode 100644
index 000000000000..bfd68f358fbb
--- /dev/null
+++ b/app-emacs/haskell-mode/haskell-mode-2.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/haskell-mode/haskell-mode-2.2.ebuild,v 1.1 2007/02/10 22:13:23 opfer Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Mode for editing (and running) Haskell programs in Emacs"
+HOMEPAGE="http://www.haskell.org/haskell-mode/
+ http://www.iro.umontreal.ca/~monnier/elisp/"
+SRC_URI="http://www.iro.umontreal.ca/~monnier/elisp/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64 ~sparc"
+
+SITEFILE="51${PN}-gentoo.el"
+
+src_compile() {
+ elisp-comp *.el || die
+}
+
+src_install() {
+ elisp-install ${PN} *.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dohtml *.html *.hs
+ dodoc ChangeLog NEWS
+ insinto /usr/share/doc/${PF}
+ doins *.hs
+}
+
+pkg_postinst() {
+ elisp_pkg_postinst
+ elog "See /usr/share/doc/${PF}/html/installation-guide.html"
+} \ No newline at end of file