summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-04-02 22:32:51 +0000
committerDan Armak <danarmak@gentoo.org>2002-04-02 22:32:51 +0000
commitcec3229401de4dfc251a93da87c2baee57b36d6f (patch)
tree4c5d2602fe3e542292c1a9d7e3ff58ffb4d40dd9 /app-emulation/bochs/bochs-1.4.ebuild
parent*** empty log message *** (diff)
downloadgentoo-2-cec3229401de4dfc251a93da87c2baee57b36d6f.tar.gz
gentoo-2-cec3229401de4dfc251a93da87c2baee57b36d6f.tar.bz2
gentoo-2-cec3229401de4dfc251a93da87c2baee57b36d6f.zip
new upstream version, lots of new stuff in it
Diffstat (limited to 'app-emulation/bochs/bochs-1.4.ebuild')
-rw-r--r--app-emulation/bochs/bochs-1.4.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-emulation/bochs/bochs-1.4.ebuild b/app-emulation/bochs/bochs-1.4.ebuild
new file mode 100644
index 000000000000..e49c111afbc5
--- /dev/null
+++ b/app-emulation/bochs/bochs-1.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Chris Arndt <arndtc@mailandnews.com>
+# Maintainer: Dan Armak <danarmak@gentoo.org>
+
+PN=${P/_/.}
+S=${WORKDIR}/${PN}
+DESCRIPTION="Bochs is a pc emulator.
+ This ebuild is set up to emulate a Pentium, with a NE2000 network card, and a
+CDROM drive.
+ It also comes with a disk image using dlxlinux."
+SRC_URI="http://prdownloads.sourceforge.net/bochs/${PN}.tar.gz
+ http://bochs.sourceforge.net/guestos/dlxlinux3.tar.gz"
+HOMEPAGE="http://bochs.sourceforge.net"
+
+#build-time dependencies
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=x11-base/xfree-4.0.1"
+
+src_unpack() {
+
+ unpack ${PN}.tar.gz
+
+ cd $S
+ cp Makefile.in Makefile.in.orig
+ sed -e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux3.tar.gz .:" \
+ -e 's: $(prefix): $(DESTDIR)$(prefix):g' \
+ -e 's: $(bindir): $(DESTDIR)$(bindir):g' \
+ -e 's: $(BOCHSDIR): $(DESTDIR)$(BOCHSDIR):g' Makefile.in.orig > Makefile.in
+
+}
+
+src_compile() {
+
+ ./configure --enable-fpu --enable-cdrom --enable-control-panel \
+ --enable-ne2000 --enable-sb16=linux -enable-slowdown --prefix=/usr \
+ --infodir=/usr/share/info --mandir=/usr/share/man --host=${CHOST} --with-x11 || die
+
+ # there's an sdl interface now, but since we an only compile 1 interface at a time
+ # i'd rather have xwindows.
+
+ emake || die
+}
+
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+ dodoc CHANGES COPYING CVS README TESTFORM.txt
+}
+