summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-03-13 19:11:52 +0000
committerPacho Ramos <pacho@gentoo.org>2010-03-13 19:11:52 +0000
commit07b6dadf3e1e5811f710f038c03130a3fb56c9b9 (patch)
tree361912a956f377237c04a0a0ca2b4a579981c5b4 /app-emulation/emul-linux-x86-soundlibs
parentVersion bump (diff)
downloadgentoo-2-07b6dadf3e1e5811f710f038c03130a3fb56c9b9.tar.gz
gentoo-2-07b6dadf3e1e5811f710f038c03130a3fb56c9b9.tar.bz2
gentoo-2-07b6dadf3e1e5811f710f038c03130a3fb56c9b9.zip
Fix bug 307893
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/emul-linux-x86-soundlibs')
-rw-r--r--app-emulation/emul-linux-x86-soundlibs/ChangeLog9
-rw-r--r--app-emulation/emul-linux-x86-soundlibs/emul-linux-x86-soundlibs-20100220-r1.ebuild41
2 files changed, 49 insertions, 1 deletions
diff --git a/app-emulation/emul-linux-x86-soundlibs/ChangeLog b/app-emulation/emul-linux-x86-soundlibs/ChangeLog
index 44771cbb45e2..4c744a0f51a6 100644
--- a/app-emulation/emul-linux-x86-soundlibs/ChangeLog
+++ b/app-emulation/emul-linux-x86-soundlibs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/emul-linux-x86-soundlibs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-soundlibs/ChangeLog,v 1.56 2010/02/20 23:10:16 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-soundlibs/ChangeLog,v 1.57 2010/03/13 19:11:52 pacho Exp $
+
+*emul-linux-x86-soundlibs-20100220-r1 (13 Mar 2010)
+
+ 13 Mar 2010; Pacho Ramos <pacho@gentoo.org>
+ +emul-linux-x86-soundlibs-20100220-r1.ebuild:
+ Fix bug 307893 to provide media-libs/libmikmod:2, that will be included in
+ tarball in the next emul round.
*emul-linux-x86-soundlibs-20100220 (20 Feb 2010)
diff --git a/app-emulation/emul-linux-x86-soundlibs/emul-linux-x86-soundlibs-20100220-r1.ebuild b/app-emulation/emul-linux-x86-soundlibs/emul-linux-x86-soundlibs-20100220-r1.ebuild
new file mode 100644
index 000000000000..37758a6ea803
--- /dev/null
+++ b/app-emulation/emul-linux-x86-soundlibs/emul-linux-x86-soundlibs-20100220-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-soundlibs/emul-linux-x86-soundlibs-20100220-r1.ebuild,v 1.1 2010/03/13 19:11:52 pacho Exp $
+
+inherit emul-linux-x86
+
+SRC_URI="mirror://gentoo/${PN}-${PV}.tar.bz2
+ http://dev.gentoo.org/~pacho/emul-linux-x86-${PV}/libmikmod.so.2"
+
+LICENSE="as-is BSD GPL-2 LGPL-2 LGPL-2.1 gsm"
+KEYWORDS="-* ~amd64"
+IUSE="alsa pulseaudio"
+
+RDEPEND="pulseaudio? ( media-sound/pulseaudio )
+ ~app-emulation/emul-linux-x86-baselibs-${PV}
+ ~app-emulation/emul-linux-x86-medialibs-${PV}"
+
+QA_DT_HASH="usr/lib32/.*"
+
+src_unpack() {
+ _ALLOWED="${S}/etc/env.d"
+ use alsa && _ALLOWED="${_ALLOWED}|${S}/usr/bin/aoss"
+ ALLOWED="(${_ALLOWED})"
+
+ emul-linux-x86_src_unpack
+
+ if use alsa; then
+ mv -f "${S}"/usr/bin/aoss{,32} || die
+ fi
+
+ # libs without the rest of pulseaudio cause problems, bug 302003
+ if ! use pulseaudio; then
+ rm -rf $(find "${S}" -name '*pulse*' -not -name '*impulse*') || die
+ fi
+}
+
+src_install() {
+ emul-linux-x86_src_install
+ insinto /usr/lib32/
+ doins "${DISTDIR}"/libmikmod.so.2 || die
+}