summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2011-08-23 15:36:10 +0000
committerLance Albertson <ramereth@gentoo.org>2011-08-23 15:36:10 +0000
commit549fed1dc572c0b189c4e6b758f7858e7eaeedc2 (patch)
treef0e6303777a86e55ab73db79d7237fb8bcb67a9d /app-emulation/ganeti
parentFix bug 379835, accidental dropping of optional modemmanager (diff)
downloadgentoo-2-549fed1dc572c0b189c4e6b758f7858e7eaeedc2.tar.gz
gentoo-2-549fed1dc572c0b189c4e6b758f7858e7eaeedc2.tar.bz2
gentoo-2-549fed1dc572c0b189c4e6b758f7858e7eaeedc2.zip
Version bump for 2.4.4, start-stop-daemon patch fixes
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/ganeti')
-rw-r--r--app-emulation/ganeti/ChangeLog11
-rw-r--r--app-emulation/ganeti/files/ganeti-fix-start-stop.patch (renamed from app-emulation/ganeti/files/ganeti-2.4.3-fix-start-stop.patch)0
-rw-r--r--app-emulation/ganeti/ganeti-2.4.3.ebuild4
-rw-r--r--app-emulation/ganeti/ganeti-2.4.4.ebuild91
-rw-r--r--app-emulation/ganeti/ganeti-2.5.0_beta2.ebuild3
5 files changed, 105 insertions, 4 deletions
diff --git a/app-emulation/ganeti/ChangeLog b/app-emulation/ganeti/ChangeLog
index 81eb418a3cab..bc210053d2c2 100644
--- a/app-emulation/ganeti/ChangeLog
+++ b/app-emulation/ganeti/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-emulation/ganeti
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ChangeLog,v 1.52 2011/08/22 16:11:20 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ChangeLog,v 1.53 2011/08/23 15:36:10 ramereth Exp $
+
+*ganeti-2.4.4 (23 Aug 2011)
+
+ 23 Aug 2011; Lance Albertson <ramereth@gentoo.org> ganeti-2.4.3.ebuild,
+ -files/ganeti-2.4.3-fix-start-stop.patch, +ganeti-2.4.4.ebuild,
+ ganeti-2.5.0_beta2.ebuild, +files/ganeti-fix-start-stop.patch:
+ Version bump for 2.4.4, start-stop-daemon patch fixes
+
+ Move to a unified patch that should work across the versions for a while.
*ganeti-2.5.0_beta2 (22 Aug 2011)
diff --git a/app-emulation/ganeti/files/ganeti-2.4.3-fix-start-stop.patch b/app-emulation/ganeti/files/ganeti-fix-start-stop.patch
index e53161a00b22..e53161a00b22 100644
--- a/app-emulation/ganeti/files/ganeti-2.4.3-fix-start-stop.patch
+++ b/app-emulation/ganeti/files/ganeti-fix-start-stop.patch
diff --git a/app-emulation/ganeti/ganeti-2.4.3.ebuild b/app-emulation/ganeti/ganeti-2.4.3.ebuild
index 439728e6874a..34c3aa1a3bfc 100644
--- a/app-emulation/ganeti/ganeti-2.4.3.ebuild
+++ b/app-emulation/ganeti/ganeti-2.4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ganeti-2.4.3.ebuild,v 1.2 2011/08/10 17:43:07 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ganeti-2.4.3.ebuild,v 1.3 2011/08/23 15:36:10 ramereth Exp $
EAPI=2
@@ -47,7 +47,7 @@ pkg_setup () {
}
src_prepare () {
- epatch "${FILESDIR}/${P}-fix-start-stop.patch"
+ epatch "${FILESDIR}/${PN}-fix-start-stop.patch"
}
src_configure () {
diff --git a/app-emulation/ganeti/ganeti-2.4.4.ebuild b/app-emulation/ganeti/ganeti-2.4.4.ebuild
new file mode 100644
index 000000000000..d5b8f7291d08
--- /dev/null
+++ b/app-emulation/ganeti/ganeti-2.4.4.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ganeti-2.4.4.ebuild,v 1.1 2011/08/23 15:36:10 ramereth Exp $
+
+EAPI=2
+
+inherit eutils confutils bash-completion
+
+MY_PV="${PV/_rc/~rc}"
+#MY_PV="${PV/_beta/~beta}"
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="Ganeti is a virtual server management software tool"
+HOMEPAGE="http://code.google.com/p/ganeti/"
+SRC_URI="http://ganeti.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="kvm xen drbd +filestorage syslog ipv6"
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="xen? ( >=app-emulation/xen-3.0 )
+ kvm? ( app-emulation/qemu-kvm )
+ drbd? ( >=sys-cluster/drbd-8.3 )
+ ipv6? ( net-misc/ndisc6 )
+ dev-libs/openssl
+ dev-python/paramiko
+ dev-python/pyopenssl
+ dev-python/pyparsing
+ dev-python/pycurl
+ dev-python/pyinotify
+ dev-python/simplejson
+ net-analyzer/arping
+ net-misc/bridge-utils
+ net-misc/curl[ssl]
+ net-misc/openssh
+ net-misc/socat
+ sys-apps/iproute2
+ sys-fs/lvm2
+ >=sys-apps/baselayout-2.0"
+RDEPEND="${DEPEND}
+ !<app-emulation/ganeti-htools-0.3"
+
+pkg_setup () {
+ confutils_require_any kvm xen
+}
+
+src_prepare () {
+ epatch "${FILESDIR}/${PN}-fix-start-stop.patch"
+}
+
+src_configure () {
+ local myconf
+ if use filestorage ; then
+ myconf="--with-file-storage-dir=/var/lib/ganeti-storage/file"
+ else
+ myconf="--with-file-storage-dir=no"
+ fi
+ econf --localstatedir=/var \
+ --docdir=/usr/share/doc/${P} \
+ --with-ssh-initscript=/etc/init.d/sshd \
+ --with-export-dir=/var/lib/ganeti-storage/export \
+ --with-os-search-path=/usr/share/ganeti/os \
+ $(use_enable syslog) \
+ ${myconf}
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ newinitd "${FILESDIR}"/ganeti-2.1.initd ganeti
+ newconfd "${FILESDIR}"/ganeti.confd ganeti
+ use kvm && newinitd "${FILESDIR}"/ganeti-kvm-poweroff.initd ganeti-kvm-poweroff
+ use kvm && newconfd "${FILESDIR}"/ganeti-kvm-poweroff.confd ganeti-kvm-poweroff
+ dobashcompletion doc/examples/bash_completion ganeti
+ dodoc INSTALL UPGRADE NEWS README doc/*.rst
+ rm -rf "${D}"/usr/share/doc/ganeti
+ docinto examples
+ #dodoc doc/examples/{basic-oob,ganeti.cron,gnt-config-backup}
+ dodoc doc/examples/{ganeti.cron,gnt-config-backup}
+ docinto examples/hooks
+ dodoc doc/examples/hooks/{ipsec,ethers}
+
+ keepdir /var/{lib,log,run}/ganeti/
+ keepdir /usr/share/ganeti/os/
+ keepdir /var/lib/ganeti-storage/{export,file}/
+}
+
+pkg_postinst () {
+ bash-completion_pkg_postinst
+}
diff --git a/app-emulation/ganeti/ganeti-2.5.0_beta2.ebuild b/app-emulation/ganeti/ganeti-2.5.0_beta2.ebuild
index c6eb0aaca1c5..37580c4609a2 100644
--- a/app-emulation/ganeti/ganeti-2.5.0_beta2.ebuild
+++ b/app-emulation/ganeti/ganeti-2.5.0_beta2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ganeti-2.5.0_beta2.ebuild,v 1.1 2011/08/22 16:11:20 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ganeti-2.5.0_beta2.ebuild,v 1.2 2011/08/23 15:36:10 ramereth Exp $
EAPI="4"
@@ -77,6 +77,7 @@ src_prepare() {
if [[ ${PV} == "9999" ]] ; then
./autogen.sh
fi
+ epatch "${FILESDIR}/${PN}-fix-start-stop.patch"
}
src_configure () {