summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2010-04-29 01:55:05 +0000
committerDoug Goldstein <cardoe@gentoo.org>2010-04-29 01:55:05 +0000
commit8bafa74fd78c26e5e7405c0cdc9da5d6372bf98a (patch)
treedc1f82663a59bf44573f14ab24f07edbdd525e62 /app-emulation/kvm-kmod
parentUse more appropriate Python getter functions. (diff)
downloadgentoo-2-8bafa74fd78c26e5e7405c0cdc9da5d6372bf98a.tar.gz
gentoo-2-8bafa74fd78c26e5e7405c0cdc9da5d6372bf98a.tar.bz2
gentoo-2-8bafa74fd78c26e5e7405c0cdc9da5d6372bf98a.zip
drop older versions
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/kvm-kmod')
-rw-r--r--app-emulation/kvm-kmod/ChangeLog6
-rw-r--r--app-emulation/kvm-kmod/kvm-kmod-2.6.32.2.ebuild66
-rw-r--r--app-emulation/kvm-kmod/kvm-kmod-2.6.32.3.ebuild66
3 files changed, 5 insertions, 133 deletions
diff --git a/app-emulation/kvm-kmod/ChangeLog b/app-emulation/kvm-kmod/ChangeLog
index 3355c67154b8..93a8b620872d 100644
--- a/app-emulation/kvm-kmod/ChangeLog
+++ b/app-emulation/kvm-kmod/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/kvm-kmod
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm-kmod/ChangeLog,v 1.8 2010/02/01 08:38:00 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm-kmod/ChangeLog,v 1.9 2010/04/29 01:55:05 cardoe Exp $
+
+ 29 Apr 2010; Doug Goldstein <cardoe@gentoo.org> -kvm-kmod-2.6.32.2.ebuild,
+ -kvm-kmod-2.6.32.3.ebuild:
+ drop older versions
*kvm-kmod-2.6.32.7 (01 Feb 2010)
diff --git a/app-emulation/kvm-kmod/kvm-kmod-2.6.32.2.ebuild b/app-emulation/kvm-kmod/kvm-kmod-2.6.32.2.ebuild
deleted file mode 100644
index 9614d1df753c..000000000000
--- a/app-emulation/kvm-kmod/kvm-kmod-2.6.32.2.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm-kmod/kvm-kmod-2.6.32.2.ebuild,v 1.2 2010/01/05 23:02:58 mr_bones_ Exp $
-
-EAPI="2"
-
-inherit eutils linux-mod
-
-SRC_URI="mirror://sourceforge/kvm/${P}.tar.bz2"
-
-DESCRIPTION="Kernel-based Virtual Machine kernel modules"
-HOMEPAGE="http://www.linux-kvm.org"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
-IUSE=""
-RESTRICT="test"
-
-RDEPEND=""
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- linux-info_pkg_setup
- if ! linux_chkconfig_present KVM; then
- eerror "KVM now needs CONFIG_KVM built into your kernel, even"
- eerror "if you're using the external modules from this package."
- eerror "Please enable KVM support in your kernel, found at:"
- eerror
- eerror " Virtualization"
- eerror " Kernel-based Virtual Machine (KVM) support"
- eerror
- die "KVM support not detected!"
- fi
- BUILD_TARGETS="all"
- MODULE_NAMES="kvm(kernel/arch/x86/kvm/:${S}:${S}/x86)"
- MODULE_NAMES="${MODULE_NAMES} kvm-intel(kernel/arch/x86/kvm/:${S}:${S}/x86)"
- MODULE_NAMES="${MODULE_NAMES} kvm-amd(kernel/arch/x86/kvm/:${S}:${S}/x86)"
- linux-mod_pkg_setup
-}
-
-src_configure() {
- local conf_opts
-
- conf_opts="--kerneldir=$KV_DIR"
-
- if has_multilib_profile && [[ "${DEFAULT_ABI}" == "x86" ]] ; then
- conf_opts="$conf_opts --arch=x86"
- fi
-
- ./configure ${conf_opts} || die "configure failed"
-}
-
-src_compile() {
- linux-mod_src_compile
-}
-
-src_install() {
- linux-mod_src_install
-}
-
-pkg_preinst() {
- find /lib/modules/${KV_FULL} -name 'kvm*.ko' -type f -delete
-
- linux-mod_pkg_preinst
-}
diff --git a/app-emulation/kvm-kmod/kvm-kmod-2.6.32.3.ebuild b/app-emulation/kvm-kmod/kvm-kmod-2.6.32.3.ebuild
deleted file mode 100644
index e58b74d8850f..000000000000
--- a/app-emulation/kvm-kmod/kvm-kmod-2.6.32.3.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm-kmod/kvm-kmod-2.6.32.3.ebuild,v 1.1 2010/01/12 06:12:24 cardoe Exp $
-
-EAPI="2"
-
-inherit eutils linux-mod
-
-SRC_URI="mirror://sourceforge/kvm/${P}.tar.bz2"
-
-DESCRIPTION="Kernel-based Virtual Machine kernel modules"
-HOMEPAGE="http://www.linux-kvm.org"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
-IUSE=""
-RESTRICT="test"
-
-RDEPEND=""
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- linux-info_pkg_setup
- if ! linux_chkconfig_present KVM; then
- eerror "KVM now needs CONFIG_KVM built into your kernel, even"
- eerror "if you're using the external modules from this package."
- eerror "Please enable KVM support in your kernel, found at:"
- eerror
- eerror " Virtualization"
- eerror " Kernel-based Virtual Machine (KVM) support"
- eerror
- die "KVM support not detected!"
- fi
- BUILD_TARGETS="all"
- MODULE_NAMES="kvm(kernel/arch/x86/kvm/:${S}:${S}/x86)"
- MODULE_NAMES="${MODULE_NAMES} kvm-intel(kernel/arch/x86/kvm/:${S}:${S}/x86)"
- MODULE_NAMES="${MODULE_NAMES} kvm-amd(kernel/arch/x86/kvm/:${S}:${S}/x86)"
- linux-mod_pkg_setup
-}
-
-src_configure() {
- local conf_opts
-
- conf_opts="--kerneldir=$KV_DIR"
-
- if has_multilib_profile && [[ "${DEFAULT_ABI}" == "x86" ]] ; then
- conf_opts="$conf_opts --arch=x86"
- fi
-
- ./configure ${conf_opts} || die "configure failed"
-}
-
-src_compile() {
- linux-mod_src_compile
-}
-
-src_install() {
- linux-mod_src_install
-}
-
-pkg_preinst() {
- find /lib/modules/${KV_FULL} -name 'kvm*.ko' -type f -delete
-
- linux-mod_pkg_preinst
-}