summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-01-04 06:24:39 +0000
committerTim Harder <radhermit@gentoo.org>2014-01-04 06:24:39 +0000
commite158b3e1be63313f8c86665ed6551ce6c7d24a1d (patch)
tree1fb7a2f3b74378c90c5982850e578d2701efed3c /app-emulation
parentVersion bump. (diff)
downloadgentoo-2-e158b3e1be63313f8c86665ed6551ce6c7d24a1d.tar.gz
gentoo-2-e158b3e1be63313f8c86665ed6551ce6c7d24a1d.tar.bz2
gentoo-2-e158b3e1be63313f8c86665ed6551ce6c7d24a1d.zip
Remove old.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/vagrant/ChangeLog8
-rw-r--r--app-emulation/vagrant/files/vagrant-1.3.5-rubygems2.patch42
-rw-r--r--app-emulation/vagrant/vagrant-1.2.4.ebuild68
-rw-r--r--app-emulation/vagrant/vagrant-1.2.6.ebuild67
-rw-r--r--app-emulation/vagrant/vagrant-1.2.7.ebuild67
-rw-r--r--app-emulation/vagrant/vagrant-1.3.1.ebuild67
-rw-r--r--app-emulation/vagrant/vagrant-1.3.3.ebuild67
-rw-r--r--app-emulation/vagrant/vagrant-1.3.4.ebuild67
-rw-r--r--app-emulation/vagrant/vagrant-1.3.5.ebuild68
-rw-r--r--app-emulation/vagrant/vagrant-1.4.0.ebuild67
10 files changed, 7 insertions, 581 deletions
diff --git a/app-emulation/vagrant/ChangeLog b/app-emulation/vagrant/ChangeLog
index c549a83747f4..2bb65f2e246e 100644
--- a/app-emulation/vagrant/ChangeLog
+++ b/app-emulation/vagrant/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/vagrant
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vagrant/ChangeLog,v 1.32 2014/01/04 06:23:01 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vagrant/ChangeLog,v 1.33 2014/01/04 06:24:38 radhermit Exp $
+
+ 04 Jan 2014; Tim Harder <radhermit@gentoo.org> -vagrant-1.2.4.ebuild,
+ -vagrant-1.2.6.ebuild, -vagrant-1.2.7.ebuild, -vagrant-1.3.1.ebuild,
+ -vagrant-1.3.3.ebuild, -vagrant-1.3.4.ebuild, -vagrant-1.3.5.ebuild,
+ -vagrant-1.4.0.ebuild, -files/vagrant-1.3.5-rubygems2.patch:
+ Remove old.
*vagrant-1.4.3 (04 Jan 2014)
diff --git a/app-emulation/vagrant/files/vagrant-1.3.5-rubygems2.patch b/app-emulation/vagrant/files/vagrant-1.3.5-rubygems2.patch
deleted file mode 100644
index 763fb6fd1088..000000000000
--- a/app-emulation/vagrant/files/vagrant-1.3.5-rubygems2.patch
+++ /dev/null
@@ -1,42 +0,0 @@
---- vagrant-1.3.5/plugins/commands/plugin/action/install_gem.rb
-+++ vagrant-1.3.5/plugins/commands/plugin/action/install_gem.rb
-@@ -1,6 +1,10 @@
- require "rubygems"
- require "rubygems/dependency_installer"
--require "rubygems/format"
-+begin
-+ require "rubygems/format"
-+rescue LoadError
-+ # rubygems 2.0
-+end
-
- require "log4r"
-
-@@ -26,8 +30,13 @@
- if plugin_name =~ /\.gem$/
- # If we're installing from a gem file, determine the name
- # based on the spec in the file.
-- pkg = Gem::Format.from_file_by_path(plugin_name)
-+ pkg = if defined?(Gem::Format)
-+ Gem::Format.from_file_by_path(plugin_name)
-+ else
-+ Gem::Package.new(plugin_name)
-+ end
- find_plugin_name = pkg.spec.name
-+ version = pkg.spec.version
- end
-
- # Install the gem
---- vagrant-1.3.5/plugins/commands/plugin/action/prune_gems.rb
-+++ vagrant-1.3.5/plugins/commands/plugin/action/prune_gems.rb
-@@ -126,6 +126,10 @@
-
- if prune_specs.length > 0
- env[:gem_helper].with_environment do
-+
-+ # due to a bug in rubygems 2.0, we need to load the specifications before removing any
-+ Gem::Specification.to_a
-+
- prune_specs.each do |prune_spec|
- uninstaller = Gem::Uninstaller.new(prune_spec.name, {
- :all => true,
diff --git a/app-emulation/vagrant/vagrant-1.2.4.ebuild b/app-emulation/vagrant/vagrant-1.2.4.ebuild
deleted file mode 100644
index 5eea8cb7656a..000000000000
--- a/app-emulation/vagrant/vagrant-1.2.4.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vagrant/vagrant-1.2.4.ebuild,v 1.1 2013/07/17 17:39:46 radhermit Exp $
-
-EAPI="5"
-USE_RUBY="ruby19"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
-RUBY_FAKEGEM_EXTRAINSTALL="config keys plugins templates"
-RUBY_FAKEGEM_TASK_DOC=""
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="A tool for building and distributing virtual machines using VirtualBox"
-HOMEPAGE="http://vagrantup.com/"
-SRC_URI="https://github.com/mitchellh/vagrant/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x64-macos"
-IUSE="test"
-
-# Missing ebuild for contest
-RESTRICT="test"
-
-RDEPEND="${RDEPEND}
- net-misc/curl
- !x64-macos? ( || ( app-emulation/virtualbox app-emulation/virtualbox-bin ) )"
-
-ruby_add_rdepend "
- >=dev-ruby/childprocess-0.3.7
- >=dev-ruby/erubis-2.7.0
- dev-ruby/i18n:0.6
- >=dev-ruby/json-1.5.1
- >=dev-ruby/log4r-1.1.9
- >=dev-ruby/net-ssh-2.6.6
- >=dev-ruby/net-scp-1.1.0
-"
-
-ruby_add_bdepend "
- dev-ruby/rake
- test? ( dev-ruby/mocha virtual/ruby-minitest )
-"
-
-all_ruby_prepare() {
- # remove bundler support
- sed -i '/[Bb]undler/d' Rakefile || die
- rm Gemfile || die
-
- # loosen dependencies
- sed -e '/childprocess\|erubis\|log4r\|net-scp\|net-ssh/s/~>/>=/' \
- -e '/json/s/, "< 1.8.0"//' \
- -i ${PN}.gemspec || die
-
- epatch "${FILESDIR}"/${PN}-1.2.1-no-warning.patch
- epatch "${FILESDIR}"/${PN}-1.2.2-rvm.patch
-}
-
-pkg_postinst() {
- if use x64-macos ; then
- ewarn
- ewarn "For Mac OS X prefixes, you must install the virtualbox"
- ewarn "package specifically for OS X which can be found at:"
- ewarn "https://www.virtualbox.org/wiki/Downloads"
- ewarn
- fi
-}
diff --git a/app-emulation/vagrant/vagrant-1.2.6.ebuild b/app-emulation/vagrant/vagrant-1.2.6.ebuild
deleted file mode 100644
index 13b2e0e38041..000000000000
--- a/app-emulation/vagrant/vagrant-1.2.6.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vagrant/vagrant-1.2.6.ebuild,v 1.1 2013/07/27 22:44:09 radhermit Exp $
-
-EAPI="5"
-USE_RUBY="ruby19"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
-RUBY_FAKEGEM_EXTRAINSTALL="config keys plugins templates"
-RUBY_FAKEGEM_TASK_DOC=""
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="A tool for building and distributing virtual machines using VirtualBox"
-HOMEPAGE="http://vagrantup.com/"
-SRC_URI="https://github.com/mitchellh/vagrant/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x64-macos"
-IUSE="test"
-
-# Missing ebuild for contest
-RESTRICT="test"
-
-RDEPEND="${RDEPEND}
- net-misc/curl
- !x64-macos? ( || ( app-emulation/virtualbox app-emulation/virtualbox-bin ) )"
-
-ruby_add_rdepend "
- >=dev-ruby/childprocess-0.3.7
- >=dev-ruby/erubis-2.7.0
- dev-ruby/i18n:0.6
- >=dev-ruby/json-1.5.1
- >=dev-ruby/log4r-1.1.9
- >=dev-ruby/net-ssh-2.6.6
- >=dev-ruby/net-scp-1.1.0
-"
-
-ruby_add_bdepend "
- dev-ruby/rake
- test? ( dev-ruby/mocha virtual/ruby-minitest )
-"
-
-all_ruby_prepare() {
- # remove bundler support
- sed -i '/[Bb]undler/d' Rakefile || die
- rm Gemfile || die
-
- # loosen dependencies
- sed -e '/childprocess\|erubis\|log4r\|net-scp\|net-ssh/s/~>/>=/' \
- -i ${PN}.gemspec || die
-
- epatch "${FILESDIR}"/${PN}-1.2.1-no-warning.patch
- epatch "${FILESDIR}"/${PN}-1.2.2-rvm.patch
-}
-
-pkg_postinst() {
- if use x64-macos ; then
- ewarn
- ewarn "For Mac OS X prefixes, you must install the virtualbox"
- ewarn "package specifically for OS X which can be found at:"
- ewarn "https://www.virtualbox.org/wiki/Downloads"
- ewarn
- fi
-}
diff --git a/app-emulation/vagrant/vagrant-1.2.7.ebuild b/app-emulation/vagrant/vagrant-1.2.7.ebuild
deleted file mode 100644
index 3b5ead93c07b..000000000000
--- a/app-emulation/vagrant/vagrant-1.2.7.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vagrant/vagrant-1.2.7.ebuild,v 1.1 2013/07/31 00:12:35 radhermit Exp $
-
-EAPI="5"
-USE_RUBY="ruby19"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
-RUBY_FAKEGEM_EXTRAINSTALL="config keys plugins templates"
-RUBY_FAKEGEM_TASK_DOC=""
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="A tool for building and distributing virtual machines using VirtualBox"
-HOMEPAGE="http://vagrantup.com/"
-SRC_URI="https://github.com/mitchellh/vagrant/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x64-macos"
-IUSE="test"
-
-# Missing ebuild for contest
-RESTRICT="test"
-
-RDEPEND="${RDEPEND}
- net-misc/curl
- !x64-macos? ( || ( app-emulation/virtualbox app-emulation/virtualbox-bin ) )"
-
-ruby_add_rdepend "
- >=dev-ruby/childprocess-0.3.7
- >=dev-ruby/erubis-2.7.0
- dev-ruby/i18n:0.6
- >=dev-ruby/json-1.5.1
- >=dev-ruby/log4r-1.1.9
- >=dev-ruby/net-ssh-2.6.6
- >=dev-ruby/net-scp-1.1.0
-"
-
-ruby_add_bdepend "
- dev-ruby/rake
- test? ( dev-ruby/mocha virtual/ruby-minitest )
-"
-
-all_ruby_prepare() {
- # remove bundler support
- sed -i '/[Bb]undler/d' Rakefile || die
- rm Gemfile || die
-
- # loosen dependencies
- sed -e '/childprocess\|erubis\|log4r\|net-scp\|net-ssh/s/~>/>=/' \
- -i ${PN}.gemspec || die
-
- epatch "${FILESDIR}"/${PN}-1.2.1-no-warning.patch
- epatch "${FILESDIR}"/${PN}-1.2.2-rvm.patch
-}
-
-pkg_postinst() {
- if use x64-macos ; then
- ewarn
- ewarn "For Mac OS X prefixes, you must install the virtualbox"
- ewarn "package specifically for OS X which can be found at:"
- ewarn "https://www.virtualbox.org/wiki/Downloads"
- ewarn
- fi
-}
diff --git a/app-emulation/vagrant/vagrant-1.3.1.ebuild b/app-emulation/vagrant/vagrant-1.3.1.ebuild
deleted file mode 100644
index 621e55da920e..000000000000
--- a/app-emulation/vagrant/vagrant-1.3.1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vagrant/vagrant-1.3.1.ebuild,v 1.1 2013/09/07 20:44:12 radhermit Exp $
-
-EAPI="5"
-USE_RUBY="ruby19"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
-RUBY_FAKEGEM_EXTRAINSTALL="config keys plugins templates"
-RUBY_FAKEGEM_TASK_DOC=""
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="A tool for building and distributing virtual machines using VirtualBox"
-HOMEPAGE="http://vagrantup.com/"
-SRC_URI="https://github.com/mitchellh/vagrant/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x64-macos"
-IUSE="test"
-
-# Missing ebuild for contest
-RESTRICT="test"
-
-RDEPEND="${RDEPEND}
- net-misc/curl
- !x64-macos? ( || ( app-emulation/virtualbox app-emulation/virtualbox-bin ) )"
-
-ruby_add_rdepend "
- >=dev-ruby/childprocess-0.3.7
- >=dev-ruby/erubis-2.7.0
- dev-ruby/i18n:0.6
- >=dev-ruby/json-1.5.1
- >=dev-ruby/log4r-1.1.9
- >=dev-ruby/net-ssh-2.6.6
- >=dev-ruby/net-scp-1.1.0
-"
-
-ruby_add_bdepend "
- dev-ruby/rake
- test? ( dev-ruby/mocha virtual/ruby-minitest )
-"
-
-all_ruby_prepare() {
- # remove bundler support
- sed -i '/[Bb]undler/d' Rakefile || die
- rm Gemfile || die
-
- # loosen dependencies
- sed -e '/childprocess\|erubis\|log4r\|net-scp\|net-ssh/s/~>/>=/' \
- -i ${PN}.gemspec || die
-
- epatch "${FILESDIR}"/${PN}-1.2.1-no-warning.patch
- epatch "${FILESDIR}"/${PN}-1.2.2-rvm.patch
-}
-
-pkg_postinst() {
- if use x64-macos ; then
- ewarn
- ewarn "For Mac OS X prefixes, you must install the virtualbox"
- ewarn "package specifically for OS X which can be found at:"
- ewarn "https://www.virtualbox.org/wiki/Downloads"
- ewarn
- fi
-}
diff --git a/app-emulation/vagrant/vagrant-1.3.3.ebuild b/app-emulation/vagrant/vagrant-1.3.3.ebuild
deleted file mode 100644
index 817e7e44c26f..000000000000
--- a/app-emulation/vagrant/vagrant-1.3.3.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vagrant/vagrant-1.3.3.ebuild,v 1.1 2013/09/23 18:39:32 radhermit Exp $
-
-EAPI="5"
-USE_RUBY="ruby19"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
-RUBY_FAKEGEM_EXTRAINSTALL="config keys plugins templates"
-RUBY_FAKEGEM_TASK_DOC=""
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="A tool for building and distributing virtual machines using VirtualBox"
-HOMEPAGE="http://vagrantup.com/"
-SRC_URI="https://github.com/mitchellh/vagrant/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x64-macos"
-IUSE="test"
-
-# Missing ebuild for contest
-RESTRICT="test"
-
-RDEPEND="${RDEPEND}
- net-misc/curl
- !x64-macos? ( || ( app-emulation/virtualbox app-emulation/virtualbox-bin ) )"
-
-ruby_add_rdepend "
- >=dev-ruby/childprocess-0.3.7
- >=dev-ruby/erubis-2.7.0
- dev-ruby/i18n:0.6
- >=dev-ruby/json-1.5.1
- >=dev-ruby/log4r-1.1.9
- >=dev-ruby/net-ssh-2.6.6
- >=dev-ruby/net-scp-1.1.0
-"
-
-ruby_add_bdepend "
- dev-ruby/rake
- test? ( dev-ruby/mocha virtual/ruby-minitest )
-"
-
-all_ruby_prepare() {
- # remove bundler support
- sed -i '/[Bb]undler/d' Rakefile || die
- rm Gemfile || die
-
- # loosen dependencies
- sed -e '/childprocess\|erubis\|log4r\|net-scp\|net-ssh/s/~>/>=/' \
- -i ${PN}.gemspec || die
-
- epatch "${FILESDIR}"/${PN}-1.2.1-no-warning.patch
- epatch "${FILESDIR}"/${PN}-1.2.2-rvm.patch
-}
-
-pkg_postinst() {
- if use x64-macos ; then
- ewarn
- ewarn "For Mac OS X prefixes, you must install the virtualbox"
- ewarn "package specifically for OS X which can be found at:"
- ewarn "https://www.virtualbox.org/wiki/Downloads"
- ewarn
- fi
-}
diff --git a/app-emulation/vagrant/vagrant-1.3.4.ebuild b/app-emulation/vagrant/vagrant-1.3.4.ebuild
deleted file mode 100644
index 5b7f9c436338..000000000000
--- a/app-emulation/vagrant/vagrant-1.3.4.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vagrant/vagrant-1.3.4.ebuild,v 1.1 2013/10/03 00:50:11 radhermit Exp $
-
-EAPI="5"
-USE_RUBY="ruby19"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
-RUBY_FAKEGEM_EXTRAINSTALL="config keys plugins templates"
-RUBY_FAKEGEM_TASK_DOC=""
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="A tool for building and distributing virtual machines using VirtualBox"
-HOMEPAGE="http://vagrantup.com/"
-SRC_URI="https://github.com/mitchellh/vagrant/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x64-macos"
-IUSE="test"
-
-# Missing ebuild for contest
-RESTRICT="test"
-
-RDEPEND="${RDEPEND}
- net-misc/curl
- !x64-macos? ( || ( app-emulation/virtualbox app-emulation/virtualbox-bin ) )"
-
-ruby_add_rdepend "
- >=dev-ruby/childprocess-0.3.7
- >=dev-ruby/erubis-2.7.0
- dev-ruby/i18n:0.6
- >=dev-ruby/json-1.5.1
- >=dev-ruby/log4r-1.1.9
- >=dev-ruby/net-ssh-2.6.6
- >=dev-ruby/net-scp-1.1.0
-"
-
-ruby_add_bdepend "
- dev-ruby/rake
- test? ( dev-ruby/mocha virtual/ruby-minitest )
-"
-
-all_ruby_prepare() {
- # remove bundler support
- sed -i '/[Bb]undler/d' Rakefile || die
- rm Gemfile || die
-
- # loosen dependencies
- sed -e '/childprocess\|erubis\|log4r\|net-scp\|net-ssh/s/~>/>=/' \
- -i ${PN}.gemspec || die
-
- epatch "${FILESDIR}"/${PN}-1.2.1-no-warning.patch
- epatch "${FILESDIR}"/${PN}-1.2.2-rvm.patch
-}
-
-pkg_postinst() {
- if use x64-macos ; then
- ewarn
- ewarn "For Mac OS X prefixes, you must install the virtualbox"
- ewarn "package specifically for OS X which can be found at:"
- ewarn "https://www.virtualbox.org/wiki/Downloads"
- ewarn
- fi
-}
diff --git a/app-emulation/vagrant/vagrant-1.3.5.ebuild b/app-emulation/vagrant/vagrant-1.3.5.ebuild
deleted file mode 100644
index 72a02d7df56c..000000000000
--- a/app-emulation/vagrant/vagrant-1.3.5.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vagrant/vagrant-1.3.5.ebuild,v 1.1 2013/10/18 05:37:46 radhermit Exp $
-
-EAPI="5"
-USE_RUBY="ruby19"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
-RUBY_FAKEGEM_EXTRAINSTALL="config keys plugins templates"
-RUBY_FAKEGEM_TASK_DOC=""
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="A tool for building and distributing virtual machines using VirtualBox"
-HOMEPAGE="http://vagrantup.com/"
-SRC_URI="https://github.com/mitchellh/vagrant/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x64-macos"
-IUSE="test"
-
-# Missing ebuild for contest
-RESTRICT="test"
-
-RDEPEND="${RDEPEND}
- net-misc/curl
- !x64-macos? ( || ( app-emulation/virtualbox app-emulation/virtualbox-bin ) )"
-
-ruby_add_rdepend "
- >=dev-ruby/childprocess-0.3.7
- >=dev-ruby/erubis-2.7.0
- dev-ruby/i18n:0.6
- >=dev-ruby/json-1.5.1
- >=dev-ruby/log4r-1.1.9
- >=dev-ruby/net-ssh-2.6.6
- >=dev-ruby/net-scp-1.1.0
-"
-
-ruby_add_bdepend "
- dev-ruby/rake
- test? ( dev-ruby/mocha virtual/ruby-minitest )
-"
-
-all_ruby_prepare() {
- # remove bundler support
- sed -i '/[Bb]undler/d' Rakefile || die
- rm Gemfile || die
-
- # loosen dependencies
- sed -e '/childprocess\|erubis\|log4r\|net-scp\|net-ssh/s/~>/>=/' \
- -i ${PN}.gemspec || die
-
- epatch "${FILESDIR}"/${PN}-1.2.1-no-warning.patch
- epatch "${FILESDIR}"/${PN}-1.2.2-rvm.patch
- epatch "${FILESDIR}"/${P}-rubygems2.patch
-}
-
-pkg_postinst() {
- if use x64-macos ; then
- ewarn
- ewarn "For Mac OS X prefixes, you must install the virtualbox"
- ewarn "package specifically for OS X which can be found at:"
- ewarn "https://www.virtualbox.org/wiki/Downloads"
- ewarn
- fi
-}
diff --git a/app-emulation/vagrant/vagrant-1.4.0.ebuild b/app-emulation/vagrant/vagrant-1.4.0.ebuild
deleted file mode 100644
index aac589fdcb4a..000000000000
--- a/app-emulation/vagrant/vagrant-1.4.0.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vagrant/vagrant-1.4.0.ebuild,v 1.1 2013/12/11 05:34:23 radhermit Exp $
-
-EAPI="5"
-USE_RUBY="ruby19"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
-RUBY_FAKEGEM_EXTRAINSTALL="config keys plugins templates"
-RUBY_FAKEGEM_TASK_DOC=""
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="A tool for building and distributing virtual machines using VirtualBox"
-HOMEPAGE="http://vagrantup.com/"
-SRC_URI="https://github.com/mitchellh/vagrant/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x64-macos"
-IUSE="test"
-
-# Missing ebuild for contest
-RESTRICT="test"
-
-RDEPEND="${RDEPEND}
- net-misc/curl
- !x64-macos? ( || ( app-emulation/virtualbox app-emulation/virtualbox-bin ) )"
-
-ruby_add_rdepend "
- >=dev-ruby/childprocess-0.3.7
- >=dev-ruby/erubis-2.7.0
- dev-ruby/i18n:0.6
- >=dev-ruby/json-1.5.1
- >=dev-ruby/log4r-1.1.9
- >=dev-ruby/net-ssh-2.6.6
- >=dev-ruby/net-scp-1.1.0
-"
-
-ruby_add_bdepend "
- dev-ruby/rake
- test? ( dev-ruby/mocha virtual/ruby-minitest )
-"
-
-all_ruby_prepare() {
- # remove bundler support
- sed -i '/[Bb]undler/d' Rakefile || die
- rm Gemfile || die
-
- # loosen dependencies
- sed -e '/childprocess\|erubis\|log4r\|net-scp\|net-ssh/s/~>/>=/' \
- -i ${PN}.gemspec || die
-
- epatch "${FILESDIR}"/${PN}-1.2.1-no-warning.patch
- epatch "${FILESDIR}"/${PN}-1.2.2-rvm.patch
-}
-
-pkg_postinst() {
- if use x64-macos ; then
- ewarn
- ewarn "For Mac OS X prefixes, you must install the virtualbox"
- ewarn "package specifically for OS X which can be found at:"
- ewarn "https://www.virtualbox.org/wiki/Downloads"
- ewarn
- fi
-}