summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2012-01-21 03:06:54 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2012-01-21 03:06:54 +0000
commit7c5017b2aadc2bb30ab6fdc46f3310f229a75570 (patch)
tree3d926c99dc92cb79f479d8cdc273268a20108246 /app-i18n/ibus-hangul
parentVersion bumped. (diff)
downloadgentoo-2-7c5017b2aadc2bb30ab6fdc46f3310f229a75570.tar.gz
gentoo-2-7c5017b2aadc2bb30ab6fdc46f3310f229a75570.tar.bz2
gentoo-2-7c5017b2aadc2bb30ab6fdc46f3310f229a75570.zip
Version bumped.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/ibus-hangul')
-rw-r--r--app-i18n/ibus-hangul/ChangeLog11
-rw-r--r--app-i18n/ibus-hangul/ibus-hangul-1.3.2.ebuild57
-rw-r--r--app-i18n/ibus-hangul/ibus-hangul-1.4.0.ebuild (renamed from app-i18n/ibus-hangul/ibus-hangul-1.3.1.ebuild)28
3 files changed, 88 insertions, 8 deletions
diff --git a/app-i18n/ibus-hangul/ChangeLog b/app-i18n/ibus-hangul/ChangeLog
index 47d64ffea845..dc5c87ce785e 100644
--- a/app-i18n/ibus-hangul/ChangeLog
+++ b/app-i18n/ibus-hangul/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-i18n/ibus-hangul
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-hangul/ChangeLog,v 1.16 2011/10/04 21:30:16 phajdan.jr Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-hangul/ChangeLog,v 1.17 2012/01/21 03:06:54 matsuu Exp $
+
+*ibus-hangul-1.4.0 (21 Jan 2012)
+*ibus-hangul-1.3.2 (21 Jan 2012)
+
+ 21 Jan 2012; MATSUU Takuto <matsuu@gentoo.org> -ibus-hangul-1.3.1.ebuild,
+ +ibus-hangul-1.3.2.ebuild, +ibus-hangul-1.4.0.ebuild:
+ Version bumped. Removed old version.
04 Oct 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
ibus-hangul-1.3.1-r1.ebuild:
diff --git a/app-i18n/ibus-hangul/ibus-hangul-1.3.2.ebuild b/app-i18n/ibus-hangul/ibus-hangul-1.3.2.ebuild
new file mode 100644
index 000000000000..6d74f399ec59
--- /dev/null
+++ b/app-i18n/ibus-hangul/ibus-hangul-1.3.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-hangul/ibus-hangul-1.3.2.ebuild,v 1.1 2012/01/21 03:06:54 matsuu Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+
+inherit eutils python
+
+DESCRIPTION="The Hangul engine for IBus input platform"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=app-i18n/ibus-1.2.99
+ dev-python/pygobject
+ dev-python/pygtk
+ >=app-i18n/libhangul-0.1
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( >=sys-devel/gettext-0.17 )"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # http://pkgs.fedoraproject.org/gitweb/?p=ibus-hangul.git
+ epatch "${FILESDIR}/${PN}-ibus-1.4.patch" || die
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+ sed -i -e "s:python:$(PYTHON -2):" setup/ibus-setup-hangul.in || die
+}
+
+src_configure() {
+ econf $(use_enable nls) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README || die
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}
diff --git a/app-i18n/ibus-hangul/ibus-hangul-1.3.1.ebuild b/app-i18n/ibus-hangul/ibus-hangul-1.4.0.ebuild
index c525daed3dfe..1e32cfde7bfd 100644
--- a/app-i18n/ibus-hangul/ibus-hangul-1.3.1.ebuild
+++ b/app-i18n/ibus-hangul/ibus-hangul-1.4.0.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-hangul/ibus-hangul-1.3.1.ebuild,v 1.2 2011/05/25 00:04:59 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-hangul/ibus-hangul-1.4.0.ebuild,v 1.1 2012/01/21 03:06:54 matsuu Exp $
EAPI="3"
PYTHON_DEPEND="2:2.5"
-inherit python
+
+inherit eutils python
DESCRIPTION="The Hangul engine for IBus input platform"
HOMEPAGE="http://code.google.com/p/ibus/"
@@ -15,17 +16,24 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="nls"
-RDEPEND=">=app-i18n/ibus-1.2.99
- !>=app-i18n/ibus-1.3.99
- >=app-i18n/libhangul-0.0.12
+RDEPEND=">=app-i18n/ibus-1.3.99
+ dev-python/pygobject
+ dev-python/pygtk
+ >=app-i18n/libhangul-0.1
nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
dev-util/pkgconfig
nls? ( >=sys-devel/gettext-0.17 )"
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
src_prepare() {
mv py-compile py-compile.orig || die
ln -s "$(type -P true)" py-compile || die
+ sed -i -e "s:python:$(PYTHON -2):" setup/ibus-setup-hangul.in || die
}
src_configure() {
@@ -37,3 +45,11 @@ src_install() {
dodoc AUTHORS ChangeLog NEWS README || die
}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}