summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2011-05-07 01:24:14 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2011-05-07 01:24:14 +0000
commit153e6b5f8a0216a736db728eb1ba874506dd09e7 (patch)
treec4be3f51d124b306facdf91cb75672321bca2ba7 /app-i18n/imsettings
parentmedia-gfx/blender: Improve desktop files (diff)
downloadgentoo-2-153e6b5f8a0216a736db728eb1ba874506dd09e7.tar.gz
gentoo-2-153e6b5f8a0216a736db728eb1ba874506dd09e7.tar.bz2
gentoo-2-153e6b5f8a0216a736db728eb1ba874506dd09e7.zip
Version bumped.
(Portage version: 2.1.9.46/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/imsettings')
-rw-r--r--app-i18n/imsettings/ChangeLog8
-rw-r--r--app-i18n/imsettings/files/imsettings-1.2.2-gtk.patch25
-rw-r--r--app-i18n/imsettings/imsettings-1.2.2.ebuild67
3 files changed, 99 insertions, 1 deletions
diff --git a/app-i18n/imsettings/ChangeLog b/app-i18n/imsettings/ChangeLog
index 3f867a644dd2..5eb19d4acbe1 100644
--- a/app-i18n/imsettings/ChangeLog
+++ b/app-i18n/imsettings/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/imsettings
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/imsettings/ChangeLog,v 1.4 2011/04/06 13:51:58 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/imsettings/ChangeLog,v 1.5 2011/05/07 01:24:14 matsuu Exp $
+
+*imsettings-1.2.2 (07 May 2011)
+
+ 07 May 2011; MATSUU Takuto <matsuu@gentoo.org> +imsettings-1.2.2.ebuild,
+ +files/imsettings-1.2.2-gtk.patch:
+ Version bumped.
*imsettings-1.2.1 (06 Apr 2011)
diff --git a/app-i18n/imsettings/files/imsettings-1.2.2-gtk.patch b/app-i18n/imsettings/files/imsettings-1.2.2-gtk.patch
new file mode 100644
index 000000000000..3320065d9d97
--- /dev/null
+++ b/app-i18n/imsettings/files/imsettings-1.2.2-gtk.patch
@@ -0,0 +1,25 @@
+From 3f316f5f4da4de8591141e4949c041cc7662666b Mon Sep 17 00:00:00 2001
+From: Akira TAGOH <akira@tagoh.org>
+Date: Thu, 28 Apr 2011 17:48:59 +0900
+Subject: [PATCH 1/3] fix a typo
+
+---
+ data/xinput.sh.in.in | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/data/xinput.sh.in.in b/data/xinput.sh.in.in
+index 2ad3f6b..39b3951 100755
+--- a/data/xinput.sh.in.in
++++ b/data/xinput.sh.in.in
+@@ -45,7 +45,7 @@ function is_gtk_supported() {
+ [ -n "$IMSETTINGS_DISABLE_DESKTOP_CHECK" ] && return 0
+ case "$DESKTOP_SESSION" in
+ *gnome|openbox)
+- if check_imsettings_capability gconf && check_imsettings_capability gsettings; then
++ if check_imsettings_capability gconf || check_imsettings_capability gsettings; then
+ return 0
+ fi
+ ;;
+--
+1.7.5.rc3
+
diff --git a/app-i18n/imsettings/imsettings-1.2.2.ebuild b/app-i18n/imsettings/imsettings-1.2.2.ebuild
new file mode 100644
index 000000000000..0879d685b81b
--- /dev/null
+++ b/app-i18n/imsettings/imsettings-1.2.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/imsettings/imsettings-1.2.2.ebuild,v 1.1 2011/05/07 01:24:14 matsuu Exp $
+
+EAPI=3
+
+DESCRIPTION="Delivery framework for general Input Method configuration"
+HOMEPAGE="http://code.google.com/p/imsettings/"
+SRC_URI="http://imsettings.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc qt4 static-libs xfconf"
+
+# X11 connections are required for test.
+RESTRICT="test"
+
+RDEPEND=">=dev-libs/check-0.9.4
+ >=dev-libs/glib-2.26
+ sys-apps/dbus
+ >=x11-libs/gtk+-2.12:2
+ >=x11-libs/libgxim-0.3.1
+ >=x11-libs/libnotify-0.7
+ x11-libs/libX11
+ qt4? ( x11-libs/qt-core:4 )
+ xfconf? ( xfce-base/xfconf )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( dev-util/gtk-doc )"
+
+MY_XINPUTSH="90-xinput"
+
+src_prepare() {
+ # Prevent automagic linking to libxfconf-0.
+ if ! use xfconf; then
+ sed -i -e 's:libxfconf-0:dIsAbLe&:' configure || die
+ fi
+ if ! use qt4; then
+ sed -i -e 's:QtCore:dIsAbLe&:' configure || die
+ fi
+
+ epatch "${FILESDIR}/${P}-gtk.patch"
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --with-xinputsh="${MY_XINPUTSH}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ find "${ED}" -name '*.la' -exec rm -f '{}' +
+
+ fperms 0755 /usr/libexec/xinputinfo.sh || die
+ fperms 0755 "/etc/X11/xinit/xinitrc.d/${MY_XINPUTSH}" || die
+
+ dodoc AUTHORS ChangeLog NEWS README || die
+}
+
+pkg_postinst() {
+ if [ ! -e "${EPREFIX}/etc/X11/xinit/xinputrc" ] ; then
+ ln -sf xinput.d/xcompose.conf "${EPREFIX}/etc/X11/xinit/xinputrc"
+ fi
+}