summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-06-23 17:11:44 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-06-23 17:11:44 +0000
commit783ad257521ea846593b64bab8b66f7ae349e4c2 (patch)
tree38fc4756cfb3de87843b6c3d2a79bac8b005c992 /app-i18n
parentApplying patch for CVE-2010-2063 , bug #323785, fixing domain and netbios nam... (diff)
downloadgentoo-2-783ad257521ea846593b64bab8b66f7ae349e4c2.tar.gz
gentoo-2-783ad257521ea846593b64bab8b66f7ae349e4c2.tar.bz2
gentoo-2-783ad257521ea846593b64bab8b66f7ae349e4c2.zip
Version bumped.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-table/ChangeLog8
-rw-r--r--app-i18n/ibus-table/ibus-table-1.3.0.20100621.ebuild53
2 files changed, 60 insertions, 1 deletions
diff --git a/app-i18n/ibus-table/ChangeLog b/app-i18n/ibus-table/ChangeLog
index fa638a74fee3..e209b4c4b80d 100644
--- a/app-i18n/ibus-table/ChangeLog
+++ b/app-i18n/ibus-table/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/ibus-table
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ChangeLog,v 1.22 2010/05/26 10:42:16 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ChangeLog,v 1.23 2010/06/23 17:11:44 matsuu Exp $
+
+*ibus-table-1.3.0.20100621 (23 Jun 2010)
+
+ 23 Jun 2010; MATSUU Takuto <matsuu@gentoo.org>
+ +ibus-table-1.3.0.20100621.ebuild:
+ Version bumped.
26 May 2010; Pacho Ramos <pacho@gentoo.org>
ibus-table-1.2.0.20100111.ebuild:
diff --git a/app-i18n/ibus-table/ibus-table-1.3.0.20100621.ebuild b/app-i18n/ibus-table/ibus-table-1.3.0.20100621.ebuild
new file mode 100644
index 000000000000..1348097a9fa7
--- /dev/null
+++ b/app-i18n/ibus-table/ibus-table-1.3.0.20100621.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ibus-table-1.3.0.20100621.ebuild,v 1.1 2010/06/23 17:11:44 matsuu Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2:2.5"
+PYTHON_USE_WITH="sqlite"
+inherit python
+
+DESCRIPTION="The Table Engine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=app-i18n/ibus-1.2
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.16.1 )
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+ python_convert_shebangs 2 engine/tabcreatedb.py || die
+ sed -i -e "s/python/python2/" \
+ engine/ibus-table-createdb.in engine/ibus-engine-table.in || die
+}
+
+src_configure() {
+ econf $(use_enable nls) --disable-additional || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README || die
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/${PN}/engine
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}/engine
+}