summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2014-01-08 09:51:36 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2014-01-08 09:51:36 +0000
commit034a45ee52b5ee22e34e590b4ebad8c5fd6b8e8f (patch)
treea421a228ac7e06901f408c89504ff16cf2857827 /app-leechcraft/lc-monocle
parentBump to LeecChraft-0.6.60 release, thanks to 0xd34df00d. (diff)
downloadgentoo-2-034a45ee52b5ee22e34e590b4ebad8c5fd6b8e8f.tar.gz
gentoo-2-034a45ee52b5ee22e34e590b4ebad8c5fd6b8e8f.tar.bz2
gentoo-2-034a45ee52b5ee22e34e590b4ebad8c5fd6b8e8f.zip
Bump to LeecChraft-0.6.60 release, thanks to 0xd34df00d.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'app-leechcraft/lc-monocle')
-rw-r--r--app-leechcraft/lc-monocle/ChangeLog9
-rw-r--r--app-leechcraft/lc-monocle/lc-monocle-0.6.60.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/app-leechcraft/lc-monocle/ChangeLog b/app-leechcraft/lc-monocle/ChangeLog
index 8e1182ef5f8a..cbfecc796dc2 100644
--- a/app-leechcraft/lc-monocle/ChangeLog
+++ b/app-leechcraft/lc-monocle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-leechcraft/lc-monocle
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-monocle/ChangeLog,v 1.9 2013/10/02 09:49:30 maksbotan Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-monocle/ChangeLog,v 1.10 2014/01/08 09:51:36 maksbotan Exp $
+
+*lc-monocle-0.6.60 (08 Jan 2014)
+
+ 08 Jan 2014; Maxim Koltsov <maksbotan@gentoo.org> +lc-monocle-0.6.60.ebuild:
+ Bump to LeecChraft-0.6.60 release, thanks to 0xd34df00d.
*lc-monocle-0.6.0-r1 (02 Oct 2013)
*lc-monocle-0.5.99-r1 (02 Oct 2013)
diff --git a/app-leechcraft/lc-monocle/lc-monocle-0.6.60.ebuild b/app-leechcraft/lc-monocle/lc-monocle-0.6.60.ebuild
new file mode 100644
index 000000000000..ff17491248d6
--- /dev/null
+++ b/app-leechcraft/lc-monocle/lc-monocle-0.6.60.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-monocle/lc-monocle-0.6.60.ebuild,v 1.1 2014/01/08 09:51:36 maksbotan Exp $
+
+EAPI="5"
+
+inherit leechcraft
+
+DESCRIPTION="Monocle, the modular document viewer for LeechCraft"
+
+SLOT="0"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="debug +djvu doc +fb2 +pdf +spectre"
+
+RDEPEND="~app-leechcraft/lc-core-${PV}
+ pdf? ( app-text/poppler[qt4] )
+ djvu? ( app-text/djvu )
+ spectre? (
+ app-text/libspectre
+ || (
+ app-text/poppler[-lcms]
+ <app-text/ghostscript-gpl-9.07
+ )
+ )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot] )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable djvu MONOCLE_SEEN)
+ $(cmake-utils_use_with doc DOCS)
+ $(cmake-utils_use_enable fb2 MONOCLE_FXB)
+ $(cmake-utils_use_enable pdf MONOCLE_PDF)
+ $(cmake-utils_use_enable spectre MONOCLE_POSTRUS)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dohtml -r "${CMAKE_BUILD_DIR}"/out/html/*
+}