summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-04-06 08:29:50 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-04-06 08:29:50 +0000
commit8a323ad138682d3394b6dcf4d624b869d671fd64 (patch)
treecc2570a12805c31e011a61c8ba1d75eaa46bcef2 /app-leechcraft
parentadd multilib support, thanks to Karl Lindén (bug 464702) (diff)
downloadgentoo-2-8a323ad138682d3394b6dcf4d624b869d671fd64.tar.gz
gentoo-2-8a323ad138682d3394b6dcf4d624b869d671fd64.tar.bz2
gentoo-2-8a323ad138682d3394b6dcf4d624b869d671fd64.zip
Bump EAPI to 5, add documentation building and installing, thanks to 0xd34df00d
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'app-leechcraft')
-rw-r--r--app-leechcraft/lc-core/ChangeLog6
-rw-r--r--app-leechcraft/lc-core/lc-core-9999.ebuild26
2 files changed, 20 insertions, 12 deletions
diff --git a/app-leechcraft/lc-core/ChangeLog b/app-leechcraft/lc-core/ChangeLog
index 0855eb9b24c3..bd43eb539ca7 100644
--- a/app-leechcraft/lc-core/ChangeLog
+++ b/app-leechcraft/lc-core/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-leechcraft/lc-core
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-core/ChangeLog,v 1.1 2013/03/08 21:56:19 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-core/ChangeLog,v 1.2 2013/04/06 08:29:50 pinkbyte Exp $
+
+ 06 Apr 2013; Sergey Popov <pinkbyte@gentoo.org> lc-core-9999.ebuild:
+ Bump EAPI to 5, add documentation building and installing, thanks to
+ 0xd34df00d
*lc-core-9999 (08 Mar 2013)
*lc-core-0.5.90 (08 Mar 2013)
diff --git a/app-leechcraft/lc-core/lc-core-9999.ebuild b/app-leechcraft/lc-core/lc-core-9999.ebuild
index 5e08aa73cb2a..e8f759688d86 100644
--- a/app-leechcraft/lc-core/lc-core-9999.ebuild
+++ b/app-leechcraft/lc-core/lc-core-9999.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-core/lc-core-9999.ebuild,v 1.1 2013/03/08 21:56:19 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-core/lc-core-9999.ebuild,v 1.2 2013/04/06 08:29:50 pinkbyte Exp $
-EAPI="4"
+EAPI="5"
EGIT_REPO_URI="git://github.com/0xd34df00d/leechcraft.git"
EGIT_PROJECT="leechcraft-${PV}"
@@ -13,15 +13,17 @@ DESCRIPTION="Core of LeechCraft, the modular network client"
SLOT="0"
KEYWORDS=""
-IUSE="debug +sqlite postgres"
-
-DEPEND=">=dev-libs/boost-1.46
- dev-qt/qtcore:4
- dev-qt/qtdeclarative:4
- dev-qt/qtgui:4
- dev-qt/qtscript:4
- dev-qt/qtsql:4[postgres?,sqlite?]"
-RDEPEND="${DEPEND}
+IUSE="debug doc +sqlite postgres"
+
+COMMON_DEPEND=">=dev-libs/boost-1.46
+ dev-qt/qtcore:4
+ dev-qt/qtdeclarative:4
+ dev-qt/qtgui:4
+ dev-qt/qtscript:4
+ dev-qt/qtsql:4[postgres?,sqlite?]"
+DEPEND="${COMMON_DEPEND}
+ doc? ( app-doc/doxygen )"
+RDEPEND="${COMMON_DEPEND}
dev-qt/qtsvg:4
|| (
kde-base/oxygen-icons
@@ -33,6 +35,7 @@ REQUIRED_USE="|| ( postgres sqlite )"
src_configure() {
local mycmakeargs=(
-DWITH_PLUGINS=False
+ $(cmake-utils_use_with doc DOCS)
)
if [[ ${PV} != 9999 ]]; then
mycmakeargs+=( -DLEECHCRAFT_VERSION=${PV} )
@@ -43,4 +46,5 @@ src_configure() {
src_install() {
cmake-utils_src_install
make_desktop_entry leechcraft "LeechCraft" leechcraft.png
+ use doc && dohtml -r "${CMAKE_BUILD_DIR}/${PN#lc-}"/out/html/*
}