summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-08-26 21:52:30 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-08-26 21:52:30 +0000
commit48f044ab310bf7df09be8e58d35788d2a7954518 (patch)
treea44346b9cd7a3fe1334ff9eb3c1a0eab9dd96a2f /app-misc/gnote
parentUse common epatch_user code now. (diff)
downloadgentoo-2-48f044ab310bf7df09be8e58d35788d2a7954518.tar.gz
gentoo-2-48f044ab310bf7df09be8e58d35788d2a7954518.tar.bz2
gentoo-2-48f044ab310bf7df09be8e58d35788d2a7954518.zip
Version bump. Use mnemonics for toolbar. Update spanish translation.
(Portage version: 2.2_rc39/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/gnote')
-rw-r--r--app-misc/gnote/ChangeLog7
-rw-r--r--app-misc/gnote/gnote-0.6.2.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/app-misc/gnote/ChangeLog b/app-misc/gnote/ChangeLog
index a28c1bf77762..55821a21100c 100644
--- a/app-misc/gnote/ChangeLog
+++ b/app-misc/gnote/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/gnote
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gnote/ChangeLog,v 1.1 2009/08/02 22:42:06 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gnote/ChangeLog,v 1.2 2009/08/26 21:52:30 eva Exp $
+
+*gnote-0.6.2 (26 Aug 2009)
+
+ 26 Aug 2009; Gilles Dartiguelongue <eva@gentoo.org> +gnote-0.6.2.ebuild:
+ Version bump. Use mnemonics for toolbar. Update spanish translation.
*gnote-0.6.1 (02 Aug 2009)
diff --git a/app-misc/gnote/gnote-0.6.2.ebuild b/app-misc/gnote/gnote-0.6.2.ebuild
new file mode 100644
index 000000000000..fa9ceaf2d064
--- /dev/null
+++ b/app-misc/gnote/gnote-0.6.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gnote/gnote-0.6.2.ebuild,v 1.1 2009/08/26 21:52:30 eva Exp $
+
+EAPI="2"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Desktop note-taking application"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="applet debug" # dbus
+
+RDEPEND=">=x11-libs/gtk+-2.14
+ >=dev-cpp/glibmm-2
+ >=dev-cpp/gtkmm-2.12
+ >=dev-libs/libxml2-2
+ dev-libs/libxslt
+ >=gnome-base/gconf-2
+ >=dev-libs/libpcre-7.8[cxx]
+ >=app-text/gtkspell-2.0.9
+ >=dev-libs/boost-1.34
+ sys-libs/e2fsprogs-libs
+ >=gnome-base/gnome-panel-2
+ applet? ( >=dev-cpp/libpanelappletmm-2.26 )"
+# Build with dbus is currently not implemented
+# dbus? ( >=dev-libs/dbus-glib-0.70 )"
+DEPEND="${DEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35.0
+ app-text/gnome-doc-utils
+ app-text/docbook-xml-dtd:4.1.2"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix intltoolize broken file, see upstream #577133
+ sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in || die "sed failed"
+}
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-dbus
+ --disable-static
+ $(use_enable applet)
+ $(use_enable debug)"
+}