summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-04-12 04:01:11 +0000
committerMike Frysinger <vapier@gentoo.org>2006-04-12 04:01:11 +0000
commit384608604286f62c878180ef074f7c85a6fce057 (patch)
tree6a8b899115beb86e2b07f34ca62d6cee8d002128 /app-misc
parentold (diff)
downloadgentoo-2-384608604286f62c878180ef074f7c85a6fce057.tar.gz
gentoo-2-384608604286f62c878180ef074f7c85a6fce057.tar.bz2
gentoo-2-384608604286f62c878180ef074f7c85a6fce057.zip
Fix scanelf hang due to grep-style changes with stdin #128247 by Matteo Azzali.
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/pax-utils/ChangeLog8
-rw-r--r--app-misc/pax-utils/files/digest-pax-utils-0.1.11-r13
-rw-r--r--app-misc/pax-utils/files/pax-utils-0.1.11.patch12
-rw-r--r--app-misc/pax-utils/pax-utils-0.1.11-r1.ebuild36
4 files changed, 58 insertions, 1 deletions
diff --git a/app-misc/pax-utils/ChangeLog b/app-misc/pax-utils/ChangeLog
index e3e56df9b1c3..307d7db35136 100644
--- a/app-misc/pax-utils/ChangeLog
+++ b/app-misc/pax-utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/pax-utils
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/pax-utils/ChangeLog,v 1.61 2006/03/30 13:13:06 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/pax-utils/ChangeLog,v 1.62 2006/04/12 04:01:11 vapier Exp $
+
+*pax-utils-0.1.11-r1 (12 Apr 2006)
+
+ 12 Apr 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/pax-utils-0.1.11.patch, +pax-utils-0.1.11-r1.ebuild:
+ Fix scanelf hang due to grep-style changes with stdin #128247 by Matteo Azzali.
*pax-utils-0.1.11 (30 Mar 2006)
diff --git a/app-misc/pax-utils/files/digest-pax-utils-0.1.11-r1 b/app-misc/pax-utils/files/digest-pax-utils-0.1.11-r1
new file mode 100644
index 000000000000..d1df02406030
--- /dev/null
+++ b/app-misc/pax-utils/files/digest-pax-utils-0.1.11-r1
@@ -0,0 +1,3 @@
+MD5 9cdfdaa30ea589e8b7e58ad768fd53e2 pax-utils-0.1.11.tar.bz2 52245
+RMD160 cf91ce04dc345a7029a5d51c1910d9ce9aa6037b pax-utils-0.1.11.tar.bz2 52245
+SHA256 d571658aedaddea1dd61fce0f4f6103eb25d86a3f25171ab0139b4cacddffc5f pax-utils-0.1.11.tar.bz2 52245
diff --git a/app-misc/pax-utils/files/pax-utils-0.1.11.patch b/app-misc/pax-utils/files/pax-utils-0.1.11.patch
new file mode 100644
index 000000000000..1ee86483c85e
--- /dev/null
+++ b/app-misc/pax-utils/files/pax-utils-0.1.11.patch
@@ -0,0 +1,12 @@
+http://bugs.gentoo.org/128247
+--- scanelf.c
++++ scanelf.c
+@@ -1683,7 +1683,7 @@ static void parseargs(int argc, char *ar
+ load_ld_so_conf(0, "/etc/ld.so.conf");
+ if (scan_ldpath) scanelf_ldpath();
+ if (scan_envpath) scanelf_envpath();
+- if (!from_file && ttyname(0) == NULL)
++ if (!from_file && optind == argc && ttyname(0) == NULL)
+ from_file = "-";
+ if (from_file) {
+ scanelf_from_file(from_file);
diff --git a/app-misc/pax-utils/pax-utils-0.1.11-r1.ebuild b/app-misc/pax-utils/pax-utils-0.1.11-r1.ebuild
new file mode 100644
index 000000000000..81787b2a5e6e
--- /dev/null
+++ b/app-misc/pax-utils/pax-utils-0.1.11-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/pax-utils/pax-utils-0.1.11-r1.ebuild,v 1.1 2006/04/12 04:01:11 vapier Exp $
+
+inherit flag-o-matic toolchain-funcs eutils
+
+DESCRIPTION="Various ELF related utils for ELF32, ELF64 binaries useful tools that can check files for security relevant properties"
+HOMEPAGE="http://hardened.gentoo.org/pax-utils.xml"
+SRC_URI="mirror://gentoo/pax-utils-${PV}.tar.bz2
+ http://dev.gentoo.org/~solar/pax/pax-utils-${PV}.tar.bz2
+ http://dev.gentoo.org/~vapier/dist/pax-utils-${PV}.tar.bz2
+ http://dev.gentoo.org/~flameeyes/dist/pax-utils-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="caps"
+
+DEPEND="caps? ( sys-libs/libcap )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}.patch
+}
+
+src_compile() {
+ use caps && append-flags -DWANT_SYSCAP
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" dumpelf scanelf || die
+ use caps && append-ldflags -lcap
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" pspax || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+}