summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2007-10-11 08:54:06 +0000
committerAlin Năstac <mrness@gentoo.org>2007-10-11 08:54:06 +0000
commit2ae8a88f8cdf04cadffb576f8b406898aabac2a9 (patch)
tree5c5b64c076e1fe6b77cbe4c7197a60d26f4a6a58 /app-mobilephone/wammu
parentStable on ppc64; bug #194606 (diff)
downloadgentoo-2-2ae8a88f8cdf04cadffb576f8b406898aabac2a9.tar.gz
gentoo-2-2ae8a88f8cdf04cadffb576f8b406898aabac2a9.tar.bz2
gentoo-2-2ae8a88f8cdf04cadffb576f8b406898aabac2a9.zip
Version bump (#195437).
(Portage version: 2.1.2.12)
Diffstat (limited to 'app-mobilephone/wammu')
-rw-r--r--app-mobilephone/wammu/ChangeLog7
-rw-r--r--app-mobilephone/wammu/files/digest-wammu-0.233
-rw-r--r--app-mobilephone/wammu/wammu-0.23.ebuild76
3 files changed, 85 insertions, 1 deletions
diff --git a/app-mobilephone/wammu/ChangeLog b/app-mobilephone/wammu/ChangeLog
index 3a806b441465..5638b8a91f21 100644
--- a/app-mobilephone/wammu/ChangeLog
+++ b/app-mobilephone/wammu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-mobilephone/wammu
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/ChangeLog,v 1.25 2007/10/03 04:56:58 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/ChangeLog,v 1.26 2007/10/11 08:54:06 mrness Exp $
+
+*wammu-0.23 (11 Oct 2007)
+
+ 11 Oct 2007; Alin Năstac <mrness@gentoo.org> +wammu-0.23.ebuild:
+ Version bump (#195437).
03 Oct 2007; Ryan Hill <dirtyepic@gentoo.org> wammu-0.20.ebuild,
wammu-0.21.ebuild, wammu-0.21-r2.ebuild:
diff --git a/app-mobilephone/wammu/files/digest-wammu-0.23 b/app-mobilephone/wammu/files/digest-wammu-0.23
new file mode 100644
index 000000000000..cc41e1f60c51
--- /dev/null
+++ b/app-mobilephone/wammu/files/digest-wammu-0.23
@@ -0,0 +1,3 @@
+MD5 5fe692efc30e92b267620c854eef6241 wammu-0.23.tar.bz2 334043
+RMD160 60c89d93949661e5740283e0eb6ea9a801965a7e wammu-0.23.tar.bz2 334043
+SHA256 3936c18ee8ce7f67feb1403bcfec59dde538bf27470a02c5be8be102ebf00430 wammu-0.23.tar.bz2 334043
diff --git a/app-mobilephone/wammu/wammu-0.23.ebuild b/app-mobilephone/wammu/wammu-0.23.ebuild
new file mode 100644
index 000000000000..97542c2aacf9
--- /dev/null
+++ b/app-mobilephone/wammu/wammu-0.23.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/wammu-0.23.ebuild,v 1.1 2007/10/11 08:54:06 mrness Exp $
+
+inherit distutils eutils versionator
+
+DESCRIPTION="front-end for gammu (Nokia and other mobiles)"
+HOMEPAGE="http://www.cihar.com/gammu/wammu/"
+SRC_URI="http://dl.cihar.com/wammu/v0/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="bluetooth"
+
+RDEPEND="=dev-python/wxpython-2.6*
+ >=dev-python/python-gammu-0.22
+ bluetooth? (
+ || (
+ dev-python/pybluez
+ net-wireless/gnome-bluetooth
+ )
+ )"
+DEPEND="${RDEPEND}"
+
+# Supported languages and translated documentation
+# Be sure all languages are prefixed with a single space!
+MY_AVAILABLE_LINGUAS=" af ca cs de es et fi fr hu it ko nl pl pt_BR ru sk sv zh_CN"
+IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
+
+src_unpack() {
+ unpack ${A}
+
+ # Select the suitable wxpython versions
+ local wxpy_pkg wxpy_slot MY_WXPYTHON_SLOTS
+ for wxpy_pkg in $(portageq match "${ROOT}" '=dev-python/wxpython-2.6*'); do
+ if built_with_use --hidden --missing false =${wxpy_pkg} unicode ; then
+ wxpy_slot=$(get_version_component_range 1-2 ${wxpy_pkg#*/*-})
+ if [ -z "${MY_WXPYTHON_SLOTS}" ]; then
+ MY_WXPYTHON_SLOTS="'${wxpy_slot}'"
+ else
+ MY_WXPYTHON_SLOTS="${MY_WXPYTHON_SLOTS}, '${wxpy_slot}'"
+ fi
+ fi
+ done
+ if [ -z "${MY_WXPYTHON_SLOTS}" ]; then
+ eerror "None of the dev-python/wxpython installed versions have been built with Unicode support."
+ eerror "Install wxpython with unicode USE flag enabled and try again."
+ die "dev-python/wxpython is missing Unicode support"
+ fi
+
+ cd "${S}"
+ sed -e "s/WXPYTHON_VER/${MY_WXPYTHON_SLOTS}/" \
+ "${FILESDIR}"/${PN}-wxversion.patch \
+ > "${T}"/${PN}-wxversion.patch
+ epatch "${T}"/${PN}-wxversion.patch
+
+ cd locale || die "locale directory not found"
+ local lang
+ for lang in ${MY_AVAILABLE_LINGUAS} ; do
+ if ! use linguas_${lang} ; then
+ rm -r ${lang}
+ fi
+ done
+}
+
+src_compile() {
+ # SKIPWXCHECK: else 'import wx' results in
+ # Xlib: connection to ":0.0" refused by server
+ SKIPWXCHECK=yes distutils_src_compile
+}
+
+src_install() {
+ DOCS="AUTHORS FAQ NEWS"
+ SKIPWXCHECK=yes distutils_src_install
+}