summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-10-28 10:11:17 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-10-28 10:11:17 +0000
commit72657046366289c97dbb55204a8b8e7b66aeb9e7 (patch)
treea645cfdc26f01bf3bb8985d8eadde8cf8e64b957 /app-office
parentDo not hardcode lib32, bug #429726 by SpanKY. (diff)
downloadgentoo-2-72657046366289c97dbb55204a8b8e7b66aeb9e7.tar.gz
gentoo-2-72657046366289c97dbb55204a8b8e7b66aeb9e7.tar.bz2
gentoo-2-72657046366289c97dbb55204a8b8e7b66aeb9e7.zip
Update the unpack code and wipe saxon.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice/ChangeLog5
-rw-r--r--app-office/libreoffice/libreoffice-9999-r2.ebuild21
2 files changed, 15 insertions, 11 deletions
diff --git a/app-office/libreoffice/ChangeLog b/app-office/libreoffice/ChangeLog
index 2a58dcaea76f..bd92f5b7a475 100644
--- a/app-office/libreoffice/ChangeLog
+++ b/app-office/libreoffice/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-office/libreoffice
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.380 2012/10/25 10:40:55 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.381 2012/10/28 10:11:17 scarabeus Exp $
+
+ 28 Oct 2012; Tomáš Chvátal <scarabeus@gentoo.org> libreoffice-9999-r2.ebuild:
+ Update the unpack code and wipe saxon.
25 Oct 2012; Tomáš Chvátal <scarabeus@gentoo.org> libreoffice-9999-r2.ebuild:
Fix the move to the submodules stuff.
diff --git a/app-office/libreoffice/libreoffice-9999-r2.ebuild b/app-office/libreoffice/libreoffice-9999-r2.ebuild
index 51c3cc02d12b..709b4f3e6a40 100644
--- a/app-office/libreoffice/libreoffice-9999-r2.ebuild
+++ b/app-office/libreoffice/libreoffice-9999-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-9999-r2.ebuild,v 1.119 2012/10/25 10:40:55 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-9999-r2.ebuild,v 1.120 2012/10/28 10:11:17 scarabeus Exp $
EAPI=4
@@ -280,7 +280,7 @@ pkg_setup() {
}
src_unpack() {
- local mod dest tmplfile tmplname mypv
+ local mod mod2 dest tmplfile tmplname mypv
[[ -n ${PATCHSET} ]] && unpack ${PATCHSET}
if use branding; then
@@ -294,9 +294,11 @@ src_unpack() {
fi
unpack "${PN}-${mod}-${PV}.tar.xz"
if [[ ${mod} != core ]]; then
- [[ ${mod} == help ]] && mod="helpcontent2"
- mkdir "${S}/${mod}/" || die
- mv -n "${WORKDIR}/${PN}-${mod}-${PV}"/* "${S}" || die
+ mod2=${mod}
+ # mapping does not match on help
+ [[ ${mod} == help ]] && mod2="helpcontent2"
+ mkdir -p "${S}/${mod2}/" || die
+ mv -n "${WORKDIR}/${PN}-${mod}-${PV}"/* "${S}/${mod2}" || die
rm -rf "${WORKDIR}/${PN}-${mod}-${PV}"
fi
done
@@ -313,10 +315,11 @@ src_unpack() {
EGIT_NOUNPACK="true"
git-2_src_unpack
if [[ ${mod} != core ]]; then
+ mod2=${mod}
# mapping does not match on help
- [[ ${mod} == help ]] && mod="helpcontent2"
- mkdir "${S}/${mod}/" || die
- mv -n "${WORKDIR}/${PN}-${mod}-${PV}"/* "${S}/${mod}" || die
+ [[ ${mod} == help ]] && mod2="helpcontent2"
+ mkdir -p "${S}/${mod2}/" || die
+ mv -n "${WORKDIR}/${PN}-${mod}-${PV}"/* "${S}/${mod2}" || die
rm -rf "${WORKDIR}/${PN}-${mod}-${PV}"
fi
done
@@ -384,10 +387,8 @@ src_configure() {
if use java; then
# hsqldb: system one is too new
- # saxon: system one does not work properly
java_opts="
--without-system-hsqldb
- --without-system-saxon
--with-ant-home="${ANT_HOME}"
--with-jdk-home=$(java-config --jdk-home 2>/dev/null)
--with-java-target-version=$(java-pkg_get-target)