summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-03-20 14:42:43 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-03-20 14:42:43 +0000
commit92e30dc9ab9520a01f6825f65071a6b955c08655 (patch)
tree772600726ac0cf7da08bc18891c09c5a698ef819 /app-pda/libsyncml
parentMask libsyncml 0.5.2 (diff)
downloadgentoo-2-92e30dc9ab9520a01f6825f65071a6b955c08655.tar.gz
gentoo-2-92e30dc9ab9520a01f6825f65071a6b955c08655.tar.bz2
gentoo-2-92e30dc9ab9520a01f6825f65071a6b955c08655.zip
Version bump so that it can build with net-wireless/bluez instead of net-wireless/bluez-libs.
(Portage version: 2.2_rc26/cvs/Linux x86_64)
Diffstat (limited to 'app-pda/libsyncml')
-rw-r--r--app-pda/libsyncml/ChangeLog11
-rw-r--r--app-pda/libsyncml/libsyncml-0.5.2.ebuild56
2 files changed, 65 insertions, 2 deletions
diff --git a/app-pda/libsyncml/ChangeLog b/app-pda/libsyncml/ChangeLog
index 59c01700d7ec..0f34f35e0789 100644
--- a/app-pda/libsyncml/ChangeLog
+++ b/app-pda/libsyncml/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-pda/libsyncml
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libsyncml/ChangeLog,v 1.12 2008/08/03 12:55:56 ulm Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libsyncml/ChangeLog,v 1.13 2009/03/20 14:42:43 flameeyes Exp $
+
+*libsyncml-0.5.2 (20 Mar 2009)
+
+ 20 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ +libsyncml-0.5.2.ebuild:
+ Version bump so that it can build with net-wireless/bluez instead of
+ net-wireless/bluez-libs.
03 Aug 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
diff --git a/app-pda/libsyncml/libsyncml-0.5.2.ebuild b/app-pda/libsyncml/libsyncml-0.5.2.ebuild
new file mode 100644
index 000000000000..24b2900974d4
--- /dev/null
+++ b/app-pda/libsyncml/libsyncml-0.5.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libsyncml/libsyncml-0.5.2.ebuild,v 1.1 2009/03/20 14:42:43 flameeyes Exp $
+
+EAPI="2"
+
+inherit eutils cmake-utils
+
+DESCRIPTION="Implementation of the SyncML protocol"
+HOMEPAGE="http://libsyncml.opensync.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+LICENSE="LGPL-2.1"
+IUSE="bluetooth debug doc http +obex"
+
+RDEPEND=">=dev-libs/glib-2.0
+ >=dev-libs/libwbxml-0.9.2
+ dev-libs/libxml2
+ http? ( >=net-libs/libsoup-2.2.91:2.2 )
+ obex? ( >=dev-libs/openobex-1.1 )
+ bluetooth? ( net-wireless/bluez
+ >=dev-libs/openobex-1.1[bluetooth] )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+# Some of the tests are broken
+RESTRICT="test"
+
+pkg_setup() {
+ if ! use obex && ! use http; then
+ eerror "${CATEGORY}/${P} without support for obex nor http is unusable."
+ eerror "Please enable \"obex\" or/and \"http\" USE flags."
+ die "Please enable \"obex\" or/and \"http\" USE flags."
+ fi
+
+ if use bluetooth && ! use obex; then
+ eerror "You are trying to build ${CATEGORY}/${P} with the \"bluetooth\""
+ eerror "USE flag, but you didn't enable the \"obex\" flag, which is"
+ eerror "needed for bluetooth support."
+ eerror "Please enable \"obex\" USE flag."
+ die "Please enable \"obex\" USE flag."
+ fi
+}
+
+src_compile() {
+ local mycmakeargs="
+ $(cmake-utils_use_enable http HTTP)
+ $(cmake-utils_use_enable obex OBEX)
+ $(cmake-utils_use_enable bluetooth BLUETOOTH)
+ $(cmake-utils_use_enable debug TRACE)"
+
+ cmake-utils_src_compile
+}