summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-07 19:28:33 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-07 19:28:33 +0000
commit73c8bb3eea1923a9389cb61c8718f8bf18c49409 (patch)
tree7606bacd389922024e728f3f7281e7e21660c1d5 /app-pda
parentversion bump (Manifest recommit) (diff)
downloadgentoo-2-73c8bb3eea1923a9389cb61c8718f8bf18c49409.tar.gz
gentoo-2-73c8bb3eea1923a9389cb61c8718f8bf18c49409.tar.bz2
gentoo-2-73c8bb3eea1923a9389cb61c8718f8bf18c49409.zip
add inherit eutils
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/pilot-link/pilot-link-0.11.8.ebuild14
-rw-r--r--app-pda/synce-libsynce/synce-libsynce-0.8.9.ebuild9
-rw-r--r--app-pda/synce-rra/synce-rra-0.8.9.ebuild9
3 files changed, 13 insertions, 19 deletions
diff --git a/app-pda/pilot-link/pilot-link-0.11.8.ebuild b/app-pda/pilot-link/pilot-link-0.11.8.ebuild
index 7c8907229091..f04971bb3741 100644
--- a/app-pda/pilot-link/pilot-link-0.11.8.ebuild
+++ b/app-pda/pilot-link/pilot-link-0.11.8.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.11.8.ebuild,v 1.6 2003/12/14 01:11:25 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.11.8.ebuild,v 1.7 2004/04/07 19:23:34 vapier Exp $
-inherit perl-module
+inherit perl-module eutils
DESCRIPTION="suite of tools for moving data between a Palm device and a desktop"
-SRC_URI="http://pilot-link.org/source/${P}.tar.bz2"
HOMEPAGE="http://www.pilot-link.org/"
+SRC_URI="http://pilot-link.org/source/${P}.tar.bz2"
-SLOT="0"
LICENSE="GPL-2 | LGPL-2"
+SLOT="0"
KEYWORDS="x86 ppc sparc alpha amd64"
IUSE="perl java tcltk python png readline"
@@ -56,7 +56,7 @@ src_compile() {
# java fails w/emake
make || die
- if [ `use perl` ] ; then
+ if use perl ; then
cd ${S}/bindings/Perl
perl-module_src_prep
perl-module_src_compile
@@ -68,7 +68,7 @@ src_install() {
dodoc ChangeLog README doc/README* doc/TODO NEWS AUTHORS
- if [ `use perl` ] ; then
+ if use perl ; then
cd ${S}/bindings/Perl
perl-module_src_install
fi
diff --git a/app-pda/synce-libsynce/synce-libsynce-0.8.9.ebuild b/app-pda/synce-libsynce/synce-libsynce-0.8.9.ebuild
index ddadaac3bcf2..b682298e859c 100644
--- a/app-pda/synce-libsynce/synce-libsynce-0.8.9.ebuild
+++ b/app-pda/synce-libsynce/synce-libsynce-0.8.9.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-libsynce/synce-libsynce-0.8.9.ebuild,v 1.2 2004/03/30 12:10:58 tad Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-libsynce/synce-libsynce-0.8.9.ebuild,v 1.3 2004/04/07 19:27:47 vapier Exp $
+
+inherit eutils
DESCRIPTION="Synchronize Windows CE devices with computers running GNU/Linux, like MS ActiveSync."
HOMEPAGE="http://sourceforge.net/projects/synce/"
@@ -18,11 +20,6 @@ src_unpack() {
epatch ${FILESDIR}/${PV}/${P}-gcc33.patch
}
-src_compile() {
- econf
- emake || die
-}
-
src_install() {
make DESTDIR=${D} install || die
dodoc README
diff --git a/app-pda/synce-rra/synce-rra-0.8.9.ebuild b/app-pda/synce-rra/synce-rra-0.8.9.ebuild
index 7fb2c9fd879d..4245923f98b4 100644
--- a/app-pda/synce-rra/synce-rra-0.8.9.ebuild
+++ b/app-pda/synce-rra/synce-rra-0.8.9.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-rra/synce-rra-0.8.9.ebuild,v 1.1 2004/03/26 12:34:10 tad Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-rra/synce-rra-0.8.9.ebuild,v 1.2 2004/04/07 19:28:00 vapier Exp $
+
+inherit eutils
DESCRIPTION="Synchronize Windows CE devices with computers running GNU/Linux, like MS ActiveSync."
HOMEPAGE="http://sourceforge.net/projects/synce/"
@@ -22,11 +24,6 @@ src_unpack() {
epatch ${DISTDIR}/librra-synce-kde-0.7.diff
}
-src_compile() {
- econf
- emake || die
-}
-
src_install() {
make DESTDIR="${D%/}" install || die
}