summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-03-15 22:01:18 +0000
committerRoy Marples <uberlord@gentoo.org>2007-03-15 22:01:18 +0000
commite515c9f26e5967d35c3f83b21f984bee53ab22e6 (patch)
tree8cd375c79c105eaf80acca9837b527948ce22e28 /app-shells/dash
parentdrop old (diff)
downloadgentoo-2-e515c9f26e5967d35c3f83b21f984bee53ab22e6.tar.gz
gentoo-2-e515c9f26e5967d35c3f83b21f984bee53ab22e6.tar.bz2
gentoo-2-e515c9f26e5967d35c3f83b21f984bee53ab22e6.zip
ka0ttic and exg are retired. I will take this over.
Update to debian patchset 7. Add patch to build correctly when LC_ALL isn't C. (Portage version: 2.1.2.2)
Diffstat (limited to 'app-shells/dash')
-rw-r--r--app-shells/dash/ChangeLog10
-rw-r--r--app-shells/dash/dash-0.5.3.7.ebuild45
-rw-r--r--app-shells/dash/files/dash-0.5.3-sort-locale.patch11
-rw-r--r--app-shells/dash/files/digest-dash-0.5.3.76
-rw-r--r--app-shells/dash/metadata.xml10
5 files changed, 74 insertions, 8 deletions
diff --git a/app-shells/dash/ChangeLog b/app-shells/dash/ChangeLog
index b1ecd9f2d4e6..f7ebd8c80f34 100644
--- a/app-shells/dash/ChangeLog
+++ b/app-shells/dash/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-shells/dash
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/ChangeLog,v 1.35 2007/02/21 23:08:31 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/ChangeLog,v 1.36 2007/03/15 22:01:18 uberlord Exp $
+
+*dash-0.5.3.7 (15 Mar 2007)
+
+ 15 Mar 2007; Roy Marples <uberlord@gentoo.org>
+ +files/dash-0.5.3-sort-locale.patch, metadata.xml, +dash-0.5.3.7.ebuild:
+ ka0ttic and exg are retired. I will take this over.
+ Update to debian patchset 7.
+ Add patch to build correctly when LC_ALL isn't C.
21 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/app-shells/dash/dash-0.5.3.7.ebuild b/app-shells/dash/dash-0.5.3.7.ebuild
new file mode 100644
index 000000000000..1a9f04a41c46
--- /dev/null
+++ b/app-shells/dash/dash-0.5.3.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/dash-0.5.3.7.ebuild,v 1.1 2007/03/15 22:01:18 uberlord Exp $
+
+inherit eutils versionator flag-o-matic toolchain-funcs
+
+DEB_P="${PN}_$(replace_version_separator 3 '-')"
+MY_P2="${DEB_P%-*}"
+MY_P="${MY_P2/_/-}"
+
+DESCRIPTION="Debian-version of NetBSD's lightweight bourne shell"
+HOMEPAGE="http://ftp.debian.org/debian/pool/main/d/dash/"
+SRC_URI="mirror://debian/pool/main/d/dash/${MY_P2}.orig.tar.gz \
+ mirror://debian/pool/main/d/dash/${DEB_P}.diff.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static"
+
+DEPEND="dev-util/yacc"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}/${DEB_P}".diff
+ epatch "${FILESDIR}/${MY_P}"-sort-locale.patch
+}
+
+src_compile() {
+ use static && append-ldflags -static
+
+ export CC="$(tc-getCC)"
+ econf || die "econf failed"
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ exeinto /bin
+ newexe src/dash dash
+ newman src/dash.1 dash.1
+ dodoc COPYING ChangeLog
+}
diff --git a/app-shells/dash/files/dash-0.5.3-sort-locale.patch b/app-shells/dash/files/dash-0.5.3-sort-locale.patch
new file mode 100644
index 000000000000..2494240e1df4
--- /dev/null
+++ b/app-shells/dash/files/dash-0.5.3-sort-locale.patch
@@ -0,0 +1,11 @@
+--- dash-0.5.3.orig/src/mkbuiltins 2005-11-26 03:17:55.000000000 +0000
++++ dash-0.5.3/src/mkbuiltins 2007-03-15 21:23:51.448422603 +0000
+@@ -65,7 +65,7 @@
+ if ($i ~ /^-/)
+ line = $(++i) "\t" line
+ print line
+- }}' $temp | sort -k 1,1 | tee $temp2 | awk '{
++ }}' $temp | LC_ALL=C sort -k 1,1 | tee $temp2 | awk '{
+ opt = ""
+ if (NF > 2) {
+ opt = substr($2, 2)
diff --git a/app-shells/dash/files/digest-dash-0.5.3.7 b/app-shells/dash/files/digest-dash-0.5.3.7
new file mode 100644
index 000000000000..c26d0fc023e9
--- /dev/null
+++ b/app-shells/dash/files/digest-dash-0.5.3.7
@@ -0,0 +1,6 @@
+MD5 6bcc0930804b790ab236af438f68475c dash_0.5.3-7.diff.gz 33290
+RMD160 b2d8263d16aa8500bab2b6d0c24598ebe6c4956d dash_0.5.3-7.diff.gz 33290
+SHA256 b0abe3a4ea9afc3136bad62b4b7f68fc6de961db46b7dc77a0c272cbe6c61477 dash_0.5.3-7.diff.gz 33290
+MD5 1a3cd6669459be4344ec55ec9d4914f8 dash_0.5.3.orig.tar.gz 207201
+RMD160 fd445535708868fe206852320eece58c3c2bbbaf dash_0.5.3.orig.tar.gz 207201
+SHA256 82aab2ff63e5fac4bff35c91222f735ec67551db86b5c3b3455ecc10e8889e53 dash_0.5.3.orig.tar.gz 207201
diff --git a/app-shells/dash/metadata.xml b/app-shells/dash/metadata.xml
index 8881475f99a8..18949c79c267 100644
--- a/app-shells/dash/metadata.xml
+++ b/app-shells/dash/metadata.xml
@@ -1,13 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>no-herd</herd>
+ <herd>base-system</herd>
<maintainer>
- <email>ka0ttic@gentoo.org</email>
- <name>Aaron Walker</name>
- </maintainer>
- <maintainer>
- <email>exg@gentoo.org</email>
- <name>Emanuele Giaquinta</name>
+ <email>uberlord@gentoo.org</email>
+ <name>Roy Marples</name>
</maintainer>
</pkgmetadata>