summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-08 01:58:06 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-08 01:58:06 +0000
commit27446be84ec019b4cdf01a26115101baec823ee4 (patch)
treef8b74d4b18fb179246f0bb38eec44b4d4a55819f /app-shells
parentno need for -L$ROOT workaround in ebuild (Manifest recommit) (diff)
downloadgentoo-2-27446be84ec019b4cdf01a26115101baec823ee4.tar.gz
gentoo-2-27446be84ec019b4cdf01a26115101baec823ee4.tar.bz2
gentoo-2-27446be84ec019b4cdf01a26115101baec823ee4.zip
make sure sash respects $LDFLAGS
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/sash/sash-3.7.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/app-shells/sash/sash-3.7.ebuild b/app-shells/sash/sash-3.7.ebuild
index 504c21ca7b30..2549cbdde7fd 100644
--- a/app-shells/sash/sash-3.7.ebuild
+++ b/app-shells/sash/sash-3.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.7.ebuild,v 1.17 2004/12/08 01:09:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.7.ebuild,v 1.18 2004/12/08 01:58:06 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -26,12 +26,10 @@ src_unpack() {
epatch ${FILESDIR}/sash-3.7-builtin.patch
use readline && epatch ${FILESDIR}/sash-3.6-readline.patch
- # this indicates broken header files but don't know what to do
- # about it yet. (03 Mar 2004 agriffis)
- use ia64 && append-flags -Du64=__u64 -Du32=__u32 -Ds64=__s64 -Ds32=__s32
-
- # use our CFLAGS in the Makefile
- sed -e "s:-O3:${CFLAGS}:" -i Makefile
+ sed -i \
+ -e "s:-O3:${CFLAGS}:" \
+ -e "/^LDFLAGS /s:$:${LDFLAGS}:" \
+ Makefile || die "sed failed"
}
src_compile() {