summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNguyen Thai Ngoc Duy <pclouds@gentoo.org>2008-02-13 20:02:34 +0000
committerNguyen Thai Ngoc Duy <pclouds@gentoo.org>2008-02-13 20:02:34 +0000
commitc2a9757e284fb2b1520e49e094bdf1d9c567688b (patch)
tree135b4cac17e6bdfb37a72149f7afb91bee3fc3bb /app-text
parentquoting (diff)
downloadgentoo-2-c2a9757e284fb2b1520e49e094bdf1d9c567688b.tar.gz
gentoo-2-c2a9757e284fb2b1520e49e094bdf1d9c567688b.tar.bz2
gentoo-2-c2a9757e284fb2b1520e49e094bdf1d9c567688b.zip
Version bump, #155734
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/vilistextum/ChangeLog8
-rw-r--r--app-text/vilistextum/files/vilistextum-2.6.9-gentoo.diff22
-rw-r--r--app-text/vilistextum/vilistextum-2.6.9.ebuild43
3 files changed, 72 insertions, 1 deletions
diff --git a/app-text/vilistextum/ChangeLog b/app-text/vilistextum/ChangeLog
index c72789d3e4d9..4f3446eca616 100644
--- a/app-text/vilistextum/ChangeLog
+++ b/app-text/vilistextum/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/vilistextum
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/vilistextum/ChangeLog,v 1.23 2008/01/11 21:46:17 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/vilistextum/ChangeLog,v 1.24 2008/02/13 20:02:33 pclouds Exp $
+
+*vilistextum-2.6.9 (13 Feb 2008)
+
+ 13 Feb 2008; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
+ +files/vilistextum-2.6.9-gentoo.diff, +vilistextum-2.6.9.ebuild:
+ Version bump, #155734
11 Jan 2008; Fabian Groffen <grobian@gentoo.org> vilistextum-2.6.7.ebuild:
Dropped ppc-macos keyword, see you in prefix
diff --git a/app-text/vilistextum/files/vilistextum-2.6.9-gentoo.diff b/app-text/vilistextum/files/vilistextum-2.6.9-gentoo.diff
new file mode 100644
index 000000000000..42db519b080a
--- /dev/null
+++ b/app-text/vilistextum/files/vilistextum-2.6.9-gentoo.diff
@@ -0,0 +1,22 @@
+diff -ur vilistextum-2.6.9/src/Makefile.am vilistextum-2.6.9.new/src/Makefile.am
+--- vilistextum-2.6.9/src/Makefile.am 2006-10-24 01:48:54.000000000 +0700
++++ vilistextum-2.6.9.new/src/Makefile.am 2006-11-20 09:51:24.000000000 +0700
+@@ -6,7 +6,7 @@
+ main.c main.h util.c util.h \
+ multibyte.h unicode_entities.c unicode_entities.h
+
+-AM_CFLAGS = -Wall -O2 -ansi
++AM_CFLAGS = -Wall -ansi
+ AM_LDFLAGS = $(STATIC)
+
+ EXTRA_DIST = kilistextum.kaptn
+diff -ur vilistextum-2.6.9/tests/Makefile.am vilistextum-2.6.9.new/tests/Makefile.am
+--- vilistextum-2.6.9/tests/Makefile.am 2004-07-06 19:06:20.000000000 +0700
++++ vilistextum-2.6.9.new/tests/Makefile.am 2006-11-20 09:51:05.000000000 +0700
+@@ -16,5 +16,5 @@
+
+ test: check
+
+-all: check
++all:
+
diff --git a/app-text/vilistextum/vilistextum-2.6.9.ebuild b/app-text/vilistextum/vilistextum-2.6.9.ebuild
new file mode 100644
index 000000000000..a7fffbc8592e
--- /dev/null
+++ b/app-text/vilistextum/vilistextum-2.6.9.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/vilistextum/vilistextum-2.6.9.ebuild,v 1.1 2008/02/13 20:02:33 pclouds Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit eutils autotools
+
+DESCRIPTION="Vilistextum is a html to ascii converter specifically programmed to get the best out of incorrect html."
+HOMEPAGE="http://bhaak.dyndns.org/vilistextum/"
+SRC_URI="http://bhaak.dyndns.org/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+#IUSE="unicode kde"
+IUSE="unicode"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=""
+# KDE support will be available once a version of kaptain in stable
+# kde? ( kde-misc/kaptain )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gentoo.diff"
+
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_enable unicode multibyte) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc README CHANGES
+ dohtml doc/*.{html,css}
+}