summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-27 20:20:16 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-27 20:20:16 +0000
commit9737fe9a0e210606df6ebffe54354d556f90802c (patch)
tree157e58857f046dc8e4459aeb7a5aa7416a86f131 /dev-cpp
parentadd ~x86, bug #469594 (diff)
downloadgentoo-2-9737fe9a0e210606df6ebffe54354d556f90802c.tar.gz
gentoo-2-9737fe9a0e210606df6ebffe54354d556f90802c.tar.bz2
gentoo-2-9737fe9a0e210606df6ebffe54354d556f90802c.zip
Fix shared lib installation on FreeBSD.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/tbb/ChangeLog5
-rw-r--r--dev-cpp/tbb/tbb-4.1.20130613.ebuild7
2 files changed, 10 insertions, 2 deletions
diff --git a/dev-cpp/tbb/ChangeLog b/dev-cpp/tbb/ChangeLog
index 6c1ba030fe60..968ae55a7e37 100644
--- a/dev-cpp/tbb/ChangeLog
+++ b/dev-cpp/tbb/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-cpp/tbb
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/ChangeLog,v 1.42 2013/08/27 19:41:16 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/ChangeLog,v 1.43 2013/08/27 20:20:16 aballier Exp $
+
+ 27 Aug 2013; Alexis Ballier <aballier@gentoo.org> tbb-4.1.20130613.ebuild:
+ Fix shared lib installation on FreeBSD.
27 Aug 2013; Alexis Ballier <aballier@gentoo.org> tbb-4.1.20130613.ebuild:
keyword ~amd64-fbsd
diff --git a/dev-cpp/tbb/tbb-4.1.20130613.ebuild b/dev-cpp/tbb/tbb-4.1.20130613.ebuild
index e9207d219f1e..99b6b8d02e3c 100644
--- a/dev-cpp/tbb/tbb-4.1.20130613.ebuild
+++ b/dev-cpp/tbb/tbb-4.1.20130613.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/tbb-4.1.20130613.ebuild,v 1.2 2013/08/27 19:41:16 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/tbb-4.1.20130613.ebuild,v 1.3 2013/08/27 20:20:16 aballier Exp $
EAPI=5
inherit eutils flag-o-matic multilib versionator toolchain-funcs
@@ -38,6 +38,11 @@ src_prepare() {
-e "/^ASM/s/as/$(tc-getAS)/g" \
build/*.gcc.inc || die
+ # Give it a soname on FreeBSD
+ echo 'LIB_LINK_FLAGS += -Wl,-soname=$(BUILDING_LIBRARY)' >> build/FreeBSD.gcc.inc
+ # Set proper versionning on FreeBSD
+ sed -i -e '/.DLL =/s/$/.1/' build/FreeBSD.inc || die
+
# force 64bit where applicable, 32bit where applicable...
# built-in detection is based on running kernel, which messes up
# e.g. in a x86 chroot on amd64 kernel. Bug 462130