summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-06 14:03:29 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-06 14:03:29 +0000
commitd9e04b0af63fdc989148d5218a5d0b8aa89a2d7f (patch)
treef20d0e48d9b0dc53212b50398f4a98dd29c7887d /dev-db
parentVersion bump, Bug 352879, jobserver fix (diff)
downloadgentoo-2-d9e04b0af63fdc989148d5218a5d0b8aa89a2d7f.tar.gz
gentoo-2-d9e04b0af63fdc989148d5218a5d0b8aa89a2d7f.tar.bz2
gentoo-2-d9e04b0af63fdc989148d5218a5d0b8aa89a2d7f.zip
Version bump (bug #353772). Fix building on FreeMiNT (bug #344353). Fixed building of tests with USE="-threadsafe" (bug #348435).
(Portage version: 2.2.0_alpha20/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/sqlite/ChangeLog11
-rw-r--r--dev-db/sqlite/files/sqlite-3.7.5-utimes.patch35
-rw-r--r--dev-db/sqlite/sqlite-3.7.5.ebuild159
3 files changed, 203 insertions, 2 deletions
diff --git a/dev-db/sqlite/ChangeLog b/dev-db/sqlite/ChangeLog
index 7a796788c414..38946d862110 100644
--- a/dev-db/sqlite/ChangeLog
+++ b/dev-db/sqlite/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-db/sqlite
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.359 2010/12/13 04:43:54 jer Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.360 2011/02/06 14:03:29 arfrever Exp $
+
+*sqlite-3.7.5 (06 Feb 2011)
+
+ 06 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +sqlite-3.7.5.ebuild, +files/sqlite-3.7.5-utimes.patch:
+ Version bump (bug #353772). Fix building on FreeMiNT (bug #344353). Fixed
+ building of tests with USE="-threadsafe" (bug #348435).
13 Dec 2010; Jeroen Roovers <jer@gentoo.org> sqlite-3.7.3.ebuild:
Stable for HPPA PPC (bug #348079).
diff --git a/dev-db/sqlite/files/sqlite-3.7.5-utimes.patch b/dev-db/sqlite/files/sqlite-3.7.5-utimes.patch
new file mode 100644
index 000000000000..4e8732926a2a
--- /dev/null
+++ b/dev-db/sqlite/files/sqlite-3.7.5-utimes.patch
@@ -0,0 +1,35 @@
+--- configure.ac
++++ configure.ac
+@@ -127,7 +127,7 @@
+ #########
+ # Figure out whether or not we have these functions
+ #
+-AC_CHECK_FUNCS([usleep fdatasync localtime_r gmtime_r localtime_s])
++AC_CHECK_FUNCS([usleep utimes fdatasync localtime_r gmtime_r localtime_s])
+
+ #########
+ # By default, we use the amalgamation (this may be changed below...)
+--- src/os_unix.c
++++ src/os_unix.c
+@@ -122,6 +122,9 @@
+ #ifndef SQLITE_OMIT_WAL
+ #include <sys/mman.h>
+ #endif
++#ifndef HAVE_UTIMES
++#include <utime.h>
++#endif
+
+ #if SQLITE_ENABLE_LOCKING_STYLE
+ # include <sys/ioctl.h>
+@@ -1610,7 +1613,11 @@
+ pFile->eFileLock = eFileLock;
+ #if !OS_VXWORKS
+ /* Always update the timestamp on the old file */
++#ifdef HAVE_UTIMES
+ utimes(zLockFile, NULL);
++#else
++ utime(zLockFile, NULL);
++#endif
+ #endif
+ return SQLITE_OK;
+ }
diff --git a/dev-db/sqlite/sqlite-3.7.5.ebuild b/dev-db/sqlite/sqlite-3.7.5.ebuild
new file mode 100644
index 000000000000..534d69c14165
--- /dev/null
+++ b/dev-db/sqlite/sqlite-3.7.5.ebuild
@@ -0,0 +1,159 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.7.5.ebuild,v 1.1 2011/02/06 14:03:29 arfrever Exp $
+
+EAPI="3"
+
+inherit autotools eutils flag-o-matic multilib versionator
+
+MY_PV="$(printf "%u%02u%02u%02u" $(get_version_components))"
+
+DESCRIPTION="A SQL Database Engine in a C Library"
+HOMEPAGE="http://sqlite.org/"
+SRC_URI="doc? ( http://sqlite.org/${PN}-doc-${MY_PV}.zip )
+ tcl? ( http://sqlite.org/${PN}-src-${MY_PV}.zip )
+ !tcl? (
+ test? ( http://sqlite.org/${PN}-src-${MY_PV}.zip )
+ !test? ( http://sqlite.org/${PN}-autoconf-${MY_PV}.tar.gz )
+ )"
+
+LICENSE="as-is"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug doc +extensions +fts3 icu +readline secure-delete soundex tcl test +threadsafe unlock-notify"
+
+RDEPEND="icu? ( dev-libs/icu )
+ readline? ( sys-libs/readline )
+ tcl? ( dev-lang/tcl )"
+DEPEND="${RDEPEND}
+ doc? ( app-arch/unzip )
+ tcl? ( app-arch/unzip )
+ test? (
+ app-arch/unzip
+ dev-lang/tcl
+ )"
+
+amalgamation() {
+ use !tcl && use !test
+}
+
+pkg_setup() {
+ if amalgamation; then
+ S="${WORKDIR}/${PN}-autoconf-${MY_PV}"
+ else
+ S="${WORKDIR}/${PN}-src-${MY_PV}"
+ fi
+}
+
+src_prepare() {
+ if amalgamation; then
+ epatch "${FILESDIR}/${PN}-3.6.22-interix-fixes-amalgamation.patch"
+ else
+ epatch "${FILESDIR}/${P}-utimes.patch"
+ epatch "${FILESDIR}/${PN}-3.6.22-dlopen.patch"
+ fi
+
+ eautoreconf
+ epunt_cxx
+}
+
+src_configure() {
+ # `configure` from amalgamation tarball doesn't add -DSQLITE_DEBUG or -DNDEBUG flag.
+ if amalgamation; then
+ if use debug; then
+ append-cppflags -DSQLITE_DEBUG
+ else
+ append-cppflags -DNDEBUG
+ fi
+ fi
+
+ # Support column metadata, bug #266651
+ append-cppflags -DSQLITE_ENABLE_COLUMN_METADATA
+
+ # Support R-trees, bug #257646
+ append-cppflags -DSQLITE_ENABLE_RTREE
+
+ if use icu; then
+ append-cppflags -DSQLITE_ENABLE_ICU
+ if amalgamation; then
+ sed -e "s/LIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
+ else
+ sed -e "s/TLIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
+ fi
+ fi
+
+ # Support FTS3, bug #207701
+ if use fts3; then
+ append-cppflags -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS
+ fi
+
+ # Enable secure_delete pragma by default
+ if use secure-delete; then
+ append-cppflags -DSQLITE_SECURE_DELETE -DSQLITE_CHECK_PAGES -DSQLITE_CORE
+ fi
+
+ # Support soundex, bug #143794
+ if use soundex; then
+ append-cppflags -DSQLITE_SOUNDEX
+ fi
+
+ # Enable unlock notification
+ if use unlock-notify; then
+ append-cppflags -DSQLITE_ENABLE_UNLOCK_NOTIFY
+ fi
+
+ local extensions_option
+ if amalgamation; then
+ extensions_option="dynamic-extensions"
+ else
+ extensions_option="load-extension"
+ fi
+
+ # Starting from 3.6.23, SQLite has locking strategies that are specific to
+ # OSX. By default they are enabled, and use semantics that only make sense
+ # on OSX. However, they require gethostuuid() function for that, which is
+ # only available on OSX starting from 10.6 (Snow Leopard). For earlier
+ # versions of OSX we have to disable all this nifty locking options, as
+ # suggested by upstream.
+ if [[ "${CHOST}" == *-darwin[56789] ]]; then
+ append-cppflags -DSQLITE_ENABLE_LOCKING_STYLE="0"
+ fi
+
+ if [[ "${CHOST}" == *-mint* ]]; then
+ append-cppflags -DSQLITE_OMIT_WAL
+ fi
+
+ # `configure` from amalgamation tarball doesn't support
+ # --with-readline-inc and --(enable|disable)-tcl options.
+ econf \
+ $(use_enable extensions ${extensions_option}) \
+ $(use_enable readline) \
+ $(use_enable threadsafe) \
+ $(amalgamation || echo --with-readline-inc="-I${EPREFIX}/usr/include/readline") \
+ $(amalgamation || use_enable debug) \
+ $(amalgamation || echo --enable-tcl)
+}
+
+src_compile() {
+ emake TCLLIBDIR="${EPREFIX}/usr/$(get_libdir)/${P}" || die "emake failed"
+}
+
+src_test() {
+ if [[ "${EUID}" -eq "0" ]]; then
+ ewarn "Skipping tests due to root permissions"
+ return
+ fi
+
+ local test="test"
+ use debug && test="fulltest"
+ emake ${test} || die "Test failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" TCLLIBDIR="${EPREFIX}/usr/$(get_libdir)/${P}" install || die "emake install failed"
+ doman sqlite3.1 || die "doman failed"
+
+ if use doc; then
+ dohtml -r "${WORKDIR}/${PN}-doc-${MY_PV}/"* || die "dohtml failed"
+ fi
+}