summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2008-06-01 11:51:35 +0000
committerJurek Bartuszek <jurek@gentoo.org>2008-06-01 11:51:35 +0000
commit1847026602074495b5c17fc84fa05a1af1e8b2c2 (patch)
treec8e677e37e6ac502669bb6447cd86e338da6ee12 /dev-dotnet/libgdiplus
parentDepend on x11-libs/openmotif explicitely for USE=motif. (diff)
downloadgentoo-2-1847026602074495b5c17fc84fa05a1af1e8b2c2.tar.gz
gentoo-2-1847026602074495b5c17fc84fa05a1af1e8b2c2.tar.bz2
gentoo-2-1847026602074495b5c17fc84fa05a1af1e8b2c2.zip
dev-dotnet/libgdiplus: Added check whether x11-libs/cairo has been built with X USE flag enabled
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-dotnet/libgdiplus')
-rw-r--r--dev-dotnet/libgdiplus/ChangeLog5
-rw-r--r--dev-dotnet/libgdiplus/libgdiplus-1.9.ebuild9
2 files changed, 12 insertions, 2 deletions
diff --git a/dev-dotnet/libgdiplus/ChangeLog b/dev-dotnet/libgdiplus/ChangeLog
index f90858b343b4..0ec2ae4ed550 100644
--- a/dev-dotnet/libgdiplus/ChangeLog
+++ b/dev-dotnet/libgdiplus/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-dotnet/libgdiplus
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/libgdiplus/ChangeLog,v 1.86 2008/06/01 01:47:30 jurek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/libgdiplus/ChangeLog,v 1.87 2008/06/01 11:51:35 jurek Exp $
+
+ 01 Jun 2008; Jurek Bartuszek <jurek@gentoo.org> libgdiplus-1.9.ebuild:
+ Added check whether x11-libs/cairo has been built with X USE flag enabled
01 Jun 2008; Jurek Bartuszek <jurek@gentoo.org> libgdiplus-1.2.4.ebuild,
libgdiplus-1.9.ebuild:
diff --git a/dev-dotnet/libgdiplus/libgdiplus-1.9.ebuild b/dev-dotnet/libgdiplus/libgdiplus-1.9.ebuild
index 07565c185521..0ab80d294719 100644
--- a/dev-dotnet/libgdiplus/libgdiplus-1.9.ebuild
+++ b/dev-dotnet/libgdiplus/libgdiplus-1.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/libgdiplus/libgdiplus-1.9.ebuild,v 1.2 2008/06/01 01:47:30 jurek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/libgdiplus/libgdiplus-1.9.ebuild,v 1.3 2008/06/01 11:51:35 jurek Exp $
inherit eutils flag-o-matic toolchain-funcs autotools
@@ -30,6 +30,13 @@ DEPEND="${RDEPEND}
RESTRICT="test"
+pkg_setup() {
+ if ! built_with_use x11-libs/cairo X; then
+ eerror "you need to compile x11-libs/cairo with X USE flag enabled"
+ die "missing X USE flag on x11-libs/cairo"
+ fi
+}
+
src_unpack() {
unpack ${A}
cd "${S}"