summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2013-11-14 07:56:18 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2013-11-14 07:56:18 +0000
commit62202f262c56106dbea29459207a8b171accc8f9 (patch)
treed948befd18ac9416b5af406dcfea7708b3d9cff2 /dev-haskell/bytestring-mmap
parentNew dep to testsuite of glance, ebuild prepped by me (diff)
downloadgentoo-2-62202f262c56106dbea29459207a8b171accc8f9.tar.gz
gentoo-2-62202f262c56106dbea29459207a8b171accc8f9.tar.bz2
gentoo-2-62202f262c56106dbea29459207a8b171accc8f9.zip
Initial commit. mmap support for strict ByteStrings.
(Portage version: 2.2.7_p18/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell/bytestring-mmap')
-rw-r--r--dev-haskell/bytestring-mmap/ChangeLog9
-rw-r--r--dev-haskell/bytestring-mmap/Manifest3
-rw-r--r--dev-haskell/bytestring-mmap/bytestring-mmap-0.2.2-r1.ebuild25
-rw-r--r--dev-haskell/bytestring-mmap/metadata.xml16
4 files changed, 53 insertions, 0 deletions
diff --git a/dev-haskell/bytestring-mmap/ChangeLog b/dev-haskell/bytestring-mmap/ChangeLog
new file mode 100644
index 000000000000..7d5127e78193
--- /dev/null
+++ b/dev-haskell/bytestring-mmap/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-haskell/bytestring-mmap
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/bytestring-mmap/ChangeLog,v 1.1 2013/11/14 07:56:18 slyfox Exp $
+
+*bytestring-mmap-0.2.2-r1 (14 Nov 2013)
+
+ 14 Nov 2013; Sergei Trofimovich <slyfox@gentoo.org>
+ +bytestring-mmap-0.2.2-r1.ebuild, +metadata.xml:
+ Initial commit. mmap support for strict ByteStrings.
diff --git a/dev-haskell/bytestring-mmap/Manifest b/dev-haskell/bytestring-mmap/Manifest
new file mode 100644
index 000000000000..586c39ad3b8a
--- /dev/null
+++ b/dev-haskell/bytestring-mmap/Manifest
@@ -0,0 +1,3 @@
+DIST bytestring-mmap-0.2.2.tar.gz 7188 SHA256 7bbcaeeccec5cf448ba59c9ed4de95bcc47b11ae2b9bcddb6201decb88eb69af SHA512 0cde0bb36808d7086f6b3e3e94813c205a61ec1d0b2156a7fac98c1dc520dcdd1821a7873b7ecb9a77fdcd254b5ac1077da86865ade20a49bba0e0da1befcf46 WHIRLPOOL bb7216bd5b2e511d2f6c68326bea5062eafe99f93d4e855d90ca6a3b82be5ddd6b842d75b3efdae07a3eee3268a0b6c9680c1c419fad2cc9b9a54cf942be3d78
+EBUILD bytestring-mmap-0.2.2-r1.ebuild 576 SHA256 7478718644715ba836f20fa376d262462d0ed2fdde541ee1f5ba8f78ce48c355 SHA512 6f3dea4d4efb062529e5ebf16a1539902947e9be752e99f2b5769fa62c3742530462de3a08a3fe3539e90743f26e1c95504ab2fc5d1cc30a33e4a2f5ef0d1f75 WHIRLPOOL e6366e38838bacc82fd376e58ecf152bad78691d417eebf0353d1056e7de909c74bedd98cbf2ed563b0140e82c0d49c9dd1b9b805a6b3eacca0104e2638c6124
+MISC metadata.xml 472 SHA256 b79cfcd5cb696aecc0de8b567e0c5bd409e653b950c8eb6b986f65fa59f77888 SHA512 d376ad0cbf3a54a52c915ad11df08ca37a1ade96e0d52f862462936f7d4bfc2adcca8ba56f40daed4445f0ada31f8fedd865719732c4e270cfed36930771053c WHIRLPOOL 83272326fef3a82a2f28b1456c227033d9a87de98f663db7fd855bef0c576c24fdc52710abd07e0eed76c264a196d41d624a20df25fe04a510c3e3e372027be3
diff --git a/dev-haskell/bytestring-mmap/bytestring-mmap-0.2.2-r1.ebuild b/dev-haskell/bytestring-mmap/bytestring-mmap-0.2.2-r1.ebuild
new file mode 100644
index 000000000000..e4f156e39e0b
--- /dev/null
+++ b/dev-haskell/bytestring-mmap/bytestring-mmap-0.2.2-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/bytestring-mmap/bytestring-mmap-0.2.2-r1.ebuild,v 1.1 2013/11/14 07:56:18 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="mmap support for strict ByteStrings"
+HOMEPAGE="http://code.haskell.org/~dons/code/bytestring-mmap/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6.0.3
+"
diff --git a/dev-haskell/bytestring-mmap/metadata.xml b/dev-haskell/bytestring-mmap/metadata.xml
new file mode 100644
index 000000000000..a914eb5ebd1a
--- /dev/null
+++ b/dev-haskell/bytestring-mmap/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+
+ This library provides a wrapper to mmap(2), allowing files or
+ devices to be lazily loaded into memory as strict or lazy
+ ByteStrings, using the virtual memory subsystem to do on-demand
+ loading.
+
+ </longdescription>
+</pkgmetadata>