summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-05-26 04:02:58 +0000
committerMark Wright <gienah@gentoo.org>2013-05-26 04:02:58 +0000
commit108b348a8c26843a5d60e4cfb003438d70f8724e (patch)
tree1f7e304a89e77f480d7e3a3ab84ba4e4d380577c /dev-haskell/haskell-platform
parentAdd case-insensitive for haskell-platform-2013.2.0.0 (diff)
downloadgentoo-2-108b348a8c26843a5d60e4cfb003438d70f8724e.tar.gz
gentoo-2-108b348a8c26843a5d60e4cfb003438d70f8724e.tar.bz2
gentoo-2-108b348a8c26843a5d60e4cfb003438d70f8724e.zip
Bump haskell-platform to 2013.2.0.0
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/haskell-platform')
-rw-r--r--dev-haskell/haskell-platform/ChangeLog8
-rw-r--r--dev-haskell/haskell-platform/haskell-platform-2013.2.0.0.ebuild64
2 files changed, 71 insertions, 1 deletions
diff --git a/dev-haskell/haskell-platform/ChangeLog b/dev-haskell/haskell-platform/ChangeLog
index b0720d93872c..8e552118872d 100644
--- a/dev-haskell/haskell-platform/ChangeLog
+++ b/dev-haskell/haskell-platform/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/haskell-platform
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haskell-platform/ChangeLog,v 1.11 2013/02/09 18:38:04 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haskell-platform/ChangeLog,v 1.12 2013/05/26 04:02:58 gienah Exp $
+
+*haskell-platform-2013.2.0.0 (26 May 2013)
+
+ 26 May 2013; Mark Wright <gienah@gentoo.org>
+ +haskell-platform-2013.2.0.0.ebuild:
+ Bump haskell-platform to 2013.2.0.0
09 Feb 2013; Sergei Trofimovich <slyfox@gentoo.org>
-haskell-platform-2009.2.0.2-r1.ebuild:
diff --git a/dev-haskell/haskell-platform/haskell-platform-2013.2.0.0.ebuild b/dev-haskell/haskell-platform/haskell-platform-2013.2.0.0.ebuild
new file mode 100644
index 000000000000..322b37cc8305
--- /dev/null
+++ b/dev-haskell/haskell-platform/haskell-platform-2013.2.0.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haskell-platform/haskell-platform-2013.2.0.0.ebuild,v 1.1 2013/05/26 04:02:58 gienah Exp $
+
+EAPI=5
+
+DESCRIPTION="The Haskell Platform"
+HOMEPAGE="http://haskell.org/platform"
+SRC_URI=""
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="profile X"
+
+RDEPEND=">=dev-haskell/async-2.0.1.4:=[profile?]
+ >=dev-haskell/attoparsec-0.10.4.0:=[profile?]
+ >=dev-haskell/case-insensitive-1.0.0.1:=[profile?]
+ >=dev-haskell/cgi-3001.1.7.5:=[profile?]
+ >=dev-haskell/fgl-5.4.2.4:=[profile?]
+ >=dev-haskell/hashable-1.1.2.5:=[profile?]
+ >=dev-haskell/haskell-src-1.0.1.5:=[profile?]
+ >=dev-haskell/html-1.0.1.2:=[profile?]
+ >=dev-haskell/http-4000.2.8:=[profile?]
+ >=dev-haskell/hunit-1.2.5.2:=[profile?]
+ >=dev-haskell/mtl-2.1.2:=[profile?]
+ >=dev-haskell/network-2.4.1.2:=[profile?]
+ >=dev-haskell/parallel-3.2.0.3:=[profile?]
+ >=dev-haskell/parsec-3.1.3:=[profile?]
+ >=dev-haskell/primitive-0.5.0.1:=[profile?]
+ >=dev-haskell/quickcheck-2.6:=[profile?]
+ >=dev-haskell/random-1.0.1.1:=[profile?]
+ >=dev-haskell/regex-base-0.93.2:=[profile?]
+ >=dev-haskell/regex-compat-0.95.1:=[profile?]
+ >=dev-haskell/regex-posix-0.95.2:=[profile?]
+ >=dev-haskell/split-0.2.2:=[profile?]
+ >=dev-haskell/stm-2.4.2:=[profile?]
+ >=dev-haskell/syb-0.4.0:=[profile?]
+ >=dev-haskell/text-0.11.3.1:=[profile?]
+ >=dev-haskell/transformers-0.3.0.0:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.3.0:=[profile?]
+ >=dev-haskell/vector-0.10.0.1:=[profile?]
+ >=dev-haskell/xhtml-3000.2.1:=[profile?]
+ >=dev-haskell/zlib-0.5.4.1:=[profile?]
+ X? (
+ >=dev-haskell/gluraw-1.3.0.0:=[profile?]
+ >=dev-haskell/glut-2.4.0.0:=[profile?]
+ >=dev-haskell/opengl-2.8.0.0:=[profile?]
+ >=dev-haskell/openglraw-1.3.0.0:=[profile?]
+ )
+ >=dev-lang/ghc-7.6.2:=
+ >=dev-haskell/alex-3.0.5
+ >=dev-haskell/cabal-1.16.0.3
+ >=dev-haskell/happy-1.18.10
+ >=dev-haskell/hscolour-1.19
+ >=dev-haskell/haddock-2.13.2"
+DEPEND="${RDEPEND}"
+
+pkg_postinst() {
+ if ! use X; then
+ elog "The haskell platform includes the 3D graphics libraries opengl and glut."
+ elog "To install opengl and glut requires the X use flag."
+ fi
+}