summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2011-04-25 09:56:06 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2011-04-25 09:56:06 +0000
commit2f79b78e91a7c69b34176a0cc88bf5a0fd598da3 (patch)
tree559d07a7d2415a163666c6fee85dc81e77002991 /dev-haskell/highlighting-kate
parentInitial commit - thanks to Oleg Gawriloff bug #318853 (diff)
downloadgentoo-2-2f79b78e91a7c69b34176a0cc88bf5a0fd598da3.tar.gz
gentoo-2-2f79b78e91a7c69b34176a0cc88bf5a0fd598da3.tar.bz2
gentoo-2-2f79b78e91a7c69b34176a0cc88bf5a0fd598da3.zip
Initial version.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/highlighting-kate')
-rw-r--r--dev-haskell/highlighting-kate/ChangeLog10
-rw-r--r--dev-haskell/highlighting-kate/highlighting-kate-0.2.9.ebuild31
-rw-r--r--dev-haskell/highlighting-kate/metadata.xml21
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-haskell/highlighting-kate/ChangeLog b/dev-haskell/highlighting-kate/ChangeLog
new file mode 100644
index 000000000000..8198f2687b99
--- /dev/null
+++ b/dev-haskell/highlighting-kate/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-haskell/highlighting-kate
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/highlighting-kate/ChangeLog,v 1.1 2011/04/25 09:56:06 slyfox Exp $
+
+*highlighting-kate-0.2.9 (25 Apr 2011)
+
+ 25 Apr 2011; Sergei Trofimovich <slyfox@gentoo.org>
+ +highlighting-kate-0.2.9.ebuild, +metadata.xml:
+ Initial version.
+
diff --git a/dev-haskell/highlighting-kate/highlighting-kate-0.2.9.ebuild b/dev-haskell/highlighting-kate/highlighting-kate-0.2.9.ebuild
new file mode 100644
index 000000000000..f61879276540
--- /dev/null
+++ b/dev-haskell/highlighting-kate/highlighting-kate-0.2.9.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/highlighting-kate/highlighting-kate-0.2.9.ebuild,v 1.1 2011/04/25 09:56:06 slyfox Exp $
+
+# ebuild generated by hackport 0.2.13
+
+EAPI="3"
+
+CABAL_FEATURES="bin lib profile haddock hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Syntax highlighting binary and library using kate syntax files"
+HOMEPAGE="http://github.com/jgm/highlighting-kate"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="executable"
+
+RDEPEND="dev-haskell/parsec
+ dev-haskell/regex-pcre-builtin
+ dev-haskell/xhtml
+ >=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+src_compile() {
+ cabal_src_compile \
+ $(cabal_flag executable)
+}
diff --git a/dev-haskell/highlighting-kate/metadata.xml b/dev-haskell/highlighting-kate/metadata.xml
new file mode 100644
index 000000000000..6b7e545fd165
--- /dev/null
+++ b/dev-haskell/highlighting-kate/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ highlighting-kate is a syntax highlighting library
+ with support for over one hundred languages. The syntax
+ parsers are automatically generated from Kate
+ syntax descriptions (http://kate-editor.org/),
+ so any syntax supported by Kate can be added.
+ An (optional) command-line program is provided, along
+ with a utility for generating new parsers from Kate
+ XML syntax descriptions.
+ </longdescription>
+ <use>
+ <flag name="executable">Build the Highlight executable</flag>
+ </use>
+</pkgmetadata>