summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-07-22 22:54:58 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-07-22 22:54:58 +0000
commitf4ec3fa4dec651f32436e53d4155b5b7bba1386c (patch)
tree7c0a1e06d6c5e9d019302cbc710ae7b72bc21e0a /dev-java/commons-jelly
parentMigrated to Generation 2. (diff)
downloadgentoo-2-f4ec3fa4dec651f32436e53d4155b5b7bba1386c.tar.gz
gentoo-2-f4ec3fa4dec651f32436e53d4155b5b7bba1386c.tar.bz2
gentoo-2-f4ec3fa4dec651f32436e53d4155b5b7bba1386c.zip
Migrated to Generation 2.
(Portage version: 2.1.1_pre3-r3)
Diffstat (limited to 'dev-java/commons-jelly')
-rw-r--r--dev-java/commons-jelly/ChangeLog8
-rw-r--r--dev-java/commons-jelly/commons-jelly-1.0-r1.ebuild75
-rw-r--r--dev-java/commons-jelly/files/digest-commons-jelly-1.0-r13
3 files changed, 85 insertions, 1 deletions
diff --git a/dev-java/commons-jelly/ChangeLog b/dev-java/commons-jelly/ChangeLog
index 32f6523f441a..2fa761cf053a 100644
--- a/dev-java/commons-jelly/ChangeLog
+++ b/dev-java/commons-jelly/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/commons-jelly
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-jelly/ChangeLog,v 1.2 2006/06/07 18:49:09 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-jelly/ChangeLog,v 1.3 2006/07/22 22:54:58 nelchael Exp $
+
+*commons-jelly-1.0-r1 (22 Jul 2006)
+
+ 22 Jul 2006; Krzysiek Pawlik <nelchael@gentoo.org>
+ +commons-jelly-1.0-r1.ebuild:
+ Migrated to Generation 2.
07 Jun 2006; Joshua Nichols <jnichols@gentoo.org>
commons-jelly-1.0.ebuild:
diff --git a/dev-java/commons-jelly/commons-jelly-1.0-r1.ebuild b/dev-java/commons-jelly/commons-jelly-1.0-r1.ebuild
new file mode 100644
index 000000000000..fd759a148c30
--- /dev/null
+++ b/dev-java/commons-jelly/commons-jelly-1.0-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-jelly/commons-jelly-1.0-r1.ebuild,v 1.1 2006/07/22 22:54:58 nelchael Exp $
+
+inherit java-pkg-2 java-ant-2 eutils
+
+MY_P="${P}-src"
+DESCRIPTION="A Java and XML based scripting and processing engine"
+HOMEPAGE="http://jakarta.apache.org/commons/jelly/"
+SRC_URI="mirror://apache/jakarta/commons/jelly/source/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~x86"
+IUSE="doc test source"
+
+RDEPEND=">=virtual/jre-1.4
+ ~dev-java/servletapi-2.3
+ =dev-java/commons-cli-1*
+ dev-java/commons-lang
+ dev-java/commons-discovery
+ dev-java/forehead
+ dev-java/jakarta-jstl
+ =dev-java/commons-jexl-1.0*
+ =dev-java/commons-beanutils-1.6*
+ dev-java/commons-collections
+ =dev-java/dom4j-1*
+ =dev-java/jaxen-1.1*
+ =dev-java/xerces-2*"
+
+DEPEND=">=virtual/jdk-1.4
+ dev-java/ant-core
+ test? (
+ dev-java/junit
+ dev-java/ant-tasks
+ dev-java/commons-logging
+ )
+ ${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # disables dependency fetching, and remove tests as a dependency of jar
+ epatch ${FILESDIR}/${P}-gentoo.patch
+
+ mkdir -p ${S}/lib
+ cd ${S}/lib
+ java-pkg_jar-from servletapi-2.3,commons-cli-1,commons-lang
+ java-pkg_jar-from commons-discovery,forehead,jakarta-jstl,commons-jexl-1.0
+ java-pkg_jar-from commons-beanutils-1.6,commons-collections
+ java-pkg_jar-from dom4j-1,jaxen-1.1,xerces-2
+
+ if use test; then
+ java-pkg_jar-from commons-logging
+ fi
+}
+
+src_compile() {
+ local antflags="-Dlibdir=lib jar"
+ use doc && antflags="${antflags} javadoc"
+ use test && antflags="${antflags} test"
+
+ eant ${antflags} || die "Ant failed"
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar ${PN}.jar
+
+ dodoc NOTICE.txt README.txt RELEASE-NOTES.txt
+
+ use doc && java-pkg_dohtml -r dist/docs/api
+ use source && java-pkg_dosrc src/java/*
+}
diff --git a/dev-java/commons-jelly/files/digest-commons-jelly-1.0-r1 b/dev-java/commons-jelly/files/digest-commons-jelly-1.0-r1
new file mode 100644
index 000000000000..c5964f16afb6
--- /dev/null
+++ b/dev-java/commons-jelly/files/digest-commons-jelly-1.0-r1
@@ -0,0 +1,3 @@
+MD5 d8c62cf844ca7ad8b6f34366eb2233c1 commons-jelly-1.0-src.tar.gz 174769
+RMD160 c273e80fb10327a833d192e89500a08302d68c58 commons-jelly-1.0-src.tar.gz 174769
+SHA256 113d606361845d08dab69f187690bf5dcfb5e9ca8fab780135898eb6d0a8d7d1 commons-jelly-1.0-src.tar.gz 174769