summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-10-02 18:15:45 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-10-02 18:15:45 +0000
commitae3b0c88d8e7d6cbf04bc4d358ba52f25d7dd9a1 (patch)
tree7dd5f0627e0632974587d452eb55c914f6dfc148 /dev-java/commons-math/commons-math-2.0.ebuild
parentStable for ppc. (diff)
downloadgentoo-2-ae3b0c88d8e7d6cbf04bc4d358ba52f25d7dd9a1.tar.gz
gentoo-2-ae3b0c88d8e7d6cbf04bc4d358ba52f25d7dd9a1.tar.bz2
gentoo-2-ae3b0c88d8e7d6cbf04bc4d358ba52f25d7dd9a1.zip
Import from Java overlay and rewrite
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/commons-math/commons-math-2.0.ebuild')
-rw-r--r--dev-java/commons-math/commons-math-2.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-java/commons-math/commons-math-2.0.ebuild b/dev-java/commons-math/commons-math-2.0.ebuild
new file mode 100644
index 000000000000..16eca6b2ed93
--- /dev/null
+++ b/dev-java/commons-math/commons-math-2.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-math/commons-math-2.0.ebuild,v 1.1 2009/10/02 18:15:45 weaver Exp $
+
+EAPI="2"
+
+WANT_ANT_TASKS="ant-junit"
+JAVA_PKG_IUSE="doc test source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Lightweight, self-contained mathematics and statistics components"
+HOMEPAGE="http://commons.apache.org/math/"
+SRC_URI="mirror://apache/commons/math/source/${P}-src.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+COMMON_DEP="
+ >=dev-java/commons-discovery-0.2
+ >=dev-java/commons-logging-1.0.3"
+
+DEPEND=">=virtual/jdk-1.5
+ >=dev-java/ant-core-1.6
+ ${COMMON_DEP}
+ test? ( dev-java/ant-junit )"
+
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/${P}-src"
+
+src_test() {
+ cd lib || die
+ java-pkg_jar-from junit
+ cd ..
+ ANT_TASKS="ant-junit" eant test
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar ${PN}.jar
+
+# use doc && java-pkg_dojavadoc dist/docs/api
+ use source && java-pkg_dosrc src/main/java/org
+}