summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSerkan Kaba <serkan@gentoo.org>2010-11-26 20:30:38 +0000
committerSerkan Kaba <serkan@gentoo.org>2010-11-26 20:30:38 +0000
commit7bd1b731df65cdd8cc6068c63876ac820189f6ae (patch)
treedda5ec039ae762aac44e4b5d948e72568a2642a6 /dev-java/commons-math/commons-math-2.1-r1.ebuild
parentstable x86, security bug 346191 (diff)
downloadgentoo-2-7bd1b731df65cdd8cc6068c63876ac820189f6ae.tar.gz
gentoo-2-7bd1b731df65cdd8cc6068c63876ac820189f6ae.tar.bz2
gentoo-2-7bd1b731df65cdd8cc6068c63876ac820189f6ae.zip
Fix empty jar when tests are not run. Reported in bug #346823 by Hendrik Iben <hiben@tzi.de>. Reenable docs.
(Portage version: 2.2.0_alpha2/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/commons-math/commons-math-2.1-r1.ebuild')
-rw-r--r--dev-java/commons-math/commons-math-2.1-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-java/commons-math/commons-math-2.1-r1.ebuild b/dev-java/commons-math/commons-math-2.1-r1.ebuild
new file mode 100644
index 000000000000..2abde21791e4
--- /dev/null
+++ b/dev-java/commons-math/commons-math-2.1-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-math/commons-math-2.1-r1.ebuild,v 1.1 2010/11/26 20:30:38 serkan Exp $
+
+EAPI="3"
+
+JAVA_PKG_IUSE="doc test source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Lightweight, self-contained mathematics and statistics components"
+HOMEPAGE="http://commons.apache.org/math/"
+SRC_URI="mirror://apache/commons/math/source/${P}-src.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.5
+ test? (
+ dev-java/ant-junit4
+ dev-java/hamcrest-core:0
+ )"
+
+RDEPEND=">=virtual/jre-1.5"
+
+S="${WORKDIR}/${P}-src"
+
+java_prepare() {
+ epatch "${FILESDIR}"/${PF}-buildfixes.patch
+}
+
+src_test() {
+ java-pkg_jar-from junit-4
+ java-pkg_jar-from hamcrest-core
+ ANT_TASKS="ant-junit4" eant -Djunit.jar=junit.jar test
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar ${PN}.jar
+
+ use doc && java-pkg_dojavadoc target/apidocs
+ use source && java-pkg_dosrc src/main/java/org
+}