summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2007-01-03 03:17:03 +0000
committerJoshua Nichols <nichoj@gentoo.org>2007-01-03 03:17:03 +0000
commit79b6c907aee139f638a510e6459a22d453955c2c (patch)
treeb54a8e47807d285b94ccb04eaded3bbc7b740265 /dev-java/ehcache
parentamd64 stable, bug 149964 (diff)
downloadgentoo-2-79b6c907aee139f638a510e6459a22d453955c2c.tar.gz
gentoo-2-79b6c907aee139f638a510e6459a22d453955c2c.tar.bz2
gentoo-2-79b6c907aee139f638a510e6459a22d453955c2c.zip
Version bump. Added as slot 1.2 because there are a few subtle API incompatibilities.
(Portage version: 2.1.2_rc4-r4)
Diffstat (limited to 'dev-java/ehcache')
-rw-r--r--dev-java/ehcache/ChangeLog10
-rw-r--r--dev-java/ehcache/ehcache-1.2.4.ebuild56
-rw-r--r--dev-java/ehcache/files/digest-ehcache-1.2.43
3 files changed, 67 insertions, 2 deletions
diff --git a/dev-java/ehcache/ChangeLog b/dev-java/ehcache/ChangeLog
index c67c9cd0cd77..1776f2535939 100644
--- a/dev-java/ehcache/ChangeLog
+++ b/dev-java/ehcache/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/ehcache
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ehcache/ChangeLog,v 1.3 2006/09/08 04:02:51 nichoj Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ehcache/ChangeLog,v 1.4 2007/01/03 03:17:03 nichoj Exp $
+
+*ehcache-1.2.4 (03 Jan 2007)
+
+ 03 Jan 2007; Joshua Nichols <nichoj@gentoo.org> +ehcache-1.2.4.ebuild:
+ Version bump. Added as slot 1.2 because there are a few subtle API
+ incompatibilities.
*ehcache-1.1-r1 (08 Sep 2006)
diff --git a/dev-java/ehcache/ehcache-1.2.4.ebuild b/dev-java/ehcache/ehcache-1.2.4.ebuild
new file mode 100644
index 000000000000..90ee8b411087
--- /dev/null
+++ b/dev-java/ehcache/ehcache-1.2.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ehcache/ehcache-1.2.4.ebuild,v 1.1 2007/01/03 03:17:03 nichoj Exp $
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Ehcache is a pure Java, fully-featured, in-process cache."
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+HOMEPAGE="http://ehcache.sourceforge.net"
+
+LICENSE="Apache-1.1"
+SLOT="1.2"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc source"
+
+COMMON_DEPEND="
+ dev-java/commons-collections
+ dev-java/concurrent-util
+ dev-java/commons-logging
+ ~dev-java/servletapi-2.4"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEPEND}"
+DEPEND=">=virtual/jdk-1.4
+ ${COMMON_DEPEND}
+ source? ( app-arch/zip )
+ >=dev-java/ant-core-1.5"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ mkdir src && cd src
+ unzip -qq ../${P}-sources.jar || die
+ rm -rf net/sf/ehcache/hibernate
+}
+
+src_compile() {
+ mkdir ${S}/classes
+ cd ${S}/src
+
+ ejavac -d ${S}/classes \
+ -classpath $(java-pkg_getjars commons-logging,commons-collections,servletapi-2.4) \
+ $(find . -name "*.java")
+
+ cd ${S}/classes
+ jar cf ${S}/${P}.jar * || die "failed to create jar"
+}
+
+src_install() {
+ java-pkg_newjar ${S}/${P}.jar
+ dodoc *.txt ehcache.xml ehcache.xsd
+ use source && java-pkg_dosrc src
+ if use doc ; then
+ unzip -qq ${P}-javadoc.zip || die
+ java-pkg_dohtml -r docs
+ fi
+}
diff --git a/dev-java/ehcache/files/digest-ehcache-1.2.4 b/dev-java/ehcache/files/digest-ehcache-1.2.4
new file mode 100644
index 000000000000..6c4d73beeffa
--- /dev/null
+++ b/dev-java/ehcache/files/digest-ehcache-1.2.4
@@ -0,0 +1,3 @@
+MD5 963cfdc7fbaa212a5227b47e733de785 ehcache-1.2.4.tgz 1330344
+RMD160 c59deec7647c2ed659de471bda3cfc721723b23a ehcache-1.2.4.tgz 1330344
+SHA256 47b5dad87d8c75773e66aef471b1b464118956f8ce3bf9ca0e0292f020a20a64 ehcache-1.2.4.tgz 1330344