summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2006-05-12 04:55:39 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2006-05-12 04:55:39 +0000
commitfc11eeceb3b68c014c148a8b7ea865b5f1d255da (patch)
treecdb2a31ae7dc950d11695643e9df3ff8078b165a /dev-java/gnu-classpath/files
parentRemoved old versions. sparc dropped because they don\'t support java at the m... (diff)
downloadgentoo-2-fc11eeceb3b68c014c148a8b7ea865b5f1d255da.tar.gz
gentoo-2-fc11eeceb3b68c014c148a8b7ea865b5f1d255da.tar.bz2
gentoo-2-fc11eeceb3b68c014c148a8b7ea865b5f1d255da.zip
Removed old versions. sparc dropped because they don\'t support java at the moment.
(Portage version: 2.1_pre10-r5) (Unsigned Manifest commit)
Diffstat (limited to 'dev-java/gnu-classpath/files')
-rw-r--r--dev-java/gnu-classpath/files/0.19-dssi.patch33
-rw-r--r--dev-java/gnu-classpath/files/0.19-dssi_data.h121
-rw-r--r--dev-java/gnu-classpath/files/digest-gnu-classpath-0.183
-rw-r--r--dev-java/gnu-classpath/files/digest-gnu-classpath-0.193
-rw-r--r--dev-java/gnu-classpath/files/digest-gnu-classpath-0.203
-rw-r--r--dev-java/gnu-classpath/files/gtk28.patch39
6 files changed, 0 insertions, 202 deletions
diff --git a/dev-java/gnu-classpath/files/0.19-dssi.patch b/dev-java/gnu-classpath/files/0.19-dssi.patch
deleted file mode 100644
index 7f8bf06d3ca9..000000000000
--- a/dev-java/gnu-classpath/files/0.19-dssi.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-Index: configure.ac
-===================================================================
-RCS file: /cvsroot/classpath/classpath/configure.ac,v
-retrieving revision 1.118
-diff -u -r1.118 configure.ac
---- configure.ac 7 Nov 2005 14:25:54 -0000 1.118
-+++ configure.ac 10 Nov 2005 10:50:23 -0000
-@@ -118,7 +118,7 @@
- dnl -----------------------------------------------------------
- dnl DSSI code (enabled by default)
- dnl -----------------------------------------------------------
--AC_ARG_ENABLE([alsa],
-+AC_ARG_ENABLE([dssi],
- [AS_HELP_STRING(--disable-dssi,compile DSSI providers (enable by --enable-dssi) [default=yes])],
- [case "${enableval}" in
- yes) COMPILE_DSSI=yes ;;
-Index: native/jni/midi-dssi/Makefile.am
-===================================================================
-RCS file: /cvsroot/classpath/classpath/native/jni/midi-dssi/Makefile.am,v
-retrieving revision 1.2
-diff -u -r1.2 Makefile.am
---- native/jni/midi-dssi/Makefile.am 23 Oct 2005 16:59:09 -0000 1.2
-+++ native/jni/midi-dssi/Makefile.am 10 Nov 2005 10:50:23 -0000
-@@ -1,7 +1,8 @@
- nativelib_LTLIBRARIES = libgjsmdssi.la
-
- libgjsmdssi_la_SOURCES = gnu_javax_sound_midi_dssi_DSSIMidiDeviceProvider.c \
--gnu_javax_sound_midi_dssi_DSSISynthesizer.c
-+ gnu_javax_sound_midi_dssi_DSSISynthesizer.c \
-+ dssi_data.h
-
- libgjsmdssi_la_LIBADD = $(top_builddir)/native/jni/classpath/jcl.lo -ljack
-
diff --git a/dev-java/gnu-classpath/files/0.19-dssi_data.h b/dev-java/gnu-classpath/files/0.19-dssi_data.h
deleted file mode 100644
index 8278f7b9e18a..000000000000
--- a/dev-java/gnu-classpath/files/0.19-dssi_data.h
+++ /dev/null
@@ -1,121 +0,0 @@
-/* dssi_data.h - DSSI data
- Copyright (C) 2005 Free Software Foundation, Inc.
-
-This file is part of GNU Classpath.
-
-GNU Classpath is free software; you can redistribute it and/or modify
-it under the terms of the GNU General Public License as published by
-the Free Software Foundation; either version 2, or (at your option)
-any later version.
-
-GNU Classpath is distributed in the hope that it will be useful, but
-WITHOUT ANY WARRANTY; without even the implied warranty of
-MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-General Public License for more details.
-
-You should have received a copy of the GNU General Public License
-along with GNU Classpath; see the file COPYING. If not, write to the
-Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
-02110-1301 USA.
-
-Linking this library statically or dynamically with other modules is
-making a combined work based on this library. Thus, the terms and
-conditions of the GNU General Public License cover the whole
-combination.
-
-As a special exception, the copyright holders of this library give you
-permission to link this library with independent modules to produce an
-executable, regardless of the license terms of these independent
-modules, and to copy and distribute the resulting executable under
-terms of your choice, provided that you also meet, for each linked
-independent module, the terms and conditions of the license of that
-module. An independent module is a module which is not derived from
-or based on this library. If you modify this library, you may extend
-this exception to your version of the library, but you are not
-obligated to do so. If you do not wish to do so, delete this
-exception statement from your version. */
-
-#include <stdlib.h>
-#include <dlfcn.h>
-#include <sys/time.h>
-#include <jni.h>
-#include <dssi.h>
-#include <jack/jack.h>
-#include <alsa/asoundlib.h>
-#include <alsa/seq.h>
-
-#include <stdio.h>
-
-#include "target_native.h"
-#include "target_native_misc.h"
-#include "../classpath/jcl.h"
-
-/* Specify the size of the circular buffer. It only needs to be big
- enough to hold the events that happen between jack callbacks (~
- 1/40th of a second). */
-#define EVENT_BUFFER_SIZE 1024
-
-/* Helper macros for going between pointers and jlongs. */
-#define JLONG_TO_PTR(T,P) ((T *)(long)P)
-#define PTR_TO_JLONG(P) ((jlong)(long)P)
-
-
-/* Every DSSI Synthesizer has one of these associated with it. The
- Java class sees it as a "long" handle. */
-
-typedef struct
-{
- /* This is a handle to the dlopen'ed .so file containing the DSSI
- synthesizer. */
- void *dlhandle;
-
- /* The function to call to get the DSS_Descriptor. */
- DSSI_Descriptor_Function fn;
-
- /* The descriptor for this synthesizer. See the dssi.h system
- header. */
- const DSSI_Descriptor *desc;
-
- /* We currently open a jack client connection for every
- synthesizer. */
- jack_client_t *jack_client;
-
- /* We currently only handle stereo jack connections. Output from
- mono synthesizers is sent to both left and right ports. */
- jack_port_t *jack_left_output_port;
- jack_port_t *jack_right_output_port;
-
- /* We use a circular buffer to hold MIDI events before processing
- them in the jack audio processing callback function. */
- snd_seq_event_t midiEventBuffer[EVENT_BUFFER_SIZE];
- int midiEventReadIndex;
- int midiEventWriteIndex;
-
- /* This is a handle the synthesizers underlying LADSPA structure.
- See the ladspa.h system header for details. */
- LADSPA_Handle plugin_handle;
-
- /* These are buffers we pass to the DSSI Synthesizer for
- filling. */
- float *left_buffer;
- float *right_buffer;
-
- /* The number of input controls for this synth. */
- unsigned control_count;
-
- /* An array of control values, control_count in length. */
- LADSPA_Data *control_values;
-
- /* A mapping of MIDI controllers to control values. There are a
- maximum of 128 MIDI controllers. */
- unsigned control_value_map[128];
-
- /* A mapping of MIDI controllers to LADSPA ports. There are a
- maximum of 128 MIDI controllers. */
- unsigned control_port_map[128];
-
- /* The sample rate. */
- jack_nframes_t sample_rate;
-
-} dssi_data;
-
diff --git a/dev-java/gnu-classpath/files/digest-gnu-classpath-0.18 b/dev-java/gnu-classpath/files/digest-gnu-classpath-0.18
deleted file mode 100644
index 2c78312eeb1e..000000000000
--- a/dev-java/gnu-classpath/files/digest-gnu-classpath-0.18
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 c0650c257aa93eafb709553f172f0bbb classpath-0.18.tar.gz 6389125
-RMD160 c4cc3ac851bba79f1b497d727c868e942f998725 classpath-0.18.tar.gz 6389125
-SHA256 f2b3962b279a1d8f98c24e39cd5d62d4e9fbf50b7b8a75e90fcf0ded822824c2 classpath-0.18.tar.gz 6389125
diff --git a/dev-java/gnu-classpath/files/digest-gnu-classpath-0.19 b/dev-java/gnu-classpath/files/digest-gnu-classpath-0.19
deleted file mode 100644
index 45605a582cf3..000000000000
--- a/dev-java/gnu-classpath/files/digest-gnu-classpath-0.19
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 0b93b1c1dd3d33ef7fb6a47dbb29e41d classpath-0.19.tar.gz 6765716
-RMD160 9336bb6694be506d29b9d672ecfddae92bd21415 classpath-0.19.tar.gz 6765716
-SHA256 154153797eae72fe4c6e22718e8b630e56317e686ca40857ed3fa9a1dd046199 classpath-0.19.tar.gz 6765716
diff --git a/dev-java/gnu-classpath/files/digest-gnu-classpath-0.20 b/dev-java/gnu-classpath/files/digest-gnu-classpath-0.20
deleted file mode 100644
index e07610e1682d..000000000000
--- a/dev-java/gnu-classpath/files/digest-gnu-classpath-0.20
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 21e34b8e8acb4f7b31296bfaf4ad560a classpath-0.20.tar.gz 7110100
-RMD160 a1fc0978c66f9d254a2224d560508bcbeb338748 classpath-0.20.tar.gz 7110100
-SHA256 6a068f70f908ee4de0ba4d7e1d5127b12ad548da371494c668966d1ff98e05a2 classpath-0.20.tar.gz 7110100
diff --git a/dev-java/gnu-classpath/files/gtk28.patch b/dev-java/gnu-classpath/files/gtk28.patch
deleted file mode 100644
index 62616827515f..000000000000
--- a/dev-java/gnu-classpath/files/gtk28.patch
+++ /dev/null
@@ -1,39 +0,0 @@
---- classpath/classpath/native/jni/gtk-peer/Makefile.am 2005/08/22 10:36:141.29
-+++ classpath/classpath/native/jni/gtk-peer/Makefile.am 2005/10/21 19:26:531.30
-@@ -54,10 +54,12 @@
- libgtkpeer_la_LIBADD = $(top_builddir)/native/jni/classpath/native_state.lo \
- $(top_builddir)/native/jni/classpath/jcl.lo
-
--AM_LDFLAGS = @CLASSPATH_MODULE@ @GTK_LIBS@ @CAIRO_LIBS@ @PANGOFT2_LIBS@ @X_LIBS@ -lXtst
-+AM_LDFLAGS = @CLASSPATH_MODULE@ @GTK_LIBS@ @CAIRO_LIBS@ @PANGOFT2_LIBS@ \
-+ @FREETYPE2_LIBS@ @X_PRE_LIBS@ @X_LIBS@ @X_EXTRA_LIBS@ -lX11 -lXtst
- AM_CPPFLAGS = @CLASSPATH_INCLUDES@
-
- # Just the WARNING_CFLAGS. We cannot use the strict flags since the gtk
- # headers contain broken prototypes (by design, see gtkitemfactory.h).
- AM_CFLAGS = @WARNING_CFLAGS@ @ERROR_CFLAGS@ \
-- @GTK_CFLAGS@ @CAIRO_CFLAGS@ @PANGOFT2_CFLAGS@
-+ @GTK_CFLAGS@ @CAIRO_CFLAGS@ @PANGOFT2_CFLAGS@ @FREETYPE2_CFLAGS@ \
-+ @X_CFLAGS@
-
---- classpath/classpath/configure.ac 2005/10/06 06:24:111.111
-+++ classpath/classpath/configure.ac 2005/10/21 19:26:531.112
-@@ -373,12 +373,17 @@
-
- if test "x${enable_gtk_cairo}" = xyes; then
- PKG_CHECK_MODULES(CAIRO, cairo >= 0.5.0)
-- PKG_CHECK_MODULES(PANGOFT2, pangoft2)
- fi
-+
-+ PKG_CHECK_MODULES(PANGOFT2, pangoft2)
-+ PKG_CHECK_MODULES(FREETYPE2, freetype2)
-+
- AC_SUBST(CAIRO_LIBS)
- AC_SUBST(CAIRO_CFLAGS)
- AC_SUBST(PANGOFT2_LIBS)
- AC_SUBST(PANGOFT2_CFLAGS)
-+ AC_SUBST(FREETYPE2_LIBS)
-+ AC_SUBST(FREETYPE2_CFLAGS)
- fi
-
- CLASSPATH_WITH_JAVAH