summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2004-09-29 21:01:53 +0000
committerThomas Matthijs <axxo@gentoo.org>2004-09-29 21:01:53 +0000
commitb348ede4735eb41feb695a3998d5633a772bcef2 (patch)
tree4f3ae85f1bce9f0276925e4aa3c5b4fe4cf3d1f1 /dev-java/ibm-jre-bin
parentThe directory needs to exist for older clients to prune the directory. (diff)
downloadgentoo-2-b348ede4735eb41feb695a3998d5633a772bcef2.tar.gz
gentoo-2-b348ede4735eb41feb695a3998d5633a772bcef2.tar.bz2
gentoo-2-b348ede4735eb41feb695a3998d5633a772bcef2.zip
Cleaned up plugin instalation, Moved some messages to the eclass, see #22395 for more information
Diffstat (limited to 'dev-java/ibm-jre-bin')
-rw-r--r--dev-java/ibm-jre-bin/ChangeLog9
-rw-r--r--dev-java/ibm-jre-bin/ibm-jre-bin-1.4.1-r1.ebuild26
-rw-r--r--dev-java/ibm-jre-bin/ibm-jre-bin-1.4.2.ebuild26
3 files changed, 30 insertions, 31 deletions
diff --git a/dev-java/ibm-jre-bin/ChangeLog b/dev-java/ibm-jre-bin/ChangeLog
index 4d24d647d7e1..8af268282c5d 100644
--- a/dev-java/ibm-jre-bin/ChangeLog
+++ b/dev-java/ibm-jre-bin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/ibm-jre-bin
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ibm-jre-bin/ChangeLog,v 1.11 2004/09/23 15:48:44 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ibm-jre-bin/ChangeLog,v 1.12 2004/09/29 20:59:12 axxo Exp $
+
+ 29 Sep 2004; Thomas Matthijs <axxo@gentoo.org>
+ ibm-jre-bin-1.4.1-r1.ebuild, ibm-jre-bin-1.4.2.ebuild:
+ Cleaned up plugin instalation, Moved some messages to the eclass, see #22395
+ for more information
+
+*ibm-jre-bin-1.4.2 (29 Sep 2004)
23 Sep 2004; Thomas Matthijs <axxo@gentoo.org> -ibm-jre-bin-1.4.1.ebuild:
prune older ebuilds
diff --git a/dev-java/ibm-jre-bin/ibm-jre-bin-1.4.1-r1.ebuild b/dev-java/ibm-jre-bin/ibm-jre-bin-1.4.1-r1.ebuild
index 0fb53ae2fd9c..9a2f3952b7f8 100644
--- a/dev-java/ibm-jre-bin/ibm-jre-bin-1.4.1-r1.ebuild
+++ b/dev-java/ibm-jre-bin/ibm-jre-bin-1.4.1-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ibm-jre-bin/ibm-jre-bin-1.4.1-r1.ebuild,v 1.10 2004/08/04 12:52:54 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ibm-jre-bin/ibm-jre-bin-1.4.1-r1.ebuild,v 1.11 2004/09/29 20:59:12 axxo Exp $
-inherit java nsplugins
+inherit java
S="${WORKDIR}/j2sdk${PV}"
DESCRIPTION="IBM Java Development Kit ${PV}"
@@ -11,7 +11,7 @@ SRC_URI="ppc?(mirror://gentoo/IBMJava2-JRE-141.ppc.tgz)
x86?(mirror://gentoo/IBMJava2-JRE-141.tgz)"
PROVIDE="virtual/jre-1.4.1
virtual/java-scheme-2"
-IUSE=""
+IUSE="mozilla"
SLOT="1.4"
LICENSE="IBM-J1.4"
KEYWORDS="ppc ~x86 ppc64"
@@ -19,7 +19,6 @@ DEPEND="virtual/libc
>=dev-java/java-config-0.2.5"
RDEPEND="${DEPEND}"
-
if use ppc; then
S=${WORKDIR}/IBMJava2-ppc-141
elif use ppc64; then
@@ -33,7 +32,7 @@ src_compile() {
}
src_install() {
- # Copy all the files to the designated directory
+ # Copy all the files to the designated directory
dodir /opt/${P}
cp -dpR ${S}/jre/* ${D}/opt/${P}/
@@ -48,16 +47,13 @@ src_install() {
< ${FILESDIR}/${P} \
> ${D}/etc/env.d/java/20${P} \
|| die "unable to install environment file"
-}
-pkg_postinst(){
- inst_plugin /opt/${P}/bin/javaplugin.so
- true
-}
-
-pkg_prerm() {
- if [ ! -z "$(java-config -J | grep ${P})" ] ; then
- ewarn "It appears you are removing your default system VM!"
- ewarn "Please run java-config -L then java-config-S to set a new system VM!"
+ if use mozilla; then
+ local plugin="libjavaplugin_oji.so"
+ if has_version '>=gcc-3*' ; then
+ plugin="libjavaplugin_ojigcc3.so"
+ fi
+ install_mozilla_plugin /opt/${P}/bin/${plugin}
fi
+
}
diff --git a/dev-java/ibm-jre-bin/ibm-jre-bin-1.4.2.ebuild b/dev-java/ibm-jre-bin/ibm-jre-bin-1.4.2.ebuild
index 168b472ea628..83ea4a46ac81 100644
--- a/dev-java/ibm-jre-bin/ibm-jre-bin-1.4.2.ebuild
+++ b/dev-java/ibm-jre-bin/ibm-jre-bin-1.4.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ibm-jre-bin/ibm-jre-bin-1.4.2.ebuild,v 1.2 2004/08/04 15:25:57 sejo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ibm-jre-bin/ibm-jre-bin-1.4.2.ebuild,v 1.3 2004/09/29 20:59:12 axxo Exp $
-inherit java nsplugins
+inherit java
S="${WORKDIR}/j2sdk${PV}"
DESCRIPTION="IBM Java Development Kit ${PV}"
@@ -11,7 +11,7 @@ SRC_URI="ppc?(mirror://gentoo/IBMJava2-JRE-142.ppc.tgz)
x86?(mirror://gentoo/IBMJava2-JRE-142.tgz)"
PROVIDE="virtual/jre-1.4.2
virtual/java-scheme-2"
-IUSE=""
+IUSE="mozilla"
SLOT="1.4"
LICENSE="IBM-J1.4"
KEYWORDS="ppc ~x86 ppc64"
@@ -19,7 +19,6 @@ DEPEND="virtual/libc
>=dev-java/java-config-0.2.5"
RDEPEND="${DEPEND}"
-
if use ppc; then
S=${WORKDIR}/IBMJava2-ppc-142
elif use ppc64; then
@@ -33,7 +32,7 @@ src_compile() {
}
src_install() {
- # Copy all the files to the designated directory
+ # Copy all the files to the designated directory
dodir /opt/${P}
cp -dpR ${S}/jre/* ${D}/opt/${P}/
@@ -48,16 +47,13 @@ src_install() {
< ${FILESDIR}/${P} \
> ${D}/etc/env.d/java/20${P} \
|| die "unable to install environment file"
-}
-pkg_postinst(){
- inst_plugin /opt/${P}/bin/javaplugin.so
- true
-}
-
-pkg_prerm() {
- if [ ! -z "$(java-config -J | grep ${P})" ] ; then
- ewarn "It appears you are removing your default system VM!"
- ewarn "Please run java-config -L then java-config-S to set a new system VM!"
+ if use mozilla; then
+ local plugin="libjavaplugin_oji.so"
+ if has_version '>=gcc-3*' ; then
+ plugin="libjavaplugin_ojigcc3.so"
+ fi
+ install_mozilla_plugin /opt/${P}/bin/${plugin}
fi
+
}